Contribute
Register

Comet Lake mITX: Z490I - i5-10400 - RX580

Joined
Mar 19, 2020
Messages
13
Motherboard
GIGABYTE Z490I AORUS ULTRA
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
yurifox's Comet Lake mITX:
Z490I • i5-10400 • RX580 • macOS Ventura • OpenCore

SystemInfo.jpg

Components​

  • Motherboard: GIGABYTE Z490I AORUS ULTRA [Amazon | NewEgg]​
    • Ethernet: Intel® I225-V​
    • Audio: Realtek ALC1220​
  • CPU: Intel Core i5-10400 (10th gen | Comet Lake) [Amazon | NewEgg]
  • GPU: Sapphire AMD Radeon RX 580 8GB [Amazon | NewEgg]
  • CPU Cooler: Deepcool GAMMAXX 300 [Amazon | NewEgg]
  • SSD: Samsung 970 EVO 500GB [Amazon | NewEgg]
  • RAM: G.Skill DDR4 32GB (2x16GB) 3200Mhz Ripjaws V (F4-3200C16D-32GVK) [Amazon | NewEgg]
  • Power Supplies: Corsair SF600 600W [Amazon | NewEgg]
  • Case: Cooler Master MasterBox NR200P Black (MCB-NR200P-KGNN-S00) [Amazon | NewEgg]
  • Software:
    • macOS Ventura 13.0.1 (22A400)
    • OpenCore 0.8.8

Comments​

I decided to build a hackintosh just for fun, a couple of years ago. It was a PC with the cheapest supporting components I found in the Buyer's guide. Then I compared this build with my old MacBook Pro 13" 2015 and this build was much better, so I decided to migrate to a hackintosh build.
Now I'm using this build for work, I'm a software engineer. At this point, I have updated all components except the SSD.

Benchmarks​

CPU: https://browser.geekbench.com/v5/cpu/16606900
CPU.png

Metal: https://browser.geekbench.com/v5/compute/5298730
Metal.png

OpenCL: https://browser.geekbench.com/v5/compute/5298730
OpenCL.png

OpenGL (Unigine Heaven):
Ultra Quality, 720p:
UngineHeaven720p.png
Ultra Quality, 1080p:
UngineHeaven1080p.png
Ultra Quality, 1440p:
UngineHeaven1440p.png

Known issues:​

  • AirDrop is not working;
  • [Solved] App Store is not working;
  • [Solved] Wi-Fi is not working;

Updates:​

  • [Nov 28, 2022] Upgraded to macOS Ventura. I had an issue with it, so you can check this thread;
  • [Dec 8, 2022] Added Unigine Heaven benchmarks;
  • [Dec 15, 2022] Found a new issue with App Store. Apps are not downloading, installing or updating;
  • [Jan 5, 2023] Fixed Wi-Fi for my build, updated Open Core to 0.8.8 and updated Kexts to latest versions;
 

Attachments

  • EFI.zip
    92.6 MB · Views: 23
Last edited:
Joined
Mar 19, 2020
Messages
13
Motherboard
GIGABYTE Z490I AORUS ULTRA
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I faced an App Store issue. I couldn't download, install or update any app from the App Store. I found this documentation and followed the steps:
1. Using Hackintool I check my "Network Interfaces". It was "en3" instead "en0";
2. I followed "Fixing ROM" section and change ROM in my config.plist. Go to `System Preferences -> Network -> Ethernet -> Advanced -> Hardware -> MAC Address`. I copied my MAC address and added this to the config without colons :)).
3. I used Terminal to reset the network interface and run the following:
sudo rm /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
sudo rm /Library/Preferences/SystemConfiguration/preferences.plist
4. Once done, I reboot and checked again. The App Store is working correctly
 
Last edited:
Top