Clover, Yosemite, XFX 6870, Crashing Apps with video playback

Not open for further replies.
May 16, 2012
3.39 GHz Intel Core i5
AMD Radeon HD 6870 1024 MB
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS

I've tinkering with Clover to install Yosemite.
Now I have almost everything working. Then I noticed a problem.

Whenever I open any app that shows a video, the app crashes almost every time. :crazy:

Here's a video showing the problem:

The funny thing is, when I clicked "Stop Recording", Quicktime crashed. When I tried to export the recorded video, it crashed too. Only when I clicked "Save As", it didn't crash.

I'm using Duckweed FB.

Any clue?

Note: It was working perfectly for a long time in Mavericks, so I doubt that it's a hardware issue.


  • Screen Shot 2014-10-24 at 4.24.09 AM.png
    Screen Shot 2014-10-24 at 4.24.09 AM.png
    86.4 KB · Views: 141
I've found out something interesting...

I ran the System Preferences App with Terminal command:
open /Applications/System\\ Preferences

My goal was to see if there's useful debug information.

As you saw from the video above, the crash happens "most" of the time, not always.

So, here's the output when the crash happens:
Last login: Fri Oct 24 05:20:05 on ttys000
Ahmeds-iMac:~ cdes$ /Applications/System\\ Preferences ; exit;
2014-10-24 05:20:12.000 System Preferences[1669:598748] Garbage Collection enabled !
GVA info: Successfully connected to the Intel plugin, offline Gen6 
Illegal instruction: 4

[Process completed]

And here's when it opens without crashing:
Last login: Fri Oct 24 05:20:42 on ttys001
Ahmeds-iMac:~ cdes$ /Applications/System\\ Preferences ; exit;
2014-10-24 05:20:54.532 System Preferences[1696:605757] Garbage Collection enabled !
System Preferences(1696,0x11055a000) malloc: *** auto malloc[1696]: error: GC operation on unregistered thread. Thread registered implicitly. Break on auto_zone_thread_registration_error() to debug.
GVA info: Successfully connected to the Intel plugin, offline Gen6 

[Process completed]

It's strange and confusing me... why is it trying to connect to Intel plugin
Changed FB to Gibba: still the same.
Removed all AppleIntelHD* kexts: still the same.
Solved :clap:

The issue was with me using the SMBIOS of iMac, when I switched to MacPro 3,1 the issue is gone.
I have the same card and have just changed over to Clover. Did you need to do anything to get it to work? If I boot off a Clover USB, it works fine but shows up as 6xxx. If I try to boot off the HDD boot loader, i get graphics errors on the login screen (only shows the upper corner of each monitor)

I have inject ati set in Configurator, but doesn't seem to help

if you have intel GPU enabled, make sure it is IGPU not GFX0 on DSDT/SSDT. you can check it with ioregistry.

i found a lot of problems using intel GPU with ATI Cards (together) but i solve it when i rename GFX0 devices (the intel GPU) to IGPU.

ATI could be renamed from PEG0 to GFX0 or not, in my case there is no diference.

when you chose to change smbios to mac3,1 you define that IGPU will be ignored. but you can use imac14,2 or any other definition that could be close to your machine if you respect the names of the devices that profile expected. for instance, imac14,2 works fine if it has IGPU and GFX0 devices or IGPU and PEG0 devices, but it will not work well with GFX0 and PEG0, or just GFX0.

I have IGPU enabled for airport, 2x R9 280X (PEG0 and PEG1) for final cut x and a single monitor plugged on display port of PEG0. no crashes at all. but on Z97X-SLI the default is intel GPU named as GFX0, so you need to rename it on clover or DSDT/SSDT.
Not open for further replies.