Contribute
Register

Clover theme defaults back to Bootcamp theme no matter what

Joined
Oct 21, 2013
Messages
298
Motherboard
Gigabyte GA-Z270X-Gaming K5
CPU
i7-7700K
Graphics
GTX 1070
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
Can someone please help me? I'm getting very annoyed with this issue. Clover keeps defaulting back to the Bootcamp theme. Doesn't matter if I use Clover Configurator to change themes or the Clover settings in the OS X System Preferences options, OR manually do it in the config.plist file. It simply will not stay on the theme I choose.
 
Joined
Dec 2, 2014
Messages
11
Motherboard
Gigabyte GA-Z97MX-GAMING 5
CPU
Haswell Devil's Canyon i7-4790K
Graphics
CPU Graphics at the moment =/
Mac
MacBook Pro
Classic Mac
Mobile Phone
Android
Delete all other themes in your EFI partition
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Can someone please help me? I'm getting very annoyed with this issue. Clover keeps defaulting back to the Bootcamp theme. Doesn't matter if I use Clover Configurator to change themes or the Clover settings in the OS X System Preferences options, OR manually do it in the config.plist file. It simply will not stay on the theme I choose.
Check your Clover bootlog.
 
Joined
Oct 21, 2013
Messages
298
Motherboard
Gigabyte GA-Z270X-Gaming K5
CPU
i7-7700K
Graphics
GTX 1070
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
Check your Clover bootlog.
Didn't check the log and fixed my issue. Here's what happened...

It seems the config file would usually keep my settings, while the Clover settings within OS X System Preferences would default back to the bootcamp theme. So, after trying seriously everything I could think of besides what fixed it, I went to EFI/CLOVER/themes/bootcamp and renamed theme.plist to simply just theme so it couldn't be read because I read the Clover Wiki and found out that doing so kind of disables the settings for the bootcamp theme from being read from the Clover settings in System Preferences, or something like that.

It works, it's good enough for me. Thanks for the replies, guys.

By the way, how do you check the Clover log? I don't see it. Checked all of the folders on the EFI/CLOVER partition.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Didn't check the log and fixed my issue. Here's what happened...

It seems the config file would usually keep my settings, while the Clover settings within OS X System Preferences would default back to the bootcamp theme. So, after trying seriously everything I could think of besides what fixed it, I went to EFI/CLOVER/themes/bootcamp and renamed theme.plist to simply just theme so it couldn't be read because I read the Clover Wiki and found out that doing so kind of disables the settings for the bootcamp theme from being read from the Clover settings in System Preferences, or something like that.
The correct file name is 'theme.plist'. Keep in mind Finder can play tricks on you if you have it set to hide file extensions. See Finder->Preferences->Advanced.

By the way, how do you check the Clover log? I don't see it. Checked all of the folders on the EFI/CLOVER partition.
If you installed the "RC scripts" when you installed Clover, it is available from Console.app.

It is also available from Terminal with 'bdmesg'.

It is also available from ioreg, if you know how to extract it (both the RC scripts and bdmesg read it from ioreg and write it to a file/stdout).
 
Joined
Oct 21, 2013
Messages
298
Motherboard
Gigabyte GA-Z270X-Gaming K5
CPU
i7-7700K
Graphics
GTX 1070
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
The correct file name is 'theme.plist'. Keep in mind Finder can play tricks on you if you have it set to hide file extensions. See Finder->Preferences->Advanced.



If you installed the "RC scripts" when you installed Clover, it is available from Console.app.

It is also available from Terminal with 'bdmesg'.

It is also available from ioreg, if you know how to extract it (both the RC scripts and bdmesg read it from ioreg and write it to a file/stdout).
Yes I know it's proper name is 'theme.plist', that's my very reason for naming it otherwise. I never hide file extensions, that's a true newb feature. Also, I think I installed the RC scripts, but can't be positive.

After running Console.app, here is what is shown in the log, if I am reading the correct one...

-------------------------------DATE: 2016-01-31 TIME: 19:26:33
-------------------------------
0:100 0:100 MemLog inited, TSC freq: 2693885692
0:100 0:000
0:100 0:000 Now is 1.2.2016, 0:26:20 (GMT+2047)
0:100 0:000 Starting Clover rev 3333 on HPQ EFI
0:100 0:000 SelfDevicePath=PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(1,GPT,965521EE-43E7-48B2-A731-5B861917DFD2,0x28,0x64000) @B995D898
0:100 0:000 SelfDirPath = \EFI\Boot
0:100 0:000 Total Memory Slots Count = 2
0:100 0:000 Type 17 Index = 0
0:100 0:000 SmbiosTable.Type17->Speed = 1333MHz
0:100 0:000 SmbiosTable.Type17->Size = 4096MB
0:100 0:000 SmbiosTable.Type17->Bank/Device = BANK 0 Bottom-Slot 1(top)
0:100 0:000 Type 17 Index = 1
0:100 0:000 SmbiosTable.Type17->Speed = 1333MHz
0:100 0:000 SmbiosTable.Type17->Size = 4096MB
0:100 0:000 SmbiosTable.Type17->Bank/Device = BANK 2 Bottom-Slot 2(under)
0:100 0:000 Boot status=0
0:100 0:000 Clover revision: 3333 running on HP ProBook 4530s
0:100 0:000 ... with board 167C
0:100 0:000 CPU Vendor = 756E6547 Model=206A7
0:100 0:000 The CPU supported turbo
0:100 0:000 BrandString = Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz
0:100 0:000 MSR 0xE2 before patch 1E008404
0:100 0:000 MSR 0xE2 is locked, PM patches will be turned on
0:100 0:000 MSR 0xE4 00020414
0:100 0:000 MSR 0xCE 00000800_60011B00
0:100 0:000 non-usable FLEX_RATIO = 10000
0:100 0:000 corrected FLEX_RATIO = 0
0:100 0:000 MSR 0x1B0 00000000
0:100 0:000 FSBFrequency=100MHz DMIvalue=100000kHz
0:100 0:000 Corrected FSBFrequency=100MHz
0:100 0:000 Vendor/Model/Stepping: 0x756E6547/0x2A/0x7
0:100 0:000 Family/ExtFamily: 0x6/0x0
0:100 0:000 MaxDiv/MinDiv: 27.0/8
0:100 0:000 Turbo: 32/32/32/34
0:100 0:000 Features: 0xBFEBFBFF
0:100 0:000 Threads: 4
0:100 0:000 Cores: 2
0:100 0:000 FSB: 100 MHz
0:100 0:000 CPU: 2700 MHz
0:100 0:000 TSC: 2700 MHz
0:100 0:000 PIS: 400 MHz
0:100 0:000 PCI (00|00:00.00) : 8086 0104 class=060000
0:100 0:000 PCI (00|00:02.00) : 8086 0126 class=030000
0:100 0:000 Found GFX model=Intel HD Graphics 3000
0:100 0:000 PCI (00|00:16.00) : 8086 1C3A class=078000
0:100 0:000 PCI (00|00:16.01) : FFFF FFFF class=FFFFFF
0:100 0:000 PCI (00|00:1A.00) : 8086 1C2D class=0C0320
0:100 0:000 PCI (00|00:1B.00) : 8086 1C20 class=040300
0:100 0:000 PCI (00|00:1C.00) : 8086 1C10 class=060400
0:100 0:000 PCI (00|00:1C.01) : 8086 1C12 class=060400
0:100 0:000 PCI (00|00:1C.02) : 8086 1C14 class=060400
0:100 0:000 PCI (00|23:00.00) : 197B 2392 class=088000
0:100 0:000 PCI (00|23:00.02) : 197B 2391 class=080501
0:100 0:000 PCI (00|23:00.03) : 197B 2393 class=088000
0:100 0:000 PCI (00|23:00.04) : FFFF FFFF class=FFFFFF
0:100 0:000 PCI (00|00:1C.03) : 8086 1C16 class=060400
0:100 0:000 PCI (00|24:00.00) : 168C 002B class=028000
0:100 0:000 PCI (00|00:1C.05) : 8086 1C1A class=060400
0:100 0:000 PCI (00|25:00.00) : 10EC 8168 class=020000
0:100 0:000 LAN 0, Vendor=10EC, MMIO=2000
0:100 0:000 PCI (00|00:1C.07) : 8086 1C1E class=060400
0:101 0:000 PCI (00|26:00.00) : 1033 0194 class=0C0330
0:101 0:000 PCI (00|00:1D.00) : 8086 1C26 class=0C0320
0:101 0:000 PCI (00|00:1F.00) : 8086 1C49 class=060100
0:101 0:000 PCI (00|00:1F.02) : 8086 1C03 class=010601
0:101 0:000 PCI (00|00:1F.06) : FFFF FFFF class=FFFFFF
0:101 0:000 Clover load options size = 0 bytes
0:103 0:002 Using OEM config.plist at path: EFI\CLOVER\config.plist
0:104 0:000 EFI\CLOVER\config.plist loaded: Success
0:105 0:001 Found theme directory: Yosemite
0:106 0:000 Found theme directory: Yosemite S
0:109 0:003 Found theme directory: applestyle
0:111 0:001 Found theme directory: BGM
0:114 0:002 Found theme directory: BGM256
0:117 0:002 Found theme directory: black_green
0:118 0:001 Found theme directory: bluemac
0:119 0:001 Found theme directory: bootcamp - bad theme because theme.plist can't be load
0:120 0:000 Found theme directory: chrome
0:122 0:001 Found theme directory: CloverX
0:123 0:001 Found theme directory: dawn
0:124 0:001 Found theme directory: embedded
0:125 0:000 Found theme directory: gold_clover
0:126 0:001 Found theme directory: iclover
0:127 0:001 Found theme directory: ios7
0:128 0:001 Found theme directory: magnifico
0:129 0:000 Found theme directory: metal
0:130 0:001 Found theme directory: mrengles
0:131 0:001 Found theme directory: orange
0:132 0:000 Found theme directory: os_box
0:133 0:001 Found theme directory: os_one
0:135 0:001 Found theme directory: Shield
0:137 0:002 Found theme directory: sketched
0:139 0:001 Found theme directory: Space
0:141 0:001 Found theme directory: steampunkblack
0:142 0:001 Found theme directory: thinkpad
0:142 0:000 Loading early settings
0:142 0:000 timeout set to 4
0:142 0:000 Custom boot CUSTOM_BOOT_DISABLED (0x0)
0:142 0:000 KextsToPatch: 13 requested
0:142 0:000 KextsToPatch 0: AppleHDA (AppleHDA Patch 10.11) Kext bin patch, data len: 4
0:142 0:000 KextsToPatch 1: IOAHCIBlockStorage (Enable Trim on SSD) Kext bin patch, data len: 9
0:142 0:000 KextsToPatch 2: AppleUSBXHCI (USB 3.0 Patch MSI or pin interrupts #2) Kext bin patch, data len: 8
0:142 0:000 KextsToPatch 3: AppleUSBXHCI (USB 3.0 Disable XHCI 1.0 check 10.10) Kext bin patch, data len: 11
0:142 0:000 KextsToPatch 4: AppleIntelSNBGraphicsFB (Patch HDMI Audio HD3000 (disable this if you use VGA patch)) Kext bin patch, data len: 12
0:142 0:000 KextsToPatch 5: AppleHDA (IDT 76D1) Kext bin patch, data len: 4
0:142 0:000 KextsToPatch 6: AppleUSBXHCI (USB 3.0 Disable Intel USB3 controller check 10.9) Kext bin patch, data len: 9
0:142 0:000 KextsToPatch 7: AppleUSBXHCI (USB 3.0 Enable PCI power management) Kext bin patch, data len: 9
0:143 0:000 KextsToPatch 8: AppleUSBXHCI (USB 3.0 Patch MSI or pin interrupts #1) Kext bin patch, data len: 7
0:143 0:000 KextsToPatch 9: disable:AppleIntelSNBGraphFB (Patch VGA port HD3000 (disable this if you use HDMI)) Kext bin patch, data len: 60
0:143 0:000 KextsToPatch 10: IOGraphicsFamily (Second Stage patch 10.10) Kext bin patch, data len: 5
0:143 0:000 KextsToPatch 11: AppleUSBXHCI (USB 3.0 Disable XHCI 1.0 check 10.9) Kext bin patch, data len: 4
0:143 0:000 KextsToPatch 12: AppleUSBXHCI (USB 3.0 Disable Intel USB3 controller check 10.10) Kext bin patch, data len: 9
0:143 0:000 Default theme: Yosemite S
0:143 0:000 ** Warning: unknown custom entry Type 'Other'
0:143 0:000 LoadDrivers() start
0:144 0:001 Loading FSInject-64.efi status=Success
0:146 0:001 Loading HFSPlus.efi status=Success
0:147 0:001 - driver needs connecting
0:147 0:000 Loading HPFanReset.efi status=Success
0:238 0:091 HPFanReset: successfully set fan control to BIOS mode.
0:238 0:000 Loading OsxAptioFixDrv-64.efi status=Success
0:240 0:001 Loading OsxFatBinaryDrv-64.efi status=Success
0:241 0:000 Loading EmuVariableUefi-64.efi status=Success
0:242 0:000 EmuVariableUefi Initialize: VariableCommonInitialize = Success, orig services stored, install gEmuVariableControlProtocolGuid = Success
0:243 0:001 1 drivers needs connecting ...
0:243 0:000 PlatformDriverOverrideProtocol not found. Installing ... Success
0:243 0:000 HFS+ driver loaded
0:243 0:000 Searching for invalid DiskIo BY_DRIVER connects:
0:243 0:000 - Handle B995D618 with DiskIo, is Partition, no Fs, BY_DRIVER Agent: BA768618, Disconnect: Success
0:243 0:000 - Handle B995D418 with DiskIo, is Partition, no Fs, BY_DRIVER Agent: BA768618, Disconnect: Success
0:498 0:254 LoadDrivers() end
0:498 0:000 EmuVariable InstallEmulation: orig vars copied, emu.var.services installed, CreateEvent VirtualAddressChange = Success, CreateEvent ExitBootServices = Success, set Status=Success
0:498 0:000 SetScreenResolution: 1920x1080 - not found!
0:498 0:000 SetMaxResolution: found best mode 0: 1024x768
0:498 0:000 - already set
0:498 0:000 Console modes reported: 4, available modes:
0:498 0:000 Mode 1: 80x25 (current mode)
0:498 0:000 Mode 3: 120x36
0:498 0:000 Mode 4: 128x40
0:498 0:000 reinit: self device path=PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(1,GPT,965521EE-43E7-48B2-A731-5B861917DFD2,0x28,0x64000)
0:500 0:001 ScanSPD() start
0:501 0:000 ScanSPD() end
0:501 0:000 Get Acpi Tables List from RSDT:
0:501 0:000 Found table: FACP 167C len=244
0:501 0:000 Found table: HPET 167C len=56
0:501 0:000 Found table: APIC 167C len=188
0:501 0:000 Found table: MCFG 167C len=60
0:501 0:000 Found table: ASF! 167C len=165
0:501 0:000 Found table: SSDT SataAhci len=643
0:501 0:000 Found table: SSDT PtidDevc len=1162
0:501 0:000 Found table: SLIC SLIC-MPC len=374
0:501 0:000 Found table: SSDT Cpu0Ist len=2064
0:501 0:000 Found table: SSDT CpuPm len=2481
0:501 0:000 Found table: DMAR SNB len=232
0:501 0:000 Calibrated TSC frequency =2693885692 =2693MHz
0:502 0:000 Loading main settings
0:502 0:000 Dropping 1 tables
0:502 0:000 Drop table 0 signature="DMAR" (52414D44)
0:502 0:000 set table: 52414D44, 0 to drop: true
0:502 0:000
0:502 0:000 Config set ChassisType=0x8
0:504 0:002 found 4 volumes with blockIO
0:504 0:000 0. Volume:
0:504 0:000 PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)
0:504 0:000 1. Volume:
0:505 0:000 PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(1,GPT,965521EE-43E7-48B2-A731-5B861917DFD2,0x28,0x64000)
0:505 0:000 Result of bootcode detection: bootable unknown (legacy)
0:505 0:000 This is SelfVolume !!
0:505 0:000 2. Volume:
0:505 0:000 PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(2,GPT,4C2F28E2-29A8-48B6-8432-64E7BFD9FDD9,0x64028,0x3A1EC0C0)
0:506 0:000 3. Volume:
0:506 0:000 PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(3,GPT,57EE5DAC-14C6-4909-A887-7848A3BE0E89,0x3A2500E8,0x135F20)
0:510 0:003 Loading nvram.plist from Vol 'Macintosh HD' - loaded, size=1308
0:510 0:000 PutNvramPlistToRtVars ...
0:510 0:000 Adding Key: Clover.BackupDirOnDestVol: Size = 2, Data: 4E 6F
0:510 0:000 Adding Key: Clover.KeepBackupLimit: Size = 1, Data: 30
0:510 0:000 Adding Key: Clover.Theme: Size = 10, Data: 59 6F 73 65 6D 69 74 65 20 53
0:510 0:000 Skipping EmuVariableUefiPresent
0:510 0:000 Adding Key: IORegistryCurrentSleepMode: Size = 1, Data: 11
0:510 0:000 Skipping OsxAptioFixDrv-RelocBase
0:510 0:000 Adding Key: SystemAudioVolume: Size = 1, Data: 17
0:510 0:000 Adding Key: SystemAudioVolumeDB: Size = 1, Data: F4
0:510 0:000 Adding Key: backlight-level: Size = 2, Data: 10 07
0:510 0:000 Adding Key: bluetoothActiveControllerInfo: Size = 16, Data: 98 21 5C 0A 00 00 00 00 13 1A 00 02 72 CE 12 73
0:510 0:000 Adding Key: boot-gamma: Size = 50, Data: 59 08 00 00 28 00 00 00 00 00 00 00 32 00 00 00 00 00 00 00 02 00 80 80 80 80 81 81 80 80 02 00 80 80 80 80 81 81 80 80 02 00 80 80 80 80 81 81 80 80
0:511 0:000 Adding Key: bootercfg: Size = 2, Data: 28 00
0:511 0:000 Adding Key: csr-active-config: Size = 4, Data: 67 00 00 00
0:511 0:000 Adding Key: fmm-computer-name: Size = 11, Data: 4D 61 63 42 6F 6F 6B 20 50 72 6F
0:511 0:000 Adding Key: intel-backlight-level: Size = 4, Data: 00 04 00 00
0:511 0:000 Adding Key: platform-uuid: Size = 16, Data: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0:511 0:000 Adding Key: prev-lang:kbd: Size = 4, Data: 65 6E 3A 30
0:511 0:000 Adding Key: security-mode: String: Size = 4, Val = 'none'
0:511 0:000 Using theme 'Yosemite S' (EFI\CLOVER\themes\Yosemite S)
0:511 0:000 theme Yosemite S defined in NVRAM found and theme.plist parsed
0:511 0:000 OS main and drive as badge
0:522 0:010 Choosing theme Yosemite S
0:522 0:000 Custom entries start
0:522 0:000 Custom entry 0 skipped because it is disabled.
0:522 0:000 Custom entries finish
0:522 0:000 Scanning loaders...
0:522 0:000 0: 'Whole Disc Boot' no file system
0:522 0:000 1: 'EFI'
0:570 0:048 2: 'Macintosh HD'
0:572 0:002 AddLoaderEntry for Volume Name=Macintosh HD
0:573 0:000 Not match custom entry 0: Type: not match
0:575 0:002 Check if volume Is Hibernated:
0:575 0:000 Check sleep image 'by signature':
0:580 0:004 read prefs \Library\Preferences\SystemConfiguration\com.apple.PowerManagement.plist status=Success
0:580 0:000 SleepImage name from pref: ImageVolume = 'Macintosh HD', ImageName = '\private\var\vm\sleepimage'
0:582 0:001 Reading first 512 bytes of sleepimage ...
0:583 0:000 OurBlockIoRead: Lba=514EF8, Offset=A29DF000 (BlockSize=512)
0:583 0:000 sig lion: 6E006F00
0:583 0:000 sig snow: 6F004C00
0:583 0:000 no valid sleep image offset was found
0:583 0:000 OurBlockIoRead: Lba=4FE2A8, Offset=9FC55000 (BlockSize=512)
0:583 0:000 sig lion: 124E0000
0:583 0:000 sig snow: 924E0000
0:583 0:000 no valid sleep image offset was found
0:584 0:000 OurBlockIoRead: Lba=4FD828, Offset=9FB05000 (BlockSize=512)
0:584 0:000 sig lion: 2E007800
0:584 0:000 sig snow: 4D002E00
0:584 0:000 no valid sleep image offset was found
0:584 0:000 Reading completed -> Success
0:584 0:000 sleepimage offset could not be acquired
0:584 0:000 hibernated: no - sign
0:588 0:004 Icon 17 (icons\vol_internal_hfs.icns) not found
0:588 0:000 Theme path EFI\CLOVER\themes\Yosemite S, ThemeDir=B92B6120
0:664 0:075 3: 'Recovery HD'
0:664 0:000 AddLoaderEntry for Volume Name=Recovery HD
0:664 0:000 Not match custom entry 0: Type: not match
0:742 0:077 Custom legacy start
0:742 0:000 Custom legacy end
0:742 0:000 Scanning legacy ...
0:742 0:000 0: 'Whole Disc Boot' (legacy) not legacy
0:742 0:000 1: 'EFI' (legacy) not legacy
0:742 0:000 2: 'Macintosh HD' (legacy) not legacy
0:742 0:000 3: 'Recovery HD' (legacy) not legacy
0:742 0:000 Custom tool start
0:742 0:000 Custom tool end
0:744 0:001 found tool \EFI\CLOVER\tools\Shell64U.efi
0:744 0:000 Checking EFI partition Volume 1 for Clover
0:744 0:000 Found Clover
0:745 0:001 EmuVariable UninstallEmulation: CloseEvent = Success, original var services restored
0:746 0:001 EmuVariable InstallEmulation: orig vars copied, emu.var.services installed, CreateEvent VirtualAddressChange = Success, CreateEvent ExitBootServices = Success, set Status=Success
0:750 0:003 GetEfiBootDeviceFromNvram: efi-boot-device-data not found
0:750 0:000 EfiBootVolume not found
0:750 0:000 found entry 0. 'Boot Mac OS X from Macintosh HD', Volume 'Macintosh HD', DevicePath 'PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(2,GPT,4C2F28E2-29A8-48B6-8432-64E7BFD9FDD9,0x64028,0x3A1EC0C0)\System\Library\CoreServices\boot.efi'
0:750 0:000 EmuVariable UninstallEmulation: CloseEvent = Success, original var services restored
0:750 0:000 DefaultIndex=0 and MainMenu.EntryCount=4
1:311 0:560 GUI ready
6:318 5:006 StartLoader() start
6:318 0:000 Entry->Settings: <null string>
6:318 0:000 Finally: Bus=99773kHz CPU=2694MHz
6:318 0:000 Kernel and Kext Patches at B73272B0:
6:318 0:000 Allowed: y
6:318 0:000 Debug: n
6:318 0:000 KernelCpu: n
6:318 0:000 Lapic: n
6:318 0:000 Haswell-E: n
6:318 0:000 AICPUPM: y
6:318 0:000 AppleRTC: y
6:318 0:000 KernelPm: n
6:318 0:000 FakeCPUID: 0x0
6:318 0:000 ATIController: null
6:318 0:000 ATIDataLength: 0
6:318 0:000 0 Kexts to load
6:318 0:000 13 Kexts to patch
6:318 0:000 KextPatch[0]: 4 bytes, AppleHDA
6:318 0:000 KextPatch[1]: 9 bytes, IOAHCIBlockStorage
6:318 0:000 KextPatch[2]: 8 bytes, AppleUSBXHCI
6:318 0:000 KextPatch[3]: 11 bytes, AppleUSBXHCI
6:318 0:000 KextPatch[4]: 12 bytes, AppleIntelSNBGraphicsFB
6:318 0:000 KextPatch[5]: 4 bytes, AppleHDA
6:318 0:000 KextPatch[6]: 9 bytes, AppleUSBXHCI
6:318 0:000 KextPatch[7]: 9 bytes, AppleUSBXHCI
6:318 0:000 KextPatch[8]: 7 bytes, AppleUSBXHCI
6:318 0:000 KextPatch[9]: 60 bytes, disable:AppleIntelSNBGraphFB
6:318 0:000 KextPatch[10]: 5 bytes, IOGraphicsFamily
6:318 0:000 KextPatch[11]: 4 bytes, AppleUSBXHCI
6:318 0:000 KextPatch[12]: 9 bytes, AppleUSBXHCI
6:318 0:000 Loading boot.efi status=Success
6:405 0:087 GetOSVersion: : 10.10.5
6:405 0:000 EmuVariable InstallEmulation: orig vars copied, emu.var.services installed, CreateEvent VirtualAddressChange = Success, CreateEvent ExitBootServices = Success, set Status=Success
6:408 0:003 insert table 9 for dev 0:0
6:408 0:000 insert table 9 for dev 0:0
6:409 0:000 Trusting SMBIOS...
6:409 0:000 Detected alternating SMBIOS channel banks
6:409 0:000 Channels: 2
6:409 0:000 Interleave: 0 2 1 3 4 6 5 7 8 10 9 11 12 14 13 15 16 18 17 19 20 22 21 23
6:409 0:000 partNum=HMT351S6BFR8C-H9
6:409 0:000 SMBIOS Type 17 Index = 0 => 0 0:
6:409 0:000 BANK0 DIMM0 1333MHz 4096MB
6:409 0:000 mTotalSystemMemory = 4096
6:409 0:000 partNum=HMT351S6CFR8C-PB
6:410 0:000 SMBIOS Type 17 Index = 1 => 1 2:
6:410 0:000 BANK1 DIMM0 1333MHz 4096MB
6:410 0:000 mTotalSystemMemory = 8192
6:410 0:000 NumberOfMemoryDevices = 2
6:410 0:000 Type20[0]->End = 0x3FFFFF, Type17[0] = 0x1000
6:410 0:000 Type20[1]->End = 0x7FFFFF, Type17[1] = 0x3000
6:410 0:000 Table 131 is present, CPUType=35
6:410 0:000 Change to: 703
6:410 0:000 RSDT 0xBCFFE0AC
6:410 0:000 FADT from RSDT: 0xBCFFC000
6:410 0:000 XSDT 0xBCFFE120
6:410 0:000 FADT from XSDT: 0xBCFFC000
6:410 0:000 Xsdt reallocation done
6:410 0:000 old FADT length=F4
6:410 0:000 Found OperationRegion(GNVS, SystemMemory, BCFBEB98, ...)
6:410 0:000 Found OperationRegion(ASMA, SystemMemory, BCFBC018, ...)
6:410 0:000 Found OperationRegion(AF10, SystemMemory, BCFBE018, ...)
6:410 0:000 Found OperationRegion(HPDF, SystemMemory, BCFBFE18, ...)
6:410 0:000 Found OperationRegion(HPD2, SystemMemory, BCE4CF18, ...)
6:410 0:000 Found OperationRegion(HPBR, SystemMemory, BCFBBF18, ...)
6:410 0:000 Found OperationRegion(MCHT, SystemMemory, FED10000, ...)
6:410 0:000 Found OperationRegion(RCRB, SystemMemory, FED1C000, ...)
6:410 0:000 Found OperationRegion(TMMB, SystemMemory, FED40000, ...)
6:410 0:000 DSDT found in Clover volume OEM folder: EFI\CLOVER\ACPI\patched\DSDT.aml
6:412 0:001 Apply DsdtFixMask=0x00000000 old way
6:412 0:000 drop _DSM mask=0x0000
6:412 0:000 ========= Auto patch DSDT Starting ========
6:412 0:000 VideoCard devID=0x1268086
6:412 0:000 DisplayADR1[0] = 0x20000, DisplayADR2[0] = 0xFFFE
6:412 0:000 USBADR[0] = 0x1A0000 and PCIe = 0xFFFE
6:422 0:010 Found Airport Atheros at 0x1C0003, 0x0, DeviceID=0x002B
6:423 0:000 USBADR[1] = 0x1C0007 and PCIe = 0x0
6:423 0:000 USBADR[2] = 0x1D0000 and PCIe = 0xFFFE
6:423 0:000 first CPU found at 1072 offset 1075
6:423 0:000 score candidate at 106E
6:423 0:000 score inserted in acpi_cpu_score _PR_
6:423 0:000 Found ACPI CPU: CPU0 And CPU1 And CPU2 And CPU3 And CPU4 And CPU5 And CPU6 And CPU7
within the score: _PR_
6:424 0:001 ========= Auto patch DSDT Finished ========
6:424 0:000 Drop tables from Xsdt, SIGN=DMAR TableID=SNB Length=232
6:424 0:000 Xsdt has tables count=11
6:424 0:000 Table: DMAR SNB 232 dropped
6:424 0:000 corrected XSDT length=116
6:424 0:000 Drop tables from Xsdt, SIGN=SSDT TableID= Length=0
6:424 0:000 Xsdt has tables count=10
6:424 0:000 Table: SSDT SataAhci 643 dropped
6:424 0:000 Table: SSDT PtidDevc 1162 dropped
6:424 0:000 Table: SSDT Cpu0Ist 2064 dropped
6:424 0:000 Table: SSDT CpuPm 2481 dropped
6:424 0:000 corrected XSDT length=84
6:424 0:000 Inserting ssdt.aml from EFI\CLOVER\ACPI\patched ... Success
6:425 0:000 CPUBase=0 and ApicCPUBase=0 ApicCPUNum=8
6:425 0:000 EdidDiscovered size=128
6:425 0:000 00 | 00 FF FF FF FF FF FF 00 30 E4 F1 02 00 00 00 00
6:425 0:000 16 | 00 14 01 03 80 22 13 78 0A 05 85 9B 5B 54 94 26
6:425 0:000 32 | 0E 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
6:425 0:000 48 | 01 01 01 01 01 01 12 1B 56 72 50 00 0C 30 24 28
6:425 0:000 64 | 35 00 58 C2 10 00 00 19 00 00 00 00 00 00 00 00
6:425 0:000 80 | 00 00 00 00 00 00 00 00 00 00 00 00 00 FE 00 4C
6:425 0:000 96 | 47 20 44 69 73 70 6C 61 79 0A 20 20 00 00 00 FE
6:425 0:000 112 | 00 4C 50 31 35 36 57 48 34 2D 54 4C 44 31 00 FF
6:425 0:000 Intel GFX injection not set
6:425 0:000 HDA Controller [8086:1C20] :: PciRoot(0x0)\Pci(0x1B,0x0) => codec not detected
6:435 0:010 LAN Controller [10EC:8168] :: PciRoot(0x0)\Pci(0x1C,0x5)\Pci(0x0,0x0)
6:435 0:000 RCBA access disabled; trying to enable
6:435 0:000 stringlength = 488
6:436 0:000 CurrentMode: Width=1024 Height=768
6:436 0:000 Beginning FSInjection
FSInjectionInstall ...
- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: B995D618
FSInjectionInstall ...
- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: B995D618
6:439 0:003 MSR 0x1B0 set to 00000000
6:439 0:000 Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
6:439 0:000 Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.10
6:439 0:000 Extra kext: EFI\CLOVER\kexts\10.10\ACPIBatteryManager.kext
6:441 0:001 Extra kext: EFI\CLOVER\kexts\10.10\ACPIPoller.kext
6:442 0:001 Extra kext: EFI\CLOVER\kexts\10.10\FakePCIID_Broadcom_WiFi.kext
6:444 0:001 Extra kext: EFI\CLOVER\kexts\10.10\FakePCIID_Intel_HD_Graphics.kext
6:444 0:000 Extra kext: EFI\CLOVER\kexts\10.10\FakeSMC.kext
6:446 0:002 Extra kext: EFI\CLOVER\kexts\10.10\IOath3kfrmwr.kext
6:449 0:002 Extra kext: EFI\CLOVER\kexts\10.10\IntelBacklight.kext
6:450 0:001 Extra kext: EFI\CLOVER\kexts\10.10\ProBookAtheros.kext
6:452 0:001 Extra kext: EFI\CLOVER\kexts\10.10\RealtekRTL8111.kext
6:454 0:002 Extra kext: EFI\CLOVER\kexts\10.10\VoodooPS2Controller.kext
6:456 0:002 Extra PlugIn kext: EFI\CLOVER\kexts\10.10\VoodooPS2Controller.kext\Contents\PlugIns\VoodooPS2Keyboard.kext
6:462 0:005 Extra PlugIn kext: EFI\CLOVER\kexts\10.10\VoodooPS2Controller.kext\Contents\PlugIns\VoodooPS2Mouse.kext
6:463 0:001 Extra PlugIn kext: EFI\CLOVER\kexts\10.10\VoodooPS2Controller.kext\Contents\PlugIns\VoodooPS2Trackpad.kext
6:469 0:006 Removed efi-boot-device-data variable: Not Found
6:469 0:000 Custom boot is disabled
6:469 0:000 Closing log


Is that the correct log?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Parts of the log relevant to theme selection:
Code:
SPEEDY-OSX:dh67gd.git RehabMan$ pbpaste |grep -y theme
0:105 0:001 Found theme directory: Yosemite
0:106 0:000 Found theme directory: Yosemite S
0:109 0:003 Found theme directory: applestyle
0:111 0:001 Found theme directory: BGM
0:114 0:002 Found theme directory: BGM256
0:117 0:002 Found theme directory: black_green
0:118 0:001 Found theme directory: bluemac
0:119 0:001 Found theme directory: bootcamp - bad theme because theme.plist can't be load
0:120 0:000 Found theme directory: chrome
0:122 0:001 Found theme directory: CloverX
0:123 0:001 Found theme directory: dawn
0:124 0:001 Found theme directory: embedded
0:125 0:000 Found theme directory: gold_clover
0:126 0:001 Found theme directory: iclover
0:127 0:001 Found theme directory: ios7
0:128 0:001 Found theme directory: magnifico
0:129 0:000 Found theme directory: metal
0:130 0:001 Found theme directory: mrengles
0:131 0:001 Found theme directory: orange
0:132 0:000 Found theme directory: os_box
0:133 0:001 Found theme directory: os_one
0:135 0:001 Found theme directory: Shield
0:137 0:002 Found theme directory: sketched
0:139 0:001 Found theme directory: Space
0:141 0:001 Found theme directory: steampunkblack
0:142 0:001 Found theme directory: thinkpad
0:143 0:000 Default theme: Yosemite S
0:510 0:000 Adding Key: Clover.Theme: Size = 10, Data: 59 6F 73 65 6D 69 74 65 20 53 
0:511 0:000 Using theme 'Yosemite S' (EFI\CLOVER\themes\Yosemite S)
0:511 0:000 theme Yosemite S defined in NVRAM found and theme.plist parsed
0:522 0:010 Choosing theme Yosemite S
0:588 0:000 Theme path EFI\CLOVER\themes\Yosemite S, ThemeDir=B92B6120
What you can learn from it:
- bootcamp theme is invalid (due to theme.plist not existing)
- bootcamp theme not loaded
- you have a lot of themes
- 'Yosemite S' is the selected theme
- seems as if you're selecting the theme from NVRAM, likely due to using Clover prefpane
- correct selection of that theme will depend on NVRAM implementation correctness
 
Joined
Oct 21, 2013
Messages
298
Motherboard
Gigabyte GA-Z270X-Gaming K5
CPU
i7-7700K
Graphics
GTX 1070
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
Parts of the log relevant to theme selection:
Code:
SPEEDY-OSX:dh67gd.git RehabMan$ pbpaste |grep -y theme
0:105 0:001 Found theme directory: Yosemite
0:106 0:000 Found theme directory: Yosemite S
0:109 0:003 Found theme directory: applestyle
0:111 0:001 Found theme directory: BGM
0:114 0:002 Found theme directory: BGM256
0:117 0:002 Found theme directory: black_green
0:118 0:001 Found theme directory: bluemac
0:119 0:001 Found theme directory: bootcamp - bad theme because theme.plist can't be load
0:120 0:000 Found theme directory: chrome
0:122 0:001 Found theme directory: CloverX
0:123 0:001 Found theme directory: dawn
0:124 0:001 Found theme directory: embedded
0:125 0:000 Found theme directory: gold_clover
0:126 0:001 Found theme directory: iclover
0:127 0:001 Found theme directory: ios7
0:128 0:001 Found theme directory: magnifico
0:129 0:000 Found theme directory: metal
0:130 0:001 Found theme directory: mrengles
0:131 0:001 Found theme directory: orange
0:132 0:000 Found theme directory: os_box
0:133 0:001 Found theme directory: os_one
0:135 0:001 Found theme directory: Shield
0:137 0:002 Found theme directory: sketched
0:139 0:001 Found theme directory: Space
0:141 0:001 Found theme directory: steampunkblack
0:142 0:001 Found theme directory: thinkpad
0:143 0:000 Default theme: Yosemite S
0:510 0:000 Adding Key: Clover.Theme: Size = 10, Data: 59 6F 73 65 6D 69 74 65 20 53 
0:511 0:000 Using theme 'Yosemite S' (EFI\CLOVER\themes\Yosemite S)
0:511 0:000 theme Yosemite S defined in NVRAM found and theme.plist parsed
0:522 0:010 Choosing theme Yosemite S
0:588 0:000 Theme path EFI\CLOVER\themes\Yosemite S, ThemeDir=B92B6120
What you can learn from it:
- bootcamp theme is invalid (due to theme.plist not existing)
- bootcamp theme not loaded
- you have a lot of themes
- 'Yosemite S' is the selected theme
- seems as if you're selecting the theme from NVRAM, likely due to using Clover prefpane
- correct selection of that theme will depend on NVRAM implementation correctness
I understand bootcamp theme isn't loading due to 'theme.plist' missing it's extension, which was intentional because nothing else I did prevented that theme from showing, rather than Yosemite S like I wanted. I did that on purpose and with knowledge of it.

As far as NVRAM implementation, I'm not 100% sure what you mean. All I know is, using Clover pref pane was useless for me. It always defaulted back to bootcamp theme. Until I renamed 'theme.plist' to 'theme' in EFI/CLOVER/themes/bootcamp, it loaded that theme no matter what I did. If I ever wanted to use it, I'd just rename it back to it's proper name. If I wanted to switch from Yosemite S to a new theme and it didn't work, I'd try to also name it's theme.plist file to simply theme, etc.

Not how it's meant to be, but it works I guess. I am going to read up real well on the Clover Wiki when I am in the mood and now I know how to check the logs, so I may start progressing in my understanding of Clover soon.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I understand bootcamp theme isn't loading due to 'theme.plist' missing it's extension, which was intentional because nothing else I did prevented that theme from showing, rather than Yosemite S like I wanted. I did that on purpose and with knowledge of it.
Re-enable it, then re-analyse Clover bootlog.

As far as NVRAM implementation, I'm not 100% sure what you mean.
Two Clover NVRAM implementations.

1) EmuVariableUefi-64.efi. Requires "RC scripts" to write the contents of NVRAM to a file on shutdown so it can be read on startup by Clover.
2) UEFI native NVRAM. Without EmuVariable, native UEFI NVRAM is used (provided by UEFI services).

All I know is, using Clover pref pane was useless for me.
Clover pref pane writes to NVRAM. Will require working NVRAM.

As described in the Clover wiki, the theme specified in config.plist is used when no theme (or perhaps invalid theme) is found in NVRAM.

So the theme defined in NVRAM takes priority. With incorrect NVRAM implementation, you may not have consistent results with Clover prefpane.

At any rate, the Clover bootlog is useful for determining what is going on. And it is easy to see what is in NVRAM (nvram -p).
 
Joined
Oct 21, 2013
Messages
298
Motherboard
Gigabyte GA-Z270X-Gaming K5
CPU
i7-7700K
Graphics
GTX 1070
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
Re-enable it, then re-analyse Clover bootlog.



Two Clover NVRAM implementations.

1) EmuVariableUefi-64.efi. Requires "RC scripts" to write the contents of NVRAM to a file on shutdown so it can be read on startup by Clover.
2) UEFI native NVRAM. Without EmuVariable, native UEFI NVRAM is used (provided by UEFI services).



Clover pref pane writes to NVRAM. Will require working NVRAM.

As described in the Clover wiki, the theme specified in config.plist is used when no theme (or perhaps invalid theme) is found in NVRAM.

So the theme defined in NVRAM takes priority. With incorrect NVRAM implementation, you may not have consistent results with Clover prefpane.

At any rate, the Clover bootlog is useful for determining what is going on. And it is easy to see what is in NVRAM (nvram -p).
Hmm, I THINK I understand. So basically it comes down to checking if I have RC scripts installed so that when I'm using 'EmuVariableUefi-64.efi', which I am, Clover pref pane works correctly.

Am I roughly right? In a non technical way.

UPDATE: Well, I renamed 'theme.plist' in EFI/CLOVER/themes/bootcamp back to 'theme.plist' and I rebooted and magically Clover pref pane seems to be working perfectly normal. I cannot explain it. I didn't do anything different at all besides rename that file. Unbelievable...
 
Top