Contribute
Register

Clover r5126 fails to boot

Status
Not open for further replies.
Joined
Sep 30, 2017
Messages
10
Motherboard
Gigabyte B150M-D3H
CPU
i5-7500
Graphics
RX580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
The last stable version of Clover is 5119, but it will work only with Catalina and below. Current Clover is buggy rubbish and it is almost dead. Don't waste your time on it, just move to OpenCore setup.
I see that you have OC on this setup: iMac 2017 Big Sur OpenCore Asus Prime Z270-P | i5 7600k (5 GHz) | 32Gb Ram (3200 Mhz) | Sapphire RX580 4Gb

I have similar setup, may you show your OC folder and settings? Thanks
 
Joined
Dec 27, 2017
Messages
5
Motherboard
ASUS H110M-E/M.2
CPU
i7-7700K
Graphics
RX 580
Mobile Phone
  1. Android
Okay, here it goes. I am using the same settings since High Sierra with updated kexts. Hope it works for you, if not, try with OpenCore. I am thinking to move to OpenCore, eventhou it doesn't boot. So, when I get some more time, I'll try harder, cuz with OC I see people are very satisfied.
Thanks. I tried all these versions. Your drivers directory had only OpenCore. I tried with and without OcQuirks.efi. Somehow , I get a frozen screen as soon as it reboot into 5126-5127. Tried a bunch of Quircks but too many options

I am thinking of creating a boot USB with just Clover and try that one until something boots. But I can't find enough documentation about needed drivers and Quirks descriptions to know what really would work.

Blindly copying some config without knowing what I'm doing is not getting me anywhere.

Anybody know the strict minimum I need to have a USB boot into Clover 5126-5127?
 
Joined
Dec 27, 2017
Messages
5
Motherboard
ASUS H110M-E/M.2
CPU
i7-7700K
Graphics
RX 580
Mobile Phone
  1. Android
For anybody else interested, before rebooting (or installing):
  • Eliminate FakeSMC from kext/other and UEFI drivers. You need to use VirtualSMC
  • Add OpenRuntime.efi to drivers
    • Eliminate Most other Drivers (EFI/Clover/drivers/UEFI). I had to manually delete files om top of CloverConfigurator)​
    • You *do not* need OcQuirks.efi​
    • You *do not* need VirtualSMC.efi​
  • I don't know which Quirks need to be enabled. I just chose the same options that were in the config-example.plist.
  • Install Clover. I used standard install and manual option making sure all the scripts run locally.
It seems to work!

Basically main issue was wrong and incompatible drivers and kext.
 
Joined
Jan 23, 2020
Messages
6
Motherboard
MSI H81-I
CPU
Intel Core i5 4670
Graphics
Intel HD 4600
Mobile Phone
  1. Android
I'm also having issues while trying to update from r5119... And OpenCore well... It almost KILLED my motherboard (besides my system couldn't boot anymore, somehow open core unwantedly made it's way to my mobo's firmware, being shown inside the boot options even with all my drives unplugged...)

I've had to re-flash my mobo's firmware, and thank god my pc came back to life...
 
Status
Not open for further replies.
Top