Clover HDMI audio for NVIDIA & AMD cards. Easy way.

Discussion in 'HDMI Audio' started by ok1ok1, Oct 22, 2014.

  1. marksleight

    marksleight

    Joined:
    Apr 14, 2017
    Messages:
    1
    Mobo:
    MSI MS-7826 (Kaili)
    CPU:
    Intel Core i7 4770
    Graphics:
    Nvidia GeForce GTX660
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Apr 15, 2017 at 8:24 AM #151
    marksleight

    marksleight

    Joined:
    Apr 14, 2017
    Messages:
    1
    Mobo:
    MSI MS-7826 (Kaili)
    CPU:
    Intel Core i7 4770
    Graphics:
    Nvidia GeForce GTX660
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Thanks so much for this. Have a Creative Soundblaster X-fi (SB0880) but failed over and over to get it working. Can't get internal audio to work either (IDT 92HD68E2). Was happy to settle for HDMI audio through Nvidia GTX660 card as don't need any more than stereo outside of Windows. Followed instruction to remove the VoodooHDA kext from extensions folder and installed your kext with KextBeast. Worked straight after a reboot.
     
  2. JessVllez7

    JessVllez7

    Joined:
    Feb 27, 2017
    Messages:
    4
    Apr 15, 2017 at 10:52 AM #152
    JessVllez7

    JessVllez7

    Joined:
    Feb 27, 2017
    Messages:
    4
    my steps:
    1. Unzip http://www54.zippyshare.com/v/HP2W44Xt/file.html with terminal (unzip HDMIAudio.kext.zip)
    2. Open Clover configurator and mount my efi particion
    3. Open finder and copy HDMIAudio.kext on other like my photo.
    4. Restart and... doesn works :(

    im soo noob :(
     

    Attached Files:

    • Captura de pantalla 2017-04-15 a las 11.50.18.png  (55 KB, 223 views)
    • Captura de pantalla 2017-04-15 a las 12.03.51.png  (75.8 KB, 207 views)
  3. hemon

    hemon

    Joined:
    Aug 5, 2014
    Messages:
    178
    Mobo:
    GA-Z97X-UD5D
    CPU:
    i7-4790K
    Graphics:
    GTX 1070
    Mac:
    iMac
    Apr 15, 2017 at 1:04 PM #153
    hemon

    hemon

    Joined:
    Aug 5, 2014
    Messages:
    178
    Mobo:
    GA-Z97X-UD5D
    CPU:
    i7-4790K
    Graphics:
    GTX 1070
    Mac:
    iMac
    HDMI Audio doesn't work to me.
     
  4. vinodh

    vinodh

    Joined:
    Apr 14, 2011
    Messages:
    45
    Mobo:
    GA-H97M-D3H
    CPU:
    i5 4690K
    Graphics:
    GTX 1080
    Mac:
    MacBook, Mac mini
    Mobile Phone:
    iOS
    Apr 15, 2017 at 5:20 PM #154
    vinodh

    vinodh

    Joined:
    Apr 14, 2011
    Messages:
    45
    Mobo:
    GA-H97M-D3H
    CPU:
    i5 4690K
    Graphics:
    GTX 1080
    Mac:
    MacBook, Mac mini
    Mobile Phone:
    iOS
    I used that exact method and it worked for me. :D

    HMDI audio works from the HDMI port on my GTX 1080. It doesn't work however via the DVI port using a DVI>HDMI adaptor.
     
  5. JessVllez7

    JessVllez7

    Joined:
    Feb 27, 2017
    Messages:
    4
    Apr 15, 2017 at 6:01 PM #155
    JessVllez7

    JessVllez7

    Joined:
    Feb 27, 2017
    Messages:
    4
    Did you install some voodoo driver?
     
  6. vinodh

    vinodh

    Joined:
    Apr 14, 2011
    Messages:
    45
    Mobo:
    GA-H97M-D3H
    CPU:
    i5 4690K
    Graphics:
    GTX 1080
    Mac:
    MacBook, Mac mini
    Mobile Phone:
    iOS
    Apr 15, 2017 at 7:20 PM #156
    vinodh

    vinodh

    Joined:
    Apr 14, 2011
    Messages:
    45
    Mobo:
    GA-H97M-D3H
    CPU:
    i5 4690K
    Graphics:
    GTX 1080
    Mac:
    MacBook, Mac mini
    Mobile Phone:
    iOS
    No. Just used the HDMIaudio kext file.
     
  7. xllpeperllx

    xllpeperllx

    Joined:
    Apr 15, 2017
    Messages:
    1
    Mobo:
    asus sabertooth z170
    CPU:
    Intel i7 6700k
    Graphics:
    Asus Strix GTX 1080
    Apr 16, 2017 at 2:13 AM #157
    xllpeperllx

    xllpeperllx

    Joined:
    Apr 15, 2017
    Messages:
    1
    Mobo:
    asus sabertooth z170
    CPU:
    Intel i7 6700k
    Graphics:
    Asus Strix GTX 1080
    Hello bro, I was in the same problem that you. If you still can not solve the problem, install VoodooHDA.kext version 2.8.9
    instead of HDMIAudio.kext like this post
    Hope that solve your problem.
     
  8. joevt

    joevt

    Joined:
    Apr 5, 2016
    Messages:
    429
    Mobo:
    GIGABYTE Z170X-Gaming 7, GIGABYTE Z170N-Gaming 5
    CPU:
    Intel Core i7-6700K 4.6 GHz, Intel Core i7-6600K 4.4 GHz
    Graphics:
    EVGA GeForce GTX TITAN X 12GB SC Gaming, EVGA GeForce GTX 1070 8GB
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
    Classic Mac:
    Apple, LC, Power Mac
    Mobile Phone:
    iOS
    Apr 16, 2017 at 8:03 AM #158
    joevt

    joevt

    Joined:
    Apr 5, 2016
    Messages:
    429
    Mobo:
    GIGABYTE Z170X-Gaming 7, GIGABYTE Z170N-Gaming 5
    CPU:
    Intel Core i7-6700K 4.6 GHz, Intel Core i7-6600K 4.4 GHz
    Graphics:
    EVGA GeForce GTX TITAN X 12GB SC Gaming, EVGA GeForce GTX 1070 8GB
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
    Classic Mac:
    Apple, LC, Power Mac
    Mobile Phone:
    iOS
    Using HDMIAudio.kext, I was able to get audio from DP1 and DP2 on the 1070. DVI-D, HDMI, and DP3 did not work.
     
  9. hunfar

    hunfar

    Joined:
    Aug 26, 2013
    Messages:
    10
    Mobo:
    MSI Z97 GAMING 7
    CPU:
    Intel i7 4790 Quad-Core
    Graphics:
    Asus GTX 780 OC-DIRECTCUII
    Mac:
    Mac Pro
    Apr 16, 2017 at 3:36 PM #159
    hunfar

    hunfar

    Joined:
    Aug 26, 2013
    Messages:
    10
    Mobo:
    MSI Z97 GAMING 7
    CPU:
    Intel i7 4790 Quad-Core
    Graphics:
    Asus GTX 780 OC-DIRECTCUII
    Mac:
    Mac Pro
    I also have a problem. Audio through my MSI Motherboard's analog ports works with the alc drivers installed through multibeast. However I don't have speakers and I don't want to be connected to headphones all the time. So I tried the Hdmiaudio drivers with my MSI GTX 1070 but they didn't work. I have doublechecked and I have installed them to the other folder in the kext folder of the efi partition. However hdmi audio doesn't work. I want both hdmi audio and analog to work. Can someone suggest a method to do that.
     
  10. hemon

    hemon

    Joined:
    Aug 5, 2014
    Messages:
    178
    Mobo:
    GA-Z97X-UD5D
    CPU:
    i7-4790K
    Graphics:
    GTX 1070
    Mac:
    iMac
    Apr 16, 2017 at 4:40 PM #160
    hemon

    hemon

    Joined:
    Aug 5, 2014
    Messages:
    178
    Mobo:
    GA-Z97X-UD5D
    CPU:
    i7-4790K
    Graphics:
    GTX 1070
    Mac:
    iMac
    Last version of VoodooHDA + Applehdadisabler.kext
     
    langweiler94 likes this.

Share This Page