Contribute
Register

Clover HDMI audio for NVIDIA & AMD cards. Easy way.

Status
Not open for further replies.
Joined
Feb 28, 2013
Messages
20
Motherboard
Desktop
CPU
I5
Graphics
Gforce 650 TI
Mac
  1. 0
Classic Mac
  1. 0
Mobile Phone
  1. 0
Updated 07/3/2018. This solution works in High Sierra 10.13.6 as well as several previous versions of MacOS. I didn't create the tools I only figured out how to use them. Credit for the kext goes to andrejkw at macrumors. Your mileage may vary but this is the easiest solution I've found. I've used it for years & its worked for many others. Definitely worth a try.

1. Download package located here https://www.dropbox.com/s/8hay1m0rec93vvo/HDMIAudio-1.0.dmg?dl=1
2. Mount HDMIAudio-1.0 disk image
3. Mount your EFI partition. You may need to use Clover Configurator or similar tool to do this.
3. Copy HDMIAudio.kext from the HDMIAudio disk image to EFI/Clover/Kexts/Other
4. Reboot. Clover may hang on the initial boot attempt, if so a restart of the computer should have you up and running.

There you have it, a simple file copy.
After the reboot I had working HDMI Audio.
*If you don't see any audio devices after reboot. Download and run AudioCloverALC command by toleda
https://github.com/toleda/audio_CloverALC/raw/master/audio_cloverALC-130.command.zip

This may help to finish off the install.

If you're confused, there is a quick rundown in this video. *VIDEO IS OLD. COPY KEXT TO "OTHER" FOLDER!
*Don't forget to select the proper output! System Preferences/Sound/output or hold the Option key while clicking volume icon.

So now you have HDMI audio, but what about volume control? OSX doesn't support volume control of HDMI devices natively. Use one of the utilities below to enable it.
Audio Hijack
Sound Siphon
 

Attachments

  • HDMIAudio-1.0.dmg
    32.1 KB · Views: 2,037
Last edited:
Does this works on GTX 780?
 
After try a lot of guide and other, nothing work

Try your method with GTX660 + HDMI + SamsungTV E7000
Clover_v2k_r2976

All work !

Capture d’écran 2014-11-04 à 19.59.06.png

Big Thank's
:thumbup::thumbup::thumbup::thumbup::thumbup:
 
After many unsuccessful attempts :banghead: to get HDMI Audio with a NVIDIA GT640 on Yosemite, now it works after a minute :thumbup:

Thank you very much!
 
Does this works on GTX 780?

I'm not sure which cards this works with. I didn't write the tools, just figured out a way to use them. Ultimately its a simple download and file copy. I'd recommend giving it a try.
 
Amazing, tried so many tutorials'!!
to make it even easier, you can use http://www.cindori.org/software/kextdrop
using this you don't even have to mount efi! VERY EASY!
just drag and drop the HDMI audio kext onto the Kextdrop app, reboot and voila!
Thanks so much

I can confirm, works with gtx 760
 
I'm not sure which cards this works with. I didn't write the tools, just figured out a way to use them. Ultimately its a simple download and file copy. I'd recommend giving it a try.

It worked on my GTX 780. Very easy fix.

Thanks for sharing! :)
 
Thank you very much!!! Work like a charm)) z87-wifi, Nvidia 760. Just run install install.sh from package and reboot. Thats all.
 
Works great with GTX 550 Ti!
Thanks!
 
Status
Not open for further replies.
Back
Top