Contribute
Register

(Clover Config.plist)All new user of Clover plz read (Configuring Clover)

Joined
Dec 11, 2011
Messages
293
Motherboard
Gigabyte Z87M D3H
CPU
Intel Core I5 4670k
Graphics
HD 4600
Mac
iMac
Classic Mac
iBook
Mobile Phone
Android,
Before u try to boot with clover beaware that clover setup install sample config.plist that will not work for everyone!
For good config.plist we can use Clover Configurator to make things easy.

Plz check Clover WIKI before just start changing things in config.plist

When u first install clover u need to know that default theme set in config.plist its "metal" soo install this one if u dont want-know to change theme in config.plist.:headbang:

Current happy users can help new users here.
Plz post here your:
Current version of clover
hardware u use
method u use Clover (Legacy or UEFI)
share your config.plist
share your list of drivers u use with clover.
 
Joined
May 12, 2011
Messages
2,721
Motherboard
GA-X99M-Gaming 5
CPU
Intel Core i7-5930K
Graphics
MSI GTX 970 Gaming 4G
Mac
MacBook Pro
Mobile Phone
Android
Clover ver. 2244
Hardware in sig.
Boot UEFI
drivers64UEFI:

drivers.png

config.plist
PHP:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Boot</key>
    <dict>
        <key>Arguments</key>
        <string>-v</string>
        <key>DefaultVolume</key>
        <string>Mavericks</string>
        <key>Fast</key>
        <false/>
        <key>XMPDetection</key>
        <false/>
        <key>Legacy</key>
        <string>PBR</string>
        <key>Log</key>
        <false/>
        <key>Timeout</key>
        <integer>3</integer>
    </dict>
    <key>CPU</key>
    <dict>
        <key>BusSpeedkHz</key>
        <string>100000</string>
    </dict>
    <key>Devices</key>
    <dict>
        <key>FakeID</key>
        <dict>
            <key>NVidia</key>
            <string>0x100</string>
        </dict>
        <key>USB</key>
        <dict>
            <key>Inject</key>
            <true/>
            <key>FixOwnership</key>
            <true/>
        </dict>
    </dict>
    <key>GUI</key>
    <dict>
        <key>TextOnly</key>
        <false/>
        <key>Theme</key>
        <string>mrengles</string>
        <key>Scan</key>
        <true/>
            <key>Scan</key>
            <dict>
                  <key>Tool</key>
                  <true/>
                  <key>Entries</key>
                  <false/>
                  <key>Legacy</key>
                  <false/>
            </dict>        
        </dict>
    <key>Graphics</key>
    <dict>
        <key>Inject</key>
        <false/>
        <key>LoadVBios</key>
        <true/>
        <key>PatchVBios</key>
        <false/>
        <key>NVidia</key>
          <true/>
    </dict>
    <key>RtVariables</key>
    <dict>
        <key>LogEveryBoot</key>
        <string>No</string>
        <key>LogLineCount</key>
        <integer>3000</integer>
        <key>MountEFI</key>
        <true/>
    </dict>
    <key>SystemParameters</key>
    <dict>
        <key>CustomUUID</key>
        <string>511CE200-1000-4000-9898-011103040523</string>
        <key>InjectSystemID</key>
        <true/>
    </dict>
</dict>
</plist>
 
Joined
Aug 20, 2010
Messages
80
Motherboard
SC NUC, Z370N
CPU
i7-8700K
Graphics
RX 580
Thanks to both of you for your posts. xpamamadeus I just followed your guide to making a USB stick with installer in your other posts and got the system to boot but my next questions were on how to set up the config so I'm glad you made this post too. Lots of settings I don't understand... will have to read up before I continue with my install. :)
 
Joined
Jan 10, 2011
Messages
51
Motherboard
ASUS Maximus VI Formula. UEFI BIOS 1402
CPU
i7 4770K @ Stock
Graphics
Gigabyte GTX 680 2GB OC Edition
Mac
MacBook Pro, Mac Pro
Classic Mac
Mobile Phone
iOS
I notice you are booting using Clover. Can you please help me with something as I have noticed that my system has changed since updating to Clover lately. And the dev team keep making so many changes to the config list. I get doubles of my boot volumes in the GUI. As in UEFI and legacy boot volumes showing up even though my config list says legacy>No. If I post my config.plist here can you please explain to me what changes I need to make in order to make it boot pure UEFI again, as it has not done so since something like version 1780. I also boot with extra kexts as well.


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>KernelAndKextPatches</key>
<dict>
<key>Debug</key>
<false/>
<key>KernelCpu</key>
<false/>
<key>AsusAICPUPM</key>
<true/>
<key>AppleRTC</key>
<false/>
<key>KextsToPatch</key>
<array/>
</dict>
<key>DisableDrivers</key>
<array>
<string>Nothing</string>
</array>
<key>ACPI</key>
<dict>
<key>DsdtName</key>
<string>DSDT.aml</string>
<key>DropMCFG</key>
<true/>
<key>GenerateIvyStates</key>
<true/>
</dict>
<key>GUI</key>
<dict>
<key>Theme</key>
<string>bootcamp</string>
<key>DefaultBootVolume</key>
<string>Mountain Lion SSD</string>
<key>DebugLog</key>
<true/>
<key>FastBoot</key>
<false/>
<key>Mouse</key>
<dict>
<key>Enabled</key>
<false/>
<key>Speed</key>
<integer>0</integer>
</dict>
<key>Volumes</key>
<dict>
<key>Legacy</key>
<false/>
</dict>
<key>HideEntries</key>
<dict>
<key>OSXInstall</key>
<false/>
<key>Recovery</key>
<true/>
<key>Duplicate</key>
<false/>
<key>WindowsEFI</key>
<false/>
<key>Grub</key>
<false/>
<key>Gentoo</key>
<false/>
<key>Ubuntu</key>
<false/>
<key>OpticalUEFI</key>
<true/>
<key>InternalUEFI</key>
<true/>
<key>ExternalUEFI</key>
<true/>
</dict>
</dict>
<key>PCI</key>
<dict>
<key>HDAInjection</key>
<integer>0</integer>
<key>USBFixOwnership</key>
<string>0</string>
<key>USBInjection</key>
<string>0</string>
</dict>
<key>RtVariables</key>
<dict>
<key>MountEFI</key>
<true/>
<key>LogLineCount</key>
<integer>3000</integer>
<key>LogEveryBoot</key>
<false/>
</dict>
<key>SMBIOS</key>
<dict>
<key>ProductName</key>
<string>iMac13,2</string>
<key>SerialNumber</key>
<string>xxxxxxxxxxxx</string>
</dict>
<key>SystemParameters</key>
<dict>
<key>boot-args</key>
<string></string>
<key>InjectKexts</key>
<true/>
<key>XMPDetection</key>
<true/>
<key>prev-lang:kbd</key>
<string>en:0</string>
<key>InjectSystemID</key>
<true/>
</dict>
<key>Graphics</key>
<dict>
<key>PatchVBios</key>
<false/>
</dict>
</dict>
</plist>
 
Joined
May 12, 2011
Messages
2,721
Motherboard
GA-X99M-Gaming 5
CPU
Intel Core i7-5930K
Graphics
MSI GTX 970 Gaming 4G
Mac
MacBook Pro
Mobile Phone
Android
Please repost your config.plist within PHP tags to maintain the proper format, no value in what you've posted. (example in post #2) Also, if you go to the Wiki, http://clover-wiki.zetam.org/Configuration, you'll find the correct format for creating Custom menus, it's in the GUI section.
 
Joined
Jan 10, 2011
Messages
51
Motherboard
ASUS Maximus VI Formula. UEFI BIOS 1402
CPU
i7 4770K @ Stock
Graphics
Gigabyte GTX 680 2GB OC Edition
Mac
MacBook Pro, Mac Pro
Classic Mac
Mobile Phone
iOS
I am not sure how to make custom PHP formatting.

Also I read through the wiki and I still did not figure it out 100%

Could you help with the PH P format??
 
Joined
May 12, 2011
Messages
2,721
Motherboard
GA-X99M-Gaming 5
CPU
Intel Core i7-5930K
Graphics
MSI GTX 970 Gaming 4G
Mac
MacBook Pro
Mobile Phone
Android
I am not sure how to make custom PHP formatting.

Also I read through the wiki and I still did not figure it out 100%

Could you help with the PH P format??
Click the toolbar icon and paste you config.plist between the PHP tags.

php.png
 
Joined
Jan 10, 2011
Messages
51
Motherboard
ASUS Maximus VI Formula. UEFI BIOS 1402
CPU
i7 4770K @ Stock
Graphics
Gigabyte GTX 680 2GB OC Edition
Mac
MacBook Pro, Mac Pro
Classic Mac
Mobile Phone
iOS
Ok, there is absolutely no toolbar that comes up when I type my message here
Or anything with font options at all

I have no idea how you even got that menu up :mad:

Edit: Right it seems that this site sets my posting to standard formatting at default and I have to go into my settings and change that
 

Attachments

Joined
Jan 10, 2011
Messages
51
Motherboard
ASUS Maximus VI Formula. UEFI BIOS 1402
CPU
i7 4770K @ Stock
Graphics
Gigabyte GTX 680 2GB OC Edition
Mac
MacBook Pro, Mac Pro
Classic Mac
Mobile Phone
iOS
The PHP is not working and my config.plist is being all jumbled up on the page. I am out of patience and seriously tired so I have just attached it instead

Not got time for stupid web formatting screw ups
 
Joined
May 12, 2011
Messages
2,721
Motherboard
GA-X99M-Gaming 5
CPU
Intel Core i7-5930K
Graphics
MSI GTX 970 Gaming 4G
Mac
MacBook Pro
Mobile Phone
Android
If you'd go to Settings> General Settings and turn on "Enhanced Interface - Full WYSIWYG Editing", you wouldn't have a problem with the editor...

Don't know what Clover version you're trying but in addition to the invalid entries like open tags "<array/>", you're using a pre-2000 config.plist structure. Go the Wiki and build new based on current structure or modify one that has already been posted.

Below is your config.plist...

PHP:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>KernelAndKextPatches</key>
    <dict>
        <key>Debug</key>
        <false/>
        <key>KernelCpu</key>
        <false/>
        <key>AsusAICPUPM</key>
        <true/>
        <key>AppleRTC</key>
        <false/>
        <key>KextsToPatch</key>
        <array/>
    </dict>
    <key>ACPI</key>
    <dict>
        <key>DsdtName</key>
        <string>DSDT.aml</string>
        <key>DropOemSSDT</key>
        <true/>
        <key>DropAPIC</key>
        <false/>
        <key>DropMCFG</key>
        <true/>
        <key>DropHPET</key>
        <false/>
        <key>DropECDT</key>
        <false/>
        <key>DropDMAR</key>
        <true/>
        <key>DropBGRT</key>
        <true/>
        <key>GenerateIvyStates</key>
        <true/>
        <key>GenerateCStates</key>
        <false/>
        <key>GeneratePStates</key>
        <false/>
        <key>DoubleFirstState</key>
        <false/>
        <key>PLimitDict</key>
        <integer>0</integer>
        <key>UnderVoltStep</key>
        <integer>0</integer>
    </dict>
    <key>DisableDrivers</key>
    <array>
        <string>Nothing</string>
    </array>
    <key>RtVariables</key>
    <dict>
        <key>MountEFI</key>
        <true/>
        <key>LogLineCount</key>
        <integer>3000</integer>
        <key>LogEveryBoot</key>
        <string>No</string>
    </dict>
    <key>GUI</key>
    <dict>
        <key>Theme</key>
        <string>bootcamp</string>
        <key>DefaultBootVolume</key>
        <string>Mavericks SSD</string>
        <key>DebugLog</key>
        <true/>
        <key>Mouse</key>
        <dict>
            <key>Enabled</key>
            <false/>
            <key>Speed</key>
            <integer>0</integer>
        </dict>
        <key>Volumes</key>
        <dict>
            <key>Legacy</key>
            <false/>
        </dict>
        <key>HideEntries</key>
        <dict>
            <key>OSXInstall</key>
            <false/>
            <key>Recovery</key>
            <true/>
            <key>Duplicate</key>
            <true/>
            <key>WindowsEFI</key>
            <false/>
            <key>Grub</key>
            <false/>
            <key>Gentoo</key>
            <false/>
            <key>Ubuntu</key>
            <false/>
            <key>OpticalUEFI</key>
            <true/>
            <key>InternalUEFI</key>
            <true/>
            <key>ExternalUEFI</key>
            <false/>
        </dict>
    </dict>
    <key>PCI</key>
    <dict>
        <key>USBInjection</key>
        <true/>
        <key>USBFixOwnership</key>
        <false/>
        <key>InjectClockID</key>
        <true/>
    </dict>
    <key>SystemParameters</key>
    <dict>
        <key>boot-args</key>
        <string></string>
        <key>InjectKexts</key>
        <true/>
        <key>prev-lang:kbd</key>
        <string>ru:0</string>
        <key>InjectSystemID</key>
        <true/>
        <key>LegacyBoot</key>
        <string>PBR</string>
    </dict>
    <key>SMBIOS</key>
    <dict>
        <key>ProductName</key>
        <string>iMac13,2</string>
        <key>SerialNumber</key>
        <string>C02LJ365DNMP</string>
    </dict>
    <key>Graphics</key>
    <dict>
        <key>PatchVBios</key>
        <false/>
    </dict>
</dict>
</plist>
 
Top