Contribute
Register

Clover bootloader screen resolution

Status
Not open for further replies.
Joined
Jan 10, 2012
Messages
52
Motherboard
MSI P67A-GD80
CPU
I7 2600K
Graphics
Sapphire Nitro+ RX 580 8gb
Mac
  1. Mac Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
CmsVideoDxe-64 works but during the progress bar the whole screen goes black for about 2 seconds then comes back and take me to the login screen, I know it acts like it changing the resolution. I prefer to have the progress bar go all the way through. Funny thing is for years when I was using the GTX570 it was distorted and changed resolution halfway through the progress bar using Sierra. When I installed the AMD RX570, I get the correct resolution on the Clover boot but could never get the card to work right in Sierra. I updated to Catalina and now the card works in Catalina but not in Clover boot, I had to use CmsVideoDxe-64. I couldn't find CSM in my BIOS. But why does the Clover work in Sierra but not Catalina using the RX580?
 
Joined
Apr 5, 2016
Messages
946
Motherboard
GIGABYTE Z170X-Gaming 7
CPU
i7-6700K
Graphics
GTX TITAN X
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Apple
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
For my Gaming 7 motherboard, Nvidia graphics card, and Dell 5K monitor, I finally got around to actually following the instructions in this thread by setting these options:
- Windows 8/10 Features: Windows 8/10 WHQL
- CSM Support: Disabled (this doesn't appear unless Windows 8/10 Features is set to one of the Windows options instead of Other OS)
Now my Dell monitor connected to Nvidia using mDP boots into Clover at 4K instead of 1600x1200. The Intel Graphics always booted this monitor into 4K.

It doesn't affect the BIOS screens (version F20), and it doesn't affect the EFI Shell (max console lines is still 60).
It affects Clover and Mac OS verbose and non-verbose boot. I think it affects the Clover debug text for kernel patches, etc. (after you choose to boot a Mac OS).

For the Apple 30" Cinema Display connected to either Intel Graphics or the Nvidia, it still booted into 1280x800 instead of 2560x1600. So in this case another solution is required (maybe the EDID override protocol idea).

The Dell in 5K mode (dual DP) still boots at 1600x1200 into Clover and Mac OS verbose and non-verbose boot. The system crashes as usual when MacOS completes booting (I'm still using El Capitan, haven't tried Sierra). 5K works when it's not connected at startup.
Strange thing happened to me today. I haven't been using my hackintosh for a long while. I booted up into Clover and found that my Dell UP2715K was showing 5120x2880 60Hz! I took a screenshot in Clover to confirm (also Clover Info menu and debug log showed 5120x2880 mode). I didn't think dual cable displays could work at full resolution.

GA-Z170X-Gaming 7​
BIOS Version: F22i​
Windows 8/10 Features: Window 8/10 WHQL​
CSM Support: Disabled​
Initial Display Output: IGFX (but it's not connected to a display)​
Dell UP2715K port 1 and port 2 connected to port 1 and port 2 of Maxwell Titan X​
Clover 4910​
Clover 5102 (but macOS hangs during boot - I need to fix it to match 4910?).​

Once booting into macOS completes, it switches to 2560x1440 mode. I need to switch off the display, wait a couple seconds, then turn it on to get 5120x2880 again.
 
Joined
Mar 19, 2020
Messages
5
Motherboard
Lenovo > Need model > See Rules!
CPU
i7-8750H
Graphics
GTX 1050 Ti
Thanx. Problem solved.

In BIOS Boot Option:
⦒Legacy boot
⦒UEFI boot (with CSM)
⦒UEFI boot (without CSM) ← I choose this option & the boot regulation is fixed.
 
Joined
Nov 23, 2018
Messages
11
Motherboard
Asus Z390M-PRO GAMING Wi-Fi
CPU
i7-8700
Graphics
integrated
Asus Z390 Gaming Plus WiFi, intel hd630, two 4k displays (HDMI and DP). CSM disabled, tried "windows" and "other os". None of the technics work. Clover still can't found any resolution above 1280x1024.
 
Status
Not open for further replies.
Top