Contribute
Register

Clevo P650SE trouble with Intel HD530

Status
Not open for further replies.
Joined
Nov 11, 2011
Messages
17
Mobile Phone
  1. Android
Hello,

I recently tried to install El Capitan on my laptop (using clover) with following specs:
CPU: Intel Core i7 6820HK / HM87
Graphics: Intel HD 530, 15.6" 1920x1080
Nvidia GTX 970M 6GB
DDR4 8GB, 120 GB SSD KINGSTON,1TB Hitachi Travelstar 7200rpm
Sound: Realtek ALC892 WIFI/BT: Intel 8260

Some info about my setup:
I use the SSD mainly for Windows 10 and have created a 300mb partition for the clover bootloader
El Capitan is installed on a 250gb partition on the other drive
I'm able to boot El Capitan
Ethernet,keyboard and mouse is working

My problem is that the Intel HD 530 is not working properly.
I used the FAKEPCID.kext and the FakePCIID_Intel_SKL_Graphics.kext from this guide:
http://www.tonymacx86.com/threads/g...ke-i7-6700hq-hd-530-using-clover-uefi.195422/ ( see attachment of that thread) for the HD 530.

When logging in and also when using Google Chrome the screen flickers.
Also HDMI is not working.

I've attached the IOReg file and EFI zip.

Any help would be much appreciated.
 

Attachments

  • EFI.zip
    2 MB · Views: 130
  • IOReg.zip
    421.3 KB · Views: 126

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello,

I recently tried to install El Capitan on my laptop with following specs:
CPU: Intel Core i7 6820HK / HM87
Graphics: Intel HD 530, 15.6" 1920x1080
Nvidia GTX 970M 6GB
DDR4 8GB, 120 GB SSD KINGSTON,1TB Hitachi Travelstar 7200rpm
Sound: Realtek ALC892 WIFI/BT: Intel 8260

Some info about my setup:
I use the SSD mainly for Windows 10 and have created a 300mb partition for the clover bootloader
El Capitan is installed on a 250gb partition on the other drive
I'm able to boot El Capitan
Ethernet,keyboard and mouse is working

My problem is that the Intel HD 530 is not working properly.
I used the FAKEPCID.kext and the FakePCIID_Intel_SKL_Graphics.kext from this guide:
http://www.tonymacx86.com/threads/g...ke-i7-6700hq-hd-530-using-clover-uefi.195422/ ( see attachment of that thread) for the HD 530.

When logging in and also when using Google Chrome the screen flickers.
Also HDMI is not working.

I've attached the IOReg file and EFI zip.

Any help would be much appreciated.

No expectation of properly working graphics when using an invalid FakeID (it is clear in your ioreg that you used 0x12345678).

The purpose of a bogus FakeID is to disable the graphics drivers. So your current situation is exactly what you should expect.
 
Joined
Nov 11, 2011
Messages
17
Mobile Phone
  1. Android
Oh. Ok. So to get the Intel HD530 working all I have to do is remove the FakeID entry?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Oh. Ok. So to get the Intel HD530 working all I have to do is remove the FakeID entry?

You might need FakePCIID.kext+FakePCIID_Intel_HD_Graphics.kext (FakePCIID_Intel_SKL_Graphics.kext is deprecated).

And you might need to tweak ig-platform-id. You'll find out when you remove the FakeID. But definitely no possibility of the graphics drivers loading when using a bogus FakeID.
 
Joined
Nov 11, 2011
Messages
17
Mobile Phone
  1. Android
Ok Thanks. Removing the FakeID did the trick.
Would it still be a good idea to use FakePCIID_Intel_HD_Graphics.kext instead of FakePCIID_Intel_SKL_Graphics.kext ?
Do I need to change anything to this kext to get it to work?

Also what would I need to do to get HDMI working?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Ok Thanks. Removing the FakeID did the trick.
Would it still be a good idea to use FakePCIID_Intel_HD_Graphics.kext instead of FakePCIID_Intel_SKL_Graphics.kext ?
Do I need to change anything to this kext to get it to work?

Also what would I need to do to get HDMI working?

The functionality in FakePCIID_Intel_SKL_Graphics.kext was rolled into FakePCIID_Intel_HD_Graphics.kext quite a while ago...

FakePCIID_Intel_SKL_Graphics.kext is deprecated.

Current build of FakePCIID: https://github.com/RehabMan/OS-X-Fake-PCI-ID
 
Joined
Nov 11, 2011
Messages
17
Mobile Phone
  1. Android
Ok I Removed the FakePCIID_Intel_SKL_Graphics.kext and installed the FakePCIID_Intel_HD_Graphics.kext and FakePCIID.kext
I also installed FakePCIID_Intel_HDMI_Audio.kext
I still don't get the HDMI to work. I doesn't recognise my monitor.
 
Joined
Nov 11, 2011
Messages
17
Mobile Phone
  1. Android
Do you mean the SMBIOS section of the config.plist?
I filled in MacBookPro11,2
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Do you mean the SMBIOS section of the config.plist?
I filled in MacBookPro11,2

Attach ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Provide output (in Terminal):
Code:
kextstat|grep -y acpiplat
kextstat|grep -y appleintelcpu
kextstat|grep -y applelpc
kextstat|grep -y applehda

Attach EFI/Clover folder as ZIP (press F4 at main Clover screen before collecting). Please eliminate 'themes' directory. Provide only EFI/Clover, not the entire EFI folder.

Attach output of (in Terminal):
Code:
sudo touch /System/Library/Extensions && sudo kextcache -u /

Compress all files as ZIP. Do not use external links. Attach all files using site attachments only.
 
Status
Not open for further replies.
Top