Contribute
Register

Chimera 2.2 Update

Status
Not open for further replies.
Joined
Apr 18, 2011
Messages
69
Motherboard
Gigabyte GA-Z77X-UD5H-OC0.8.6
CPU
i7-3770K
Graphics
RX 580
I've tried everything but DSDT (GraphicsEnabler=Yes/No, EFI strings, IGPEnabler=Yes/No, changing settings in UEF bios, changing platform-id,etc), and I get frustrated, this drives my crazy. Is impossible to get HD 4000 working properly over HDMI.

The HD 4000 is working OK on DVI but the problem is over HDMI, where there is no way I can get QE/CI working (Flickering desktop, black screen every few seconds), it works only with GraphicsEnabler=No, so no QE/CI.

I don't know what to do, neither the last Chimera fixed my problem.


My specs:

platform-id 0166000a
Motherboard GA-Z77X-UD5H (rev 1.1)
Bios F14
i7 3770K
Display Dell S2440L
Mountain Lion 10.8.4
Chimera 2.2


Some help will be apreciated.
 
Joined
Sep 9, 2012
Messages
17
Motherboard
Dell Optiplex 7010 Mini Tower
CPU
i5-3475S/Q77
Graphics
HD 4000, 2x 1920x1080
Mobile Phone
  1. iOS
I posted earlier how I have everything working fine with my HD2500 and 660Ti which I basically do. However, I am only able to enable my HD2500 when I have IGFX set in BIOS as my primary graphics. The problem with this is that I want to have my monitor hooked up to my discrete graphics card and if I do that then it only sends video signal when I get to the login screen. No video for BIOS, Chimera, etc unless I plug into my integrated graphics. Has anyone figured out a solution for this so that IGFX can be enabled but primary display is dedicated graphics card? It seems that the only way I can get video during BIOS would be to have PEG as initial display but in doing this HD2500 disappears.
 
Joined
Aug 6, 2013
Messages
1
Motherboard
self built
CPU
3770k
Graphics
7970
Mac
Classic Mac
Mobile Phone
will there ever be an update that allows to boot directly from a 7970?
 
Joined
Oct 22, 2012
Messages
88
Motherboard
GA-Z68X-UD3H
CPU
i5-3570
Graphics
HD 7970
Mac
  1. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Article: Chimera 2.2 Update

under 10.8.4 in S/L/E what kext is the one for hd 2500 graphics i only seem to find HD 3000,4000 and HD graphics on my extensions regards wolf
 
Joined
Oct 22, 2012
Messages
88
Motherboard
GA-Z68X-UD3H
CPU
i5-3570
Graphics
HD 7970
Mac
  1. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Article: Chimera 2.2 Update

The IGPlatformID key is not needed as the default value works fine.
Thanks Mac man, ill give it a try, thanks for all your awesome work.
does system definition will affect my graphics performance or setup?
im running mac pro 3.1, i will like to have mac pro 5.1.
according to http://www.everymac.com/systems/app...-i5-3.2-27-inch-aluminum-late-2012-specs.html
this i mac uses a 3470 with hd 2500,mine is i5-3570, so does this system definition can solve some wake issues i have and give better performance with hd2500?
regards wolf
 
Joined
Oct 22, 2012
Messages
88
Motherboard
GA-Z68X-UD3H
CPU
i5-3570
Graphics
HD 7970
Mac
  1. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Article: Chimera 2.2 Update

Wolf,

Set your initial display in your BIOS to PCI for the 640 and make sure the following is in your org.chameleon.Boot.plist:

Code:
[COLOR=#942193][FONT=Courier]
<key>GraphicsEnabler</key>[/FONT][/COLOR]
[COLOR=#942193][FONT=Courier]        <string>No</string>[/FONT][/COLOR]
[COLOR=#942193][FONT=Courier]        <key>IGPlatformID</key>[/FONT][/COLOR]
[COLOR=#942193][FONT=Courier]    <string>01660003</string>
<key>IGPEnabler</key> [/FONT][/COLOR]
[COLOR=#942193][FONT=Courier]        <string>Yes</string>[/FONT][/COLOR]

That should enable both the HD2500 and use your 640 for main display.

Hope this helps. Also, as I mentioned to someone else make sure you set your system definition to Mac mini 6,1 or 6,2 if you are wanting to enable Airplay
Thanks David airplay would be fine, but ill prefer a mac pro definition and with that definition airplay can be achieved i will be pleased.
if not my main concern is to have my build working with both graphics fully running for cs6 and final cut pro.
and also with the edit you are giving me that i can hook up my screen to my 640 and have bios and everything.
regards wolf
 
Joined
Sep 9, 2012
Messages
17
Motherboard
Dell Optiplex 7010 Mini Tower
CPU
i5-3475S/Q77
Graphics
HD 4000, 2x 1920x1080
Mobile Phone
  1. iOS
Article: Chimera 2.2 Update

Wolf,

Through some experimentation I found that if I set IGFX as initial display and have my primary monitor attached to it then Airplay will be enabled even with the Mac Pro 3,1 system definition and my 660ti is also enabled. Not sure if that is relevant to you and what you are looking for? I assume you want the 640 for rendering tasks, etc.?
 
Joined
Oct 22, 2012
Messages
88
Motherboard
GA-Z68X-UD3H
CPU
i5-3570
Graphics
HD 7970
Mac
  1. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Article: Chimera 2.2 Update

Wolf,

Through some experimentation I found that if I set IGFX as initial display and have my primary monitor attached to it then Airplay will be enabled even with the Mac Pro 3,1 system definition and my 660ti is also enabled. Not sure if that is relevant to you and what you are looking for? I assume you want the 640 for rendering tasks, etc.?
Thanks David its quite relevant, i want the 640 for rendering a bit of gaming console emulators, cs6 and finalcut pro mainly.
what im also looking for is to have uniformity in the sense of just haven my display attached to one output and at boot have my bios, because i dual boot with win 7 on other hard drive, also to have the same purposes on windows and also performance.
on win 7
gaming, dvd fab rovi total code studio, are my tasks.
Thanks Regards Wolf
 
Joined
Aug 9, 2012
Messages
35
Motherboard
Gigabyte Z77-UD5H
CPU
i7-3770K
Graphics
RX 570
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Installed 2.2, added IGPEnabler = Yes, Internal Graphics Enabled w/64MB, Initializing PEG first. OSX 10.8.4, HD4000 doesn't show up in my graphics card list.

iMac 13,2
GTX 670
GA-Z77X-UD5H
3770k CPU

Any ideas!? Am I missing a kext file for the 4000, it seems that it should at least be recognized as being installed in the system.
 

Obvious Answer Man

Super Moderator
Joined
Jan 12, 2010
Messages
1,390
Article: Chimera 2.2 Update

Installed 2.2, added IGPEnabler = Yes, Internal Graphics Enabled w/64MB, Initializing PEG first. OSX 10.8.4, HD4000 doesn't show up in my graphics card list.

iMac 13,2
GTX 670
GA-Z77X-UD5H
3770k CPU

Any ideas!? Am I missing a kext file for the 4000, it seems that it should at least be recognized as being installed in the system.
Did you enable it in the BIOS/UEFI?
 
Status
Not open for further replies.
Top