Contribute
Register

Checkered B&W screen after L5430 Xeon LGA771 install. Any ideas?

Joined
Sep 16, 2012
Messages
26
Motherboard
P5Q with 2209 mBIOS
CPU
L5430@3.4GHz
Graphics
ASUS GT630v2 1GB Silent
Mac
  1. MacBook
  2. Mac mini
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
  2. Other
Guys, I am trying to upgrade old LGA775 P5Q board with new processor.
It is Xeon L5430 with adapter. It is working perfectly under Windows since I've updated microcodes in BIOS. Bios I am using is so called 5th Year anniversary mode BIOS.


Dual core E4400 is absolutely fine with the setup. So far i don't have problems with running it on Clover 10.10(tweaked) or 10.11(vanilla config with only latest FakeSMC) on e4400 but Xeon gives me checkered screen after initial apple on black loading screen on both installs. Black has fuzzy RGB dots.

Any ideas what this can be or how to troubleshoot that? Thank you.

IMG_2829.JPGIMG_2830.JPGIMG_2831.jpg
 
Joined
Sep 16, 2012
Messages
26
Motherboard
P5Q with 2209 mBIOS
CPU
L5430@3.4GHz
Graphics
ASUS GT630v2 1GB Silent
Mac
  1. MacBook
  2. Mac mini
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
  2. Other
Seems like I have fixed it with the guide https://zhaomin.me/core_to_xeon.html

Guide was like except I've omitted first two steps since I had working setup I did it on.
Note for Quad Core you should put 3 (yes, it is No of Cores minus 1:)

Now testing. IF it will fail I will do follow up.
Speedster is working for sure& Cant say about C and P states since never was trying to understand them but it is not panicing with them enabled in BIOS. Sleep is working but restarts on wakeup.


  • Add cpus=1 pciroot=1 tscsync and npci=0x2000 (based on motherboard spec.) boot-args.
  • Get into dektop without GPU driver.
  • Google and download VoodooTSCSync.kext.
  • Edit VoodooTSCSync.kext/Contents/Info.plist, change the value of IOCPUNumber to x (x=CPU threads-1).
  • Change boot-args to npci=0x2000 pciroot=1.
  • Rebuild kext cache and Reboot.
 
Top