Chameleon boot loader not working

Jun 20, 2015
PC Mate Z97 LGA 1150
Intel i7 4790K
GTX 980 Ti
Hey everyone,

Been using my dual boot hackintosh for several months now and now during my OS X drive it has just froze up. When I reboot and get to the Chameleon boot loader to run Yosemite it hangs. My drives appear but when I choose which drive I want to boot (and only for OS X formatted drives) the drives disappear when I hit enter and then I am left with the theme background and no activity. Works just fine when I select Windows but no luck with. When I boot with verbose mode it runs through and again hangs with the theme background.

Any suggestions would be greatly appreciated.


I guess I should mention I made no major changes. Was encoding video when the system froze up.

UPDATE 1: Now when I run verbose mode I get a message "Can't find boot file '/System/Library/Kernels/Kernel'"

Beginning to think it might be hardware related. Maybe my SSD that has OS X installed is corrupt but that doesn't why I can't boot from a USB. Chameleon seems to ignore any OS X related drives.

UPDATE2: Got the computer to recognize OS X but now it only loads half way from Apple Logo and doesn't go any further. Tried all boot flags I know and Single, Verbose and Safe Modes. Any help is greatly appreciated.