Contribute
Register

Catalina USB Devices does not in USB Hub

Joined
Feb 14, 2020
Messages
1
Motherboard
Lenovo U410 Motherboard
CPU
Intel i5-3337U
Graphics
Intel HD Graphics 4000 + Geforce GT610M(Not used)
Mobile Phone
Android
I found my USB devices cannot be recognized properly, here is the problem:

IMG_1236.JPG

As you can see in the photo, 2 devices have been plugged to the computer, one directly, while the other plugged using a dock.
But I can only read the right one's data in the system. At first, I think it is the USB hotpatch's problem, so I chose [bat]Lenovo U4x0 to patch DSDT. After rebooting into the system, the problem remains, when I check the System Information, I found the left one is outside the USB 3.0 hub, while the right one is inside, just like this(I am sure that the readable one is the right one because of its serial number):
Screen Shot 2020-04-06 at 5.54.46 AM.png
Screen Shot 2020-04-06 at 5.54.33 AM.png

Is this the hotpatch's problem, or the power management's problem? By the way, the Bluetooth controller and the internal camera is also out of the hub, it's the reason why they are disabled?

Here is my Computer:
Lenovo U410
Intel i5-3337U 1.80Ghz
HD 4000(the Nvidia card has been disabled)

This is the Finder interface after plugged the USB Stick in:
Screen Shot 2020-04-06 at 5.58.36 AM.png


My kexts in /EFI/Clover/kexts/other:
Screen Shot 2020-04-06 at 6.07.39 AM.png


Please let me know if more information should be provided, and sorry for my poor English.
 

Attachments

Top