Contribute
Register

<< Solved >> Catalina Upgrade Stalls

Status
Not open for further replies.
Joined
Aug 28, 2016
Messages
133
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
What do you mean?
 
Joined
Aug 28, 2016
Messages
133
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
Well, again, thanks a lot!

I'll see what I can do.

Cheers.
 
Joined
May 10, 2011
Messages
2,576
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
What do you mean?
He means you can create a separate USB key/s, with its own EFI ie. Opencore 0.7.0. When you boot your system, instead of running your current EFI Clover default settings from your hard drive, you boot from the Opencore USB stick instead. That allows you to test your system with the new EFI without affecting it (because with whichever bootloader you use, you are accessing the same number of system files on the main drive).
 
Last edited:
Joined
Aug 28, 2016
Messages
133
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
He means you can create a separate USB key/s, with its own EFI ie. Opencore 0.7.0. When you boot your system, instead of running your current EFI Clover default settings from your hard drive, you boot from the Opencore USB stick instead. That allows you to test your system with the new EFI without affecting it (because with whichever bootloader you use, you are accessing the same number of system files on the main drive).
Thanks,

I made a "bootable" USB stick with unibeast for Catalina.

I have a m.2 external drive that I want to use to install the OS and test before updating my OS, However, I don't know why it is not booting. I get the "missing operating system" message.

Regards.
 
Joined
May 10, 2011
Messages
2,576
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Thanks,

I made a "bootable" USB stick with unibeast for Catalina.

I have a m.2 external drive that I want to use to install the OS and test before updating my OS, However, I don't know why it is not booting. I get the "missing operating system" message.

Regards.
It's probably caused by the way its been formatted by Unibeast (maybe formatted as Master Boot Record?). If you are using it as a USB installer, you should try to use macOS (HFS) Extended format with GUID partitioning via Disk Utility. If you plan to install the latest macOS onto it as a drive you should format it as APFS with GUID partitioning. You should also try using Apple’s USB key creation method via Terminal. I find it works better.
 
Joined
Aug 28, 2016
Messages
133
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
It's probably caused by the way its been formatted by Unibeast (maybe formatted as Master Boot Record?). If you are using it as a USB installer, you should try to use macOS (HFS) Extended format with GUID partitioning via Disk Utility. If you plan to install the latest macOS onto it as a drive you should format it as APFS with GUID partitioning. You should also try using Apple’s USB key creation method via Terminal. I find it works better.
Thanks.

I mounted the EFI partition from the USB created with Unibeast and it was empty. So I copied the EFI folder there and I'm going to run a test.

In the meantime I started creating another bootable drive with apple's USB key creation method. This following the OC instructions.

By the way, do you happen to know where can I find the appropriate kext for my "Intel® GbE LAN chip (10/100/1000 Mbit)"

With Clover I use the Intellimouse.kext, but as far as I've read, OC's Kexts are different.

Many Thanks!
 
Joined
May 10, 2011
Messages
2,576
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Thanks.

I mounted the EFI partition from the USB created with Unibeast and it was empty. So I copied the EFI folder there and I'm going to run a test.

In the meantime I started creating another bootable drive with apple's USB key creation method. This following the OC instructions.

By the way, do you happen to know where can I find the appropriate kext for my "Intel® GbE LAN chip (10/100/1000 Mbit)"

With Clover I use the Intellimouse.kext, but as far as I've read, OC's Kexts are different.

Many Thanks!
Good going! You can try IntelMausi.kext for the ethernet, that should work > https://github.com/acidanthera/IntelMausi
You're welcome.
 
Joined
Aug 28, 2016
Messages
133
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
Good going! You can try IntelMausi.kext for the ethernet, that should work > https://github.com/acidanthera/IntelMausi
You're welcome.
Well, I finally got Catalina Update.

What was wrong?

Well, Clover of course.

What did I do?

I erased clover from the EFI partition and installed a new Clover version (5103) As P1LGRIM said.

I tested the USB installer with this new clover and it booted well so that showed me I was pointing in a corect direction.

Now my USB3 ports are not working but I had the same issue in High Sierra, so I think I know what to do.

Thank you guys!
 
Status
Not open for further replies.
Top