Contribute
Register

<< Solved >> Catalina on Biostar TH55HD Socket 1156 with Sapphire Pulse RX580 - CLOVER & OC

Status
Not open for further replies.
Joined
Sep 22, 2011
Messages
1,527
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Hi, I have Mojave 10.14.6 installed on my Gigabyte G41M-Combo with Sapphire RX580 8GB Nitro running nicely.
After reading your upgrade path, I followed your instructions and managed to get to the installation screen of Catalina after the language selection part. The installation could not detect my Mojave HD for installation. Any idea what went wrong?

Did you temporarily change your MacModel to a Catalina-supported model as I described here?
 
Joined
Aug 26, 2011
Messages
23
Motherboard
Gigabyte GA-41M
CPU
Q9550
Graphics
RX 580
Mobile Phone
  1. iOS
Hi, sorry for the late response. Ya, I did temporarily changed the MacModel to MacPro6,1. It didn't work either. Guess I'll just hang on to my Mojave first. Thanks anyway.
 
Joined
Sep 22, 2011
Messages
1,527
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Hi, sorry for the late response. Ya, I did temporarily changed the MacModel to MacPro6,1. It didn't work either. Guess I'll just hang on to my Mojave first. Thanks anyway.

Are you sure you properly changed the MacModel to MacPro6,1? The only reason I can think that your Mojave disk is not recognized as a candidate partition by Catalina installer is that the Catalina installer doesn't know your SMBIOS MacModel is a supported system.

Not sure, but just to be sure, your Mojave partition is APFS?

If you want more help, please post your problem reporting files generated using Black Dragons gen_debug tool.
 
Joined
Aug 26, 2011
Messages
23
Motherboard
Gigabyte GA-41M
CPU
Q9550
Graphics
RX 580
Mobile Phone
  1. iOS
Just tried again this morning. Still the same. SSD formatted as APSF.
 

Attachments

  • 79A0B28B-18AB-4795-BD06-AF24D8762679.jpeg
    79A0B28B-18AB-4795-BD06-AF24D8762679.jpeg
    78.9 KB · Views: 71
Joined
Aug 26, 2011
Messages
23
Motherboard
Gigabyte GA-41M
CPU
Q9550
Graphics
RX 580
Mobile Phone
  1. iOS
After trying the above for many times without success, I decided to install on another rig a Gigabyte EP35-DS3 with Intel Q9500 using MacPro6,1 in SMBIOS. It worked and successfully installed Catalina without network and audio. My Fenvi wireless PCIE card also didn't work. So I went online and downloaded a patch for it. After patching, my motherboard broke, it went into a BIOS loop even after I reinstall the BIOS with QFlash. I just fried the MB but it is a 10 year old MB. Took the Catalina installation to my other rig a Gigabyte G41M with Radeon 580 card. This rig was running Mojave happily but just refused to boot the Catalina installation to the full Apple logo bar and ended with NO ENTRY sign. Tried all the SMBIOS I can think of but still doesn't work. I gave up and am considering getting a new Ryzen rig to built a Ryzentosh.
 
Joined
Sep 22, 2011
Messages
1,527
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
After trying the above for many times without success, I decided to install on another rig a Gigabyte EP35-DS3 with Intel Q9500 using MacPro6,1 in SMBIOS. It worked and successfully installed Catalina without network and audio. My Fenvi wireless PCIE card also didn't work. So I went online and downloaded a patch for it. After patching, my motherboard broke, it went into a BIOS loop even after I reinstall the BIOS with QFlash. I just fried the MB but it is a 10 year old MB. Took the Catalina installation to my other rig a Gigabyte G41M with Radeon 580 card. This rig was running Mojave happily but just refused to boot the Catalina installation to the full Apple logo bar and ended with NO ENTRY sign. Tried all the SMBIOS I can think of but still doesn't work. I gave up and am considering getting a new Ryzen rig to built a Ryzentosh.

Try adding the following Clover boot arg: amfi_get_out_of_my_way=1 and let me know if that let's you boot Catalina.
 
Joined
Sep 22, 2011
Messages
1,527
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
EDIT: An alternative to swapping the boot.efi files in Step 15 in the following procedure is to run the following command in Terminal: sudo nvram wake-failure=%00%00%00%00%00

After running this command as suggested here, I am able to keep the stock 10.15.4 boot.efi when running Catalina 10.15.4. Choose the method (command or boot.efi file replacement) that works for you.

--------------------------------------------------------------------------------

I upgraded from 10.15.3 to 10.15.4 by doing the following:
  1. Backup your Catalina 10.15.3 volume
  2. Save a copy of your 10.15.3 boot.efi (located in /System/Library/CoreServices). Thank you Herve for this tip provided here.
  3. Save your current BIOS so that you can easily reload your BIOS config (it will reset multiple times during this procedure)
  4. Create "vanilla" Catalina 10.15.4.02 installer USB
  5. Install Clover (Legacy) r5109 on the USB thumb drive and configure the thumb drive's EFI as per Post #1 in this thread with two exceptions: place all 3rd-party kexts in E/C/k/O in the thumb drive's EFI and change the SMBIOS MacModel to MacPro6,1 (Catalina won't install on MacPro5,1)
  6. Boot from the USB installer and select the Catalina installer on the USB
  7. When the first phase of the 10.15.4 install finishes, ignore the error "An error occurred while preparing the installation" and reboot
  8. Restore your BIOS config if it has reset to factory defaults and boot from your USB thumbdrive
  9. At the Clover boot screen, select the Catalina installer on your Catalina Data volume (not on the USB)
  10. When the second phase of the 10.15.4 install finishes, ignore the error "The bless tool was unable to set the current boot disk" and reboot
  11. Restore your BIOS config if it has reset to factory defaults and boot from your USB thumbdrive
  12. At the Clover boot screen, select the upgraded Catalina volume
  13. Follow the prompts to configure Catalina 10.15.4
  14. Install Clover r5109 or later on your SSD
  15. Replace your 10.15.4 boot.efi (in /System/Library/CoreServices) with the boot.efi that you copied from 10.15.3 in Step 2.
  16. Remove the USB thumb drive and reboot. With boot-arg = -no_compat_check and the the 10.15.3 boot.efi, your HackPro5,1 will boot and run Catalina 10.15.4 just fine.
  17. Remove /System/Volumes/Data/'macOS Install Data' which is left because of the error in Step #10
  18. Welcome to Catalina 10.15.4!
Potential Issues and their solutions
  • Catalina 10.15.4 installer does not recognize a suitable volume to upgrade (all volumes are grayed-out): you forgot to temporarily modify the SMBIOS MacModel (changing to MacPro6,1)
  • After upgrading, Catalina 10.15.4 boots to a "prohibited" sign: temporarily add boot-arg "amfi_get_out_of_my_way=1" for one boot to see if this clears the problem
  • Your BIOS resets after booting Catalina 10.15.4: you forgot to either run Terminal command "sudo nvram wake-failure=%00%00%00%00%00" OR to replace the 10.15.4 boot.efi with the 10.15.3 boot.efi
 
Last edited:
Joined
Aug 26, 2011
Messages
23
Motherboard
Gigabyte GA-41M
CPU
Q9550
Graphics
RX 580
Mobile Phone
  1. iOS
Just tried the amfi arg still getting to the prohibited sign. I replaced the boot.efi from my High Sierra too and using MacPro6,1 for SMBIOS.
 
Joined
Sep 22, 2011
Messages
1,527
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@seehong I've helped as much as I can without your problem reporting files. Sorry I can't be of further assistance.
 
Status
Not open for further replies.
Top