Contribute
Register

Catalina 10.15.6 + 5700 XT: Crashing under load

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,277
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Any luck testing it out Poorman9? Unfortunately, I still had two crashes last night. I noticed that audio continues to play from Music or YouTube for a several seconds after the black screen and can be paused/resumed for a brief period before everything dies.

Can someone help me with how to locate the crash in Console? I've tried to look at "Errors and Fails" during the timecodes I see the flashes and I can see the eventual system reboot but there's so much nonsense in between that it's difficult to narrow it down. When I do a search, I can't find anything related to "(com.apple.DumpGPURestart)"

try filtering for AMD
 
Joined
Oct 10, 2011
Messages
60
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700
Graphics
MSI RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Any luck testing it out Poorman9? Unfortunately, I still had two crashes last night. I noticed that audio continues to play from Music or YouTube for a several seconds after the black screen and can be paused/resumed for a brief period before everything dies.

Can someone help me with how to locate the crash in Console? I've tried to look at "Errors and Fails" during the timecodes I see the flashes and I can see the eventual system reboot but there's so much nonsense in between that it's difficult to narrow it down. When I do a search, I can't find anything related to "(com.apple.DumpGPURestart)"
About to do some testing now, just creating a full drive backup first. Here's how I track down my crashes, keep the clock open and not the exact time HH:MM:SS that the crash takes places (easy for me because it freezes and locks up until I restart). One the system restarts, open console, on the left click on system.log and browse back to the time crash took place. Hope that helps.
Screen Shot 2020-08-15 at 8.46.51 PM.png
 
Joined
Oct 10, 2011
Messages
60
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700
Graphics
MSI RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
There's also a new supplemental update for 10.15.6 just out today with updated AMD graphics drivers.

I've updated to 19G2021, native MacOS update process went smooth.
Screen Shot 2020-08-16 at 12.18.57 PM.png

Sadly crashes are still taking place. Here's the screenshoot of the system.log from when the most recent crash took place. (highlighted the DumpGPURestart that corresponded with the system time when my computer locked up.)

Screen Shot 2020-08-16 at 12.04.10 PM.png



I'd try removing DAGPM, GPUSensors and radnogva boot arg and observe

Thanks for the ideas, made the changes you recommended, also had no effect.

Curiously I was able to run the GFXBench Metal benchmarking tool, the computer made it through all the tests without crashing. Here's the results -
Screen Shot 2020-08-16 at 11.55.38 AM.png

So as of right now, the only way I can get the DumpGPU crashes is by using Cinema 4D and Octane Render (a GPU rendered). I'm starting to wonder if maybe the issue is with that specific software and my hardware is fine?

Thanks again for the time everybody.
 
Joined
May 28, 2020
Messages
15
Motherboard
Gigabyte GA-Z170X - Gaming 7
CPU
Intel® Core™ i7-6700K
Graphics
AMD Radeon RX 5700XT
One the system restarts, open console, on the left click on system.log and browse back to the time crash took place. Hope that helps.

Thank you. It helped me where to look. I haven't been as lucky to figure out exactly what I'm looking for in that section though. I've had one crash today. No sign of the DumpGPU error. I was able to locate the seconds around the crash but can't tell what exactly did it. Notice the reboot about 8 min after the highlight:


Screen Shot 2020-08-16 at 12.19.21 PM.png


Curiously I was able to run the GFXBench Metal benchmarking tool, the computer made it through all the tests without crashing. Here's the results -

Ha! We're really operating on the same wavelength. I downloaded GFXBench for the first time this morning and have been running it a bunch. The crash above was during my first run of it. I've had multiple successful completions of the tests since without crashing (but it still does cause some of the flicker or flashes sometimes). Like you, I'm starting to wonder if it's a combo of apps that are problematic. I know Chrome's hardware acceleration feature has caused a ton of issues for me in the past and I've pretty much had it open during every crash. I may try killing that function for a while.

The flashes happen quite randomly and it's not necessarily when the GPU is running near max.

VIDEO LINK: Menu Bar Flashes

When I run GFX Bench, the flashing becomes way more obvious with the tests featuring on-screen graphics. They almost look like screen tears in the GFX renders.
 
Joined
Mar 29, 2011
Messages
859
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Just FYI: there's /Library/Logs/DiagnosticReports in addition to the system log. The ones starting with "kernel," and then they have a type at the end. They're able to get saved in NVRAM and then written out to disk on the next boot, as I understand it. So those can have things that the system log didn't have a chance to save. I believe panics and the "gpuRestart" type both work that way.
 
Joined
May 28, 2020
Messages
15
Motherboard
Gigabyte GA-Z170X - Gaming 7
CPU
Intel® Core™ i7-6700K
Graphics
AMD Radeon RX 5700XT
Just FYI: there's /Library/Logs/DiagnosticReports in addition to the system log. The ones starting with "kernel," and then they have a type at the end. They're able to get saved in NVRAM and then written out to disk on the next boot, as I understand it. So those can have things that the system log didn't have a chance to save. I believe panics and the "gpuRestart" type both work that way.

Thank you for that. I wasn't able to find any files for today's crashes but I did find three from a couple of days ago that started with kernel and ended in ".gpuRestart". I've attached them here in case anyone can help me translate.
 

Attachments

  • gpuRestarts.zip
    47.2 KB · Views: 12
Joined
May 28, 2020
Messages
15
Motherboard
Gigabyte GA-Z170X - Gaming 7
CPU
Intel® Core™ i7-6700K
Graphics
AMD Radeon RX 5700XT
I did notice a few instances of this in these reports:

"ProcessName = ScreenSaverEngin"

I have noticed that if a screen saver that utilizes the GPU runs for a while, I will often come back to the frozen black screen. Disabled it for now. This seems to be unrelated to the increasing flashes crash though.
 
Joined
Jun 9, 2020
Messages
6
Motherboard
GIGABYTE Z390 GAMING-X Bios Version F9
CPU
i9 9900
Graphics
GIGABYT AMD RX 5700 XT
Hello,

Just to say that I have exactly the same kind of issue with my RX 5700 XT. Issues come when trying to work with Blender that is running perfectly fine on a another mackintosh based on a GTX 1070 Ti. I tried Mac OS big sur yesterday but had exactly the same issue (Came back to Catalina 10.15.6 yesterday night).
Hence following this thread carefully in case someone finds a solution to this problem!
Happy to share any other information of course.
 
Joined
Oct 10, 2011
Messages
60
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700
Graphics
MSI RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello,

Just to say that I have exactly the same kind of issue with my RX 5700 XT. Issues come when trying to work with Blender that is running perfectly fine on a another mackintosh based on a GTX 1070 Ti. I tried Mac OS big sur yesterday but had exactly the same issue (Came back to Catalina 10.15.6 yesterday night).
Hence following this thread carefully in case someone finds a solution to this problem!
Happy to share any other information of course.
Thanks for sharing, makes me feel less like I'm totally insane. I'm in the process of testing with OpenCore as it seems like I've pretty much hit a dead end here. Will follow up at some point.
 
Joined
May 28, 2020
Messages
15
Motherboard
Gigabyte GA-Z170X - Gaming 7
CPU
Intel® Core™ i7-6700K
Graphics
AMD Radeon RX 5700XT
Thanks for sharing, makes me feel less like I'm totally insane. I'm in the process of testing with OpenCore as it seems like I've pretty much hit a dead end here. Will follow up at some point.
I was considering trying OpenCore too. Would love to hear how it works out for you.
 
Top