Contribute
Register

Catalina 10.15.4 Supplemental Update Didn't Work - Please Help

Status
Not open for further replies.
Joined
Oct 4, 2013
Messages
21
Motherboard
Asus TUF Z390 Plus Gaming
CPU
i5 9600K @4.8GHz
Graphics
Radeon RX 580
Mobile Phone
  1. Android
Update from 10.15.1 did not work, after reboot it is still 10.15.1. So I decided to boot "MacOS Install prebooter" or something like this, thinking that the update should run off a different partition prepared before reboot. The prebooter of course didn't do it, instead it completely messed up my system. So I booted off my backup disk, which still is 10.15.1 (a backup from day before). Btw it states that the macOS is up to date - no new versions.. However, my main partition is now not working (some apfs_spec_read_wrapper errors popping forever) so I want to restore my system from the backup disk.

What I did is I do the reverse of rsync that is usually done daily from cron. This did not help. The system behaves the same - these errors. What confuses me is the data partition - macOS since Catalina uses 2 partitions. My rsync script has /Volumes excluded but obviously data partition is somehow backed up since I can normally start OS with all user data from my backup disk. There is mounted the broken Mac partition, also Mac - data. They can be unmounted. The original system appears as 2 partition of 1 disk. The backup is 1 partition. How to assemble data partition? I think I need to restore or reconstruct this partition. Any idea what I'm doing wrong? Or how to finish this broken update? Thank you very much.
 
Joined
Oct 4, 2013
Messages
21
Motherboard
Asus TUF Z390 Plus Gaming
CPU
i5 9600K @4.8GHz
Graphics
Radeon RX 580
Mobile Phone
  1. Android
Please delete this thread, I can't. The issue is not solved so I'm going to reformat and clean install.
 
Status
Not open for further replies.
Top