Can't Play iTunes Videos after 10.13.0 Supplimental and Nvidia Drivers Update

Discussion in 'Graphics' started by Scott1204, Oct 7, 2017.

  1. Scott1204

    Scott1204

    Joined:
    Dec 14, 2016
    Messages:
    146
    Mobo:
    Gigabyte Z170X-UD3 ULTRA
    CPU:
    i7700K
    Graphics:
    EVGA Nvidia GTX 1080Ti
    Mobile Phone:
    iOS
    Oct 7, 2017 at 5:54 PM #1
    Scott1204

    Scott1204

    Joined:
    Dec 14, 2016
    Messages:
    146
    Mobo:
    Gigabyte Z170X-UD3 ULTRA
    CPU:
    i7700K
    Graphics:
    EVGA Nvidia GTX 1080Ti
    Mobile Phone:
    iOS
    Thought my 1080 was working fine until I tried to play iTunes video — most files don’t play, just stay black.

    Anyone else notice? Is HDCP working with these drivers?
     
  2. CrashMidnick

    CrashMidnick

    Joined:
    Dec 15, 2015
    Messages:
    209
    Mobo:
    MSI Z270 M7
    CPU:
    Kaby Lake 7700k
    Graphics:
    GTX 1070
    Mobile Phone:
    iOS
    Oct 7, 2017 at 8:45 PM #2
    CrashMidnick

    CrashMidnick

    Joined:
    Dec 15, 2015
    Messages:
    209
    Mobo:
    MSI Z270 M7
    CPU:
    Kaby Lake 7700k
    Graphics:
    GTX 1070
    Mobile Phone:
    iOS
    There is no official web drivers at the moment for supplemental update, maybe this is the reason why you get that error ?
     
  3. umran23

    umran23

    Joined:
    May 22, 2011
    Messages:
    129
    Mobo:
    ASUS ROG MAXIMUS VIII GENE LGA 1151 Intel Z170
    CPU:
    Intel i7 6700
    Graphics:
    MSI GTX 1070 Gaming X
    Mobile Phone:
    iOS
    Oct 8, 2017 at 1:44 AM #3
    umran23

    umran23

    Joined:
    May 22, 2011
    Messages:
    129
    Mobo:
    ASUS ROG MAXIMUS VIII GENE LGA 1151 Intel Z170
    CPU:
    Intel i7 6700
    Graphics:
    MSI GTX 1070 Gaming X
    Mobile Phone:
    iOS
    nvidia drivers have been updated. You can find them here:
     

Share This Page