Contribute
Register

Can't Get VoodooI2C to work for Trackpad

Status
Not open for further replies.
Joined
Nov 23, 2016
Messages
48
Motherboard
Asus Zenbook UX305UA (Clover)
CPU
i5-6200U
Graphics
HD 520 @ 1920x1080
Mobile Phone
  1. Android
I've just recently hackintosh'd my ux305UA and gotten everything working well enough except the trackpad. I followed the guide here, https://github.com/alexandred/VoodooI2C/blob/master/Documentation/Installation.md, unfortunately the trackpad is still not working. It runs Elan1000, and previous versions of this VoodooI2C did correctly work on this laptop, yet I can't figure out what's wrong this time. Please check my files and tell me if anything seems off. Thanks in advance.
 

Attachments

  • Problem Reporting Files.zip
    2.3 MB · Views: 85
Joined
Apr 21, 2016
Messages
1,011
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
I've just recently hackintosh'd my ux305UA and gotten everything working well enough except the trackpad. I followed the guide here, https://github.com/alexandred/VoodooI2C/blob/master/Documentation/Installation.md, unfortunately the trackpad is still not working. It runs Elan1000, and previous versions of this VoodooI2C did correctly work on this laptop, yet I can't figure out what's wrong this time. Please check my files and tell me if anything seems off. Thanks in advance.
Seems like you have an ELAN0100, not ELAN1000. They both use the VoodooI2CELAN satellite though.

-Kexts should be installed to /Library/Extensions. Not /System/Library/Extensions.
-You didn't follow the GPIO pinning guide:
https://voodooi2c.github.io/#GPIO Pinning/GPIO Pinning
-2 OS Patches are wrong. Revert the Windows 2013 patch.
-No need to remove Apple LPSS kexts, just use CoolStar's patches. You can revert them by running the macOS installer (Don't format the drive, of course).

After you make those changes, and if it's still not working, upload a new set of files.
You don't need to collect them manually, just use gen_debug.sh (It'll also collect more data):
https://www.tonymacx86.com/threads/tool-generate-proper-problem-reporting-files.235953/
 
Joined
Nov 23, 2016
Messages
48
Motherboard
Asus Zenbook UX305UA (Clover)
CPU
i5-6200U
Graphics
HD 520 @ 1920x1080
Mobile Phone
  1. Android
Seems like you have an ELAN0100, not ELAN1000. They both use the VoodooI2CELAN satellite though.

-Kexts should be installed to /Library/Extensions. Not /System/Library/Extensions.
-You didn't follow the GPIO pinning guide:
https://voodooi2c.github.io/#GPIO Pinning/GPIO Pinning
-2 OS Patches are wrong. Revert the Windows 2013 patch.
-No need to remove Apple LPSS kexts, just use CoolStar's patches. You can revert them by running the macOS installer (Don't format the drive, of course).

After you make those changes, and if it's still not working, upload a new set of files.
You don't need to collect them manually, just use gen_debug.sh (It'll also collect more data):
https://www.tonymacx86.com/threads/tool-generate-proper-problem-reporting-files.235953/

Thanks for the advice, how exactly would I recert the next patches? Would I just look for the rewritten code and manually do it?

Also, how would I run the installer without rewriting the hard drive?
 
Joined
Apr 21, 2016
Messages
1,011
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
Thanks for the advice, how exactly would I recert the next patches? Would I just look for the rewritten code and manually do it?

Also, how would I run the installer without rewriting the hard drive?
To revert that OS patch, change this:
Code:
If(LOr(_OSI("Darwin"),_OSI("Windows 2013")))
Back to this:
Code:
If _OSI ("Windows 2013"))

Just run the installer and select your macOS partition. Simple as that.
 
Status
Not open for further replies.
Top