Contribute
Register

Can't Get to Installer- Sabertooth X79, 4930k, GTX 760

Status
Not open for further replies.
Joined
Jan 28, 2013
Messages
10
Motherboard
Asus Sabertooth X79
CPU
Intel Core i7-4930K
Graphics
EVGA GTX 760 SC 4GB
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Classic Mac
Mobile Phone
  1. iOS
This is the first Hackintosh build I've ever attempted. I have an existing Windows machine that I would love to run Mac OS X. I removed the drive with the Windows partition, inserted a left-over SSD and followed the guide for installing 10.9 to the letter, but I can't seem to make it to the installer. I've tried a variety of boot arguments, but can never make it all the way.

The parts in my build are as follows:

Corsair C70 Chasis
ASUS X79 Sabertooth Mainboard (bios 4502, set to defaults)
Intel 4930K CPU (running at stock clock speed)
Corsair H100i CPU Cooler
EVGA GTX 760 SC 4GB GPU
Crucial Ballistix 1 x 8GB DDR3 1600MHz Memory Module (Place-Holder for Corsair Vengeance Pro 8 x 8GB Memory Modules)
Crucial M4 128GB SSD (Place-Holder for Samsung 840 Pro 512GB SSD)
Corsair AX860i PSU

Any help in this would be much appreciated!
 
Joined
Nov 27, 2010
Messages
47
Motherboard
Gigabyte X58A-UD5, Asus P9X79WS
CPU
i7 3500, Xeon E5 2620
Graphics
Nvidia GeForce 9800 GT, GTX 670 x 2
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Classic Mac
Mobile Phone
  1. iOS
Saw your post on a similar thread.

You need a patched kernel for Ivy Bridge-E cpus. I don't see it in the download section, Google around. I think a guy named stinga11 modded it. He may be on this forum, too, I don't recall.

Someone on that thread also put npci=0x3000. I think 0x2000 is probably correct for your board.

David

ETA: Looked over your hardware again. Should be a very nice rig once you get up and going. One of my HackPros is an X79 rig.
 
Joined
Jan 28, 2013
Messages
10
Motherboard
Asus Sabertooth X79
CPU
Intel Core i7-4930K
Graphics
EVGA GTX 760 SC 4GB
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Classic Mac
Mobile Phone
  1. iOS
Thanks for the assistance, David. I'll have a chance to try this out once I get home this evening. I'll update after.

I'm also really excited about this build. I've been a Mac user for my mobile solution for some time, but I'm excited to get a Mac with some real power behind it for my video/ graphics work.
 
Joined
Jan 28, 2013
Messages
10
Motherboard
Asus Sabertooth X79
CPU
Intel Core i7-4930K
Graphics
EVGA GTX 760 SC 4GB
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Classic Mac
Mobile Phone
  1. iOS
I successfully found stinga11's modded kext for Ivy Bridge-E support and applied it successfully, but I'm still not making it al the way to the installer. I'm getting further, but it will stop. I see this when booting verbose, right before the display goes black:
IMG_0553.jpg
Any ideas?
 
Joined
Nov 27, 2010
Messages
47
Motherboard
Gigabyte X58A-UD5, Asus P9X79WS
CPU
i7 3500, Xeon E5 2620
Graphics
Nvidia GeForce 9800 GT, GTX 670 x 2
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Classic Mac
Mobile Phone
  1. iOS
Huh... I'm trying to read the screenshot. Can you send me your email?
David

ETA:
Should not be a kext, just a kernel.
Also, are you specifying any additional PciRootUID info?
 

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,367
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Other
Huh... I'm trying to read the screenshot. Can you send me your email?
David

ETA:
Should not be a kext, just a kernel.
Also, are you specifying any additional PciRootUID info?


Click on the image to enlarge it.

@thepaperclipper,

Reboot and try the same again - when it sticks try to quickly remove and then replace the USB flash drive.

Adrian B
 
Joined
Jul 1, 2012
Messages
25
Motherboard
My Golden Hac Pro
CPU
Intel Core i7 3930K
Graphics
AMD 6850
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Ok, I have the same motherboard as you. But I have 3930K CPU.

In order to get to the installer. I have to use npci=0x3000 exclusively everytime. Try that and let me know.
 
Joined
Nov 27, 2010
Messages
47
Motherboard
Gigabyte X58A-UD5, Asus P9X79WS
CPU
i7 3500, Xeon E5 2620
Graphics
Nvidia GeForce 9800 GT, GTX 670 x 2
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Classic Mac
Mobile Phone
  1. iOS
Can you list all the boot flags you are using?
(manually and with the boot.plist)
 
Joined
Jul 1, 2012
Messages
25
Motherboard
My Golden Hac Pro
CPU
Intel Core i7 3930K
Graphics
AMD 6850
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Can you list all the boot flags you are using?
(manually and with the boot.plist)


Here is my manual code at the time of installation.

-v GraphicsEnabler=No npci=0x3000 cpus=1

My boot.plist.


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot Banner</key>
<string>No</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>IGPEnabler</key>
<string>Yes</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>npci=0x3000</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>UseKernelCache</key>
<string>No</string>
</dict>
</plist>

For some reason I can't use Timeout. If I have timeout it doesn't start I get error waiting for root device...So I have omitted it. I have to select disk everytime I restart. I can live without that. Also, I don't need AppleHDA as I have usb card sound card that works fine.
 
Status
Not open for further replies.
Top