Contribute
Register

Can't get graphics to work Kaby Lake 620 with WhateverGreen

Status
Not open for further replies.

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,535
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Agreed, thanks. But that still doesn't solve the graphics in Mojave sadly.
use one from the laptop guide:

Use this tool and upload your problem reporting files:
 
Joined
Jul 11, 2019
Messages
35
Motherboard
Lenovo Miix 720-Clover
CPU
i5-7200U
Graphics
HD 620, 2880 x 1920
use one from the laptop guide:

Use this tool and upload your problem reporting files:

I tried the config from the laptop guide (https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD615_620_630_640_650.plist). I did this prior to posting this thread and tried again on the recommendation of @mpckid after. That config doesn't work for me, I always get stuck at exactly the same point, which is gioScreenLockState 3.

To recap, I tried:

1. Config from the guide (https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD615_620_630_640_650.plist) - Freezes at gioScreenLockState
2. Basic Config from UniBeast using MacBook SMBIOS, updated with WhateverGreen guide at https://www.tonymacx86.com/threads/guide-intel-framebuffer-patching-using-whatevergreen.256490/ and ig-platform-id 0x59160000 - Freezes at gioScreenLockState. I tried adding boot flags -disablegfxfirmware -cdfon and -disablegfxfirmware, all make no difference.
3. 2 Different configs provided by @mpckid in this thread. Those actually don't freeze but cause panics. The main difference being that those configs are using ig-platform-id 0x19160000, which seems to cause the panic.

If there is any other alternative to try, I will use the tool to upload problem reporting files, but I've got a feeling that this device just won't work with Mojave full stop. It'd be interesting to hear from someone with a Lenovo Miix 720 that has actually gotten graphics to work in Mojave, I discovered a thread by @Promise (https://www.tonymacx86.com/threads/having-trouble-getting-my-hd620-working.262860/#post-1832536) where he seemed to have struggled with the same issue. Don't think it ever got resolved....
 
Joined
Jul 11, 2019
Messages
35
Motherboard
Lenovo Miix 720-Clover
CPU
i5-7200U
Graphics
HD 620, 2880 x 1920
Oh and forgot 1 other thing I tried in the recap:

4. Used Hackintool to generate Devices/Properties. Also got stuck at gioScreenLockState 3.
 
Joined
Jul 11, 2019
Messages
35
Motherboard
Lenovo Miix 720-Clover
CPU
i5-7200U
Graphics
HD 620, 2880 x 1920
OK, I reinstalled from scratch, only installed Lilu and WhateverGreen and used the config from the laptop guide. Now I get a panic. Problem reporting attached. Can anyone help?
 

Attachments

  • debug_22731.zip
    1.3 MB · Views: 35

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,535
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
OK, I reinstalled from scratch, only installed Lilu and WhateverGreen and used the config from the laptop guide. Now I get a panic. Problem reporting attached. Can anyone help?
FakeSMC kext missing from /L/E (also verbose image of panic)
 
Joined
Jul 11, 2019
Messages
35
Motherboard
Lenovo Miix 720-Clover
CPU
i5-7200U
Graphics
HD 620, 2880 x 1920
Installed FakeSMC to L/E. Realised the config I used was labelled the same as the laptop guide but was different. Redownloaded from GitHub and now stuck at gioScreenLockState again, no panic. Tried both Spoof and non-spoof versions of config_HD615_620_630_640_650.
 

Attachments

  • screen.jpg
    screen.jpg
    2.9 MB · Views: 37
  • debug_30835.zip
    1.6 MB · Views: 37

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,535
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Installed FakeSMC to L/E. Realised the config I used was labelled the same as the laptop guide but was different. Redownloaded from GitHub and now stuck at gioScreenLockState again, no panic. Tried both Spoof and non-spoof versions of config_HD615_620_630_640_650.
maybe have look at:
 
Joined
Oct 21, 2015
Messages
83
Motherboard
HP Pavilion x360 m3-u103dx
CPU
i5-7200U
Graphics
HD620
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Take this configuration againhttps://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD615_620_630_640_650.plist

Try with boot arg lilucpu=7 instead of 9 and Inject Intel as true.
Set Inject ATI and Nvidia as false.

This should at least allow you to enter the OS to run Hackintool and/or make configuration changes as needed.

Read the guide on how to use Hackintool for graphics.
Take a look at what hot patches you're applying on Clover and see if they are valid.
I think you will need a few of them if not all. I'd try one by one and see.
You can adjust your config.plist on the fly during the boot loader Clover options.
Go to the corresponding menus to enable/disable SSDT hot patches on the fly.

Read this all over again -

Read IMPORTANT and Prerequisite section here -

Try this hot patch, I had to spoof my Kaby Lake HD620 to Skylake (that's why I have the 0x19160000)
You'll need to compile that into an AML using MaciASL (RehabMan's version) and place into Clover/ACPI/patched folder.

Keep on going you're almost at the end of this nightmare.
 
Status
Not open for further replies.
Top