Contribute
Register

Can't get Bcm20702 Bluetooth to work (Sierra)

Status
Not open for further replies.
Joined
Mar 21, 2017
Messages
6
Motherboard
P5Q - Pro
CPU
Xeon 5460
Graphics
GTX 970
Mobile Phone
  1. iOS
Hello,

I bought this dongle after some research https://www.gmyle.com/products/ubbtadpud400m and I installed BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext kexts using Kextbeast. After rebooting with verbose mode on, I am seeing this log, found only one or two previous examples to this error and they did not help me. Computer boots up to a black screen and nothing happens. If I unplug the dongle computer boots up normally.

I tried
sudo touch /System/Library/Extensions && sudo kextcache -u /
Did not help me. Can anyone point me to the right direction?

Any help would be appreciated
2017-04-10 21.48.21.jpg
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello,

I bought this dongle after some research https://www.gmyle.com/products/ubbtadpud400m and I installed BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext kexts using Kextbeast. After rebooting with verbose mode on, I am seeing this log, found only one or two previous examples to this error and they did not help me. Computer boots up to a black screen and nothing happens. If I unplug the dongle computer boots up normally.

I tried
sudo touch /System/Library/Extensions && sudo kextcache -u /
Did not help me. Can anyone point me to the right direction?

Any help would be appreciatedView attachment 247431

The logs indicate the kexts are installed incorrectly. Looks to me that BrcmPatchRAM2.kext is installed but not BrcmFirmwareRepo.kext, or you installed mixed versions of the kexts.

Remove both (from wherever they may be installed), then download from my bitbucket site to make sure you have a matched set. Install with Kext Wizard.
 
Joined
Mar 21, 2017
Messages
6
Motherboard
P5Q - Pro
CPU
Xeon 5460
Graphics
GTX 970
Mobile Phone
  1. iOS
The logs indicate the kexts are installed incorrectly. Looks to me that BrcmPatchRAM2.kext is installed but not BrcmFirmwareRepo.kext, or you installed mixed versions of the kexts.

Remove both (from wherever they may be installed), then download from my bitbucket site to make sure you have a matched set. Install with Kext Wizard.

I was already using the kexts from your bitbucket site, removed BrcmFirmwareRepo and BrcmPatchRAM2 from System/Library/Extensions, they were only there, did not install kexts or copied to any other folder, and reinstalled with Kext Wizard, used its repair missions and rebuild cache after installing, rebooted again.

Exactly the same problem. Am I missing something?
 
Joined
Mar 21, 2017
Messages
6
Motherboard
P5Q - Pro
CPU
Xeon 5460
Graphics
GTX 970
Mobile Phone
  1. iOS
I reinstalled macOS Sierra, hoping this error would be disappear. I am able to boot after those errors now, previously nothing was happening after those errors, only showing black screen. But again without bluetooth working. Only difference of my build and regular hackintosh may be the old motherboard. Can this happen because of P5Q - Pro?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Mar 21, 2017
Messages
6
Motherboard
P5Q - Pro
CPU
Xeon 5460
Graphics
GTX 970
Mobile Phone
  1. iOS
Problem still persists, I have finally find time to read "Problem Reporting" and I attached ioreg, aml files and clover.

Output of kexstats
Code:
eralpsahins-iMac:Attachments eralpsahin$ kextstat|grep -y acpiplat
   13    1 0xffffff7f82c43000 0x60000    0x60000    com.apple.driver.AppleACPIPlatform (5.0) 65E05472-6AE7-3308-8CC8-FA6CB0DB2AEE <12 11 7 6 5 4 3 1>
eralpsahins-iMac:Attachments eralpsahin$ kextstat|grep -y appleintelcpu
   25    0 0xffffff7f8289f000 0x2b000    0x2b000    com.apple.driver.AppleIntelCPUPowerManagement (219.0.0) C2841490-D1F6-30D4-AC81-48D63A8FA04C <7 6 5 4 3 1>
   31    0 0xffffff7f8289a000 0x3000     0x3000     com.apple.driver.AppleIntelCPUPowerManagementClient (219.0.0) B802638B-251C-3602-BA8C-001F87228765 <7 6 5 4 3 1>
eralpsahins-iMac:Attachments eralpsahin$ kextstat|grep -y applelpc
eralpsahins-iMac:Attachments eralpsahin$ kextstat|grep -y applehda
   72    1 0xffffff7f82944000 0x1d000    0x1d000    com.apple.driver.AppleHDAController (279.48) ED51F180-19C8-3DE1-AF81-0E389D98ADDE <71 70 62 12 7 6 5 4 3 1>
  110    0 0xffffff7f82ac6000 0xb5000    0xb5000    com.apple.driver.AppleHDA (279.48) 806B8C17-50CA-3C6B-90B3-195F38D8FB89 <109 75 72 71 70 62 6 5 4 3 1>

This one only waits for the lock and then acquires it, does nothing else.
Code:
eralpsahins-iMac:Attachments eralpsahin$ sudo touch /System/Library/Extensions && sudo kextcache -u /
/ locked; waiting for lock.
Lock acquired; proceeding.
eralpsahins-iMac:Attachments eralpsahin$
 

Attachments

  • CLOVER.zip
    1.7 MB · Views: 62
  • Downloads-Rehabman.zip
    17.7 KB · Views: 83
  • eralpsahin’s iMac.ioreg
    5.9 MB · Views: 132

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Problem still persists, I have finally find time to read "Problem Reporting" and I attached ioreg, aml files and clover.

Output of kexstats
Code:
eralpsahins-iMac:Attachments eralpsahin$ kextstat|grep -y acpiplat
   13    1 0xffffff7f82c43000 0x60000    0x60000    com.apple.driver.AppleACPIPlatform (5.0) 65E05472-6AE7-3308-8CC8-FA6CB0DB2AEE <12 11 7 6 5 4 3 1>
eralpsahins-iMac:Attachments eralpsahin$ kextstat|grep -y appleintelcpu
   25    0 0xffffff7f8289f000 0x2b000    0x2b000    com.apple.driver.AppleIntelCPUPowerManagement (219.0.0) C2841490-D1F6-30D4-AC81-48D63A8FA04C <7 6 5 4 3 1>
   31    0 0xffffff7f8289a000 0x3000     0x3000     com.apple.driver.AppleIntelCPUPowerManagementClient (219.0.0) B802638B-251C-3602-BA8C-001F87228765 <7 6 5 4 3 1>
eralpsahins-iMac:Attachments eralpsahin$ kextstat|grep -y applelpc
eralpsahins-iMac:Attachments eralpsahin$ kextstat|grep -y applehda
   72    1 0xffffff7f82944000 0x1d000    0x1d000    com.apple.driver.AppleHDAController (279.48) ED51F180-19C8-3DE1-AF81-0E389D98ADDE <71 70 62 12 7 6 5 4 3 1>
  110    0 0xffffff7f82ac6000 0xb5000    0xb5000    com.apple.driver.AppleHDA (279.48) 806B8C17-50CA-3C6B-90B3-195F38D8FB89 <109 75 72 71 70 62 6 5 4 3 1>

This one only waits for the lock and then acquires it, does nothing else.
Code:
eralpsahins-iMac:Attachments eralpsahin$ sudo touch /System/Library/Extensions && sudo kextcache -u /
/ locked; waiting for lock.
Lock acquired; proceeding.
eralpsahins-iMac:Attachments eralpsahin$

Your ioreg shows bluetooth connected to USB1.
Connect to a USB2 header.
 
Joined
Mar 21, 2017
Messages
6
Motherboard
P5Q - Pro
CPU
Xeon 5460
Graphics
GTX 970
Mobile Phone
  1. iOS
Your ioreg shows bluetooth connected to USB1.
Connect to a USB2 header.

I tried every single port, and looked bios settings if there were something related to usb2 but the dongle was never showing up at usb2, while doing this I broke my mechanical keyboard, I do not know how but it was not working anymore light was blinking with 10 seconds delay. So I tried to figure out what was wrong with my keyboard, I plugged it to my macbook pro usb, still same problem. Then I plugged it to a usb3.0 hub which was connected to my macbook pro. It worked with the hub. So I connected my keyboard to my desktop with the hub, keyboard and the hub showed as connected to usb2.0, so I connected the dongle to the hub and voila, bluetooth is working now. But now I need to use a hub with them.

That keyboard problem is really weird, it only works with hub, tried with my hackintosh desktop, macbook pro, and surface laptop, blinking looks like not enough power is going to the keyboard but how can it be solved with the hub, weird.

Thanks for the help.

Edit: Tried with another hub, this time usb 2.0, keyboard and dongle works with this hub too. I understand the dongle, correct driver for my motherboard is not installed or something like that, but why did my keyboard started to act like dongle :D, whatever just wanted to share my experience.
 
Last edited:
Joined
Sep 23, 2012
Messages
2
Motherboard
MSI X58 Pro-E
CPU
X5650
Graphics
GTX260
Mac
  1. MacBook Air
Status
Not open for further replies.
Top