Contribute
Register

Can't get ALC298 working

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Forgot my PR files from after installing.
If there are other layout-id values supported for your audio codec by AppleALC.kext, try them.
 
Joined
Mar 8, 2017
Messages
63
Motherboard
Razer Blade 2018 - C1_MB
CPU
i7-8750H/HM370
Graphics
UHD630 + GTX 1070, 3840x2160
Mobile Phone
Android
@RehabMan

It seems to be working right now, done three reboots - still fully working.

So what have I done to get to this point (for others who may read this):
  • AppleALC.kext with Devices/Properties layout-id 30
  • CodecCommander.kext
  • Background-Demon for Plug-Fix (just google it, you should find it)

Happy to finally got it working, I hope it stays like this...
 
Joined
Mar 8, 2017
Messages
63
Motherboard
Razer Blade 2018 - C1_MB
CPU
i7-8750H/HM370
Graphics
UHD630 + GTX 1070, 3840x2160
Mobile Phone
Android
Ouh, I just recognized that my speakers are not working, only audio-jack. Maybe investigate that later today, but I don't really use them much anywayas. Probably a demon-issue, it does not switch if plug is used.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Ouh, I just recognized that my speakers are not working, only audio-jack. Maybe investigate that later today, but I don't really use them much anywayas. Probably a demon-issue, it does not switch if plug is used.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Mar 8, 2017
Messages
63
Motherboard
Razer Blade 2018 - C1_MB
CPU
i7-8750H/HM370
Graphics
UHD630 + GTX 1070, 3840x2160
Mobile Phone
Android
@RehabMan

Yeah... So:

  • Layout-ID 29 -> Speakers and Jack working, but after some time it turns into sh**
  • Layout-ID 30 -> Speakers not working, Jack works: When lucky I even have working audio for the whole session till reboot, depends on something during booting I guess
So it seems that 29 is the way to go, all other don't work out at all. I've tested: 3, 11, 13, 28, 29, 30, 47, 66, 72, 99

Both debugs are attached, ID 29 and 30.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
@RehabMan

Yeah... So:

  • Layout-ID 29 -> Speakers and Jack working, but after some time it turns into sh**
  • Layout-ID 30 -> Speakers not working, Jack works: When lucky I even have working audio for the whole session till reboot, depends on something during booting I guess
So it seems that 29 is the way to go, all other don't work out at all. I've tested: 3, 11, 13, 28, 29, 30, 47, 66, 72, 99

Both debugs are attached, ID 29 and 30.
You may need to customize AppleALC for your hardware.
 
Joined
Mar 8, 2017
Messages
63
Motherboard
Razer Blade 2018 - C1_MB
CPU
i7-8750H/HM370
Graphics
UHD630 + GTX 1070, 3840x2160
Mobile Phone
Android
@RehabMan

Is there a guide available for that kind of customisation / patching?
TBH - I really have no idea how to go on about that problem.

Thank you! :)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
@RehabMan

Is there a guide available for that kind of customisation / patching?
TBH - I really have no idea how to go on about that problem.

Thank you! :)
Refer to AppleALC documentation on github.
Note: Developer skills required.
 
Top