Contribute
Register

Can't download apps from App Store

Joined
Feb 20, 2020
Messages
3
Motherboard
Asus Maximus IX Fomula
CPU
7700k
Graphics
GTX 1080 Ti
Hey guys I'm new in this forum (first post), but I have experience with Hackintosh builds.
I've tried every single solution I found in the forum, but none of them solved my problem.

My system version: macOS 10.13.6 (17G11023)

I have a new hackintosh up and running. Everything works 100%, but App Store won't let me install apps.
When I press install it just stays green and nothing happens. No errors, no crashing, nothing!

Screen Shot 2020-02-22 at 7.24.55 PM.png


I've configured my SMBios, Variables, etc! I'm even signed into iCloud.
Let me know what info you need (if you can help me).

In console i'm getting this error, IDK if is this the problem.

Screen Shot 2020-02-22 at 7.29.51 PM.png
Screen Shot 2020-02-22 at 7.33.00 PM.png



Also attaching my config.plist
 

Attachments

  • config.plist.zip
    2.5 KB · Views: 41
Joined
May 9, 2016
Messages
2
Motherboard
MSI Z97-I ac
CPU
i7-5775C
Graphics
Iris Pro 6200
Mac
  1. iMac
Mobile Phone
  1. Android
Hi . I'm noob. My problem is almost the same of yours.
Are you logged on App Store? I can't even login on App Store. I could download Catalina and install. But with Pages, Unarchiver etc, I can see the green button "install" and click on it. After this the button turns " GET" again and nothing happens. No error messages. Nothing. I can not even see my purchased items. It just stay on the "sign in" page. I fill my account and password and the screen stay the same way like I never tried to login. iCloud is working.
 
Joined
May 9, 2016
Messages
2
Motherboard
MSI Z97-I ac
CPU
i7-5775C
Graphics
Iris Pro 6200
Mac
  1. iMac
Mobile Phone
  1. Android
Hi. Im back just to say that if you use an "usb wifi" and did'n install your onboard wired cards , you will face the same problem that mine. ( click on download and nothing happens ) . I just install my dual RTL8111 and App Sore release the downloads. I known its kinda stupid, but worked on my test table, where I have to use usb wifi to install my pcs and do not have net cables there
 
Joined
Jul 31, 2015
Messages
70
Motherboard
MSI B75A-G43
CPU
i5-6400
Graphics
GTX 660
Mobile Phone
  1. Android
im tried every RealtekRTL8111.kext `s(v2.0.0/v2.1.0d1/v2.2.2) from MultiBeast, but still nothing happens when i click download any app from app store

Up,
hm, just now its start working but i didnt understood what happened, two reasons
1. im confirmed my phone number in System Preferences
2. im did install correct driver, dont remember which one but some of v2.0.0 or v2.1.0d1
 
Last edited:
Top