Contribute
Register

Cant boot to Mojave after installation - ASUS Zenbook 533FD

Joined
Jul 20, 2019
Messages
1
Motherboard
ASUS
CPU
i7-8565U
Graphics
Intel UHD 620, Nvidia GTX 1050 with Max Q
Few days ago I bought ASUS Zenbook 533FD for my CS classes. I wanted to install mac OS Mojave, so I tried to do it. It's been a while since I installed Hackintosh to PC. The last successful one was Mojave on my HP Envy 17. I researched about some new info about hackintoshing new PCs because my old one was 5 years old. I had found some difficulties as:

Spoofing IGPU( My laptop come with i7-8565U(Whiskey Lake-U) which is not natively supported in macOS as its IGPU (UHD 620)). I tried to use Rehabman's clover config and it's boot installer.

I2C Touchpad(ELAN 1200) instead of PS2 Trackpad(I used external mouse instead of internal one)

Lot's of DSDT patches to be applied.

I managed to install it and boot. But there is no sound, no touchpad, WIFI, lots of other things and the worst one is no QE/CI.

I tried to look at other builds with almost same configuration except CPU. I found guides with models ASUS Q405UA and one with Zenbook models before 2018. But there is no change. Then I tried to find some other configurations with just same CPU. I had found one another sit. I tried it with some modifications and it gets QE/CI. But after restarting it something goes wrong, so I cant boot and something damaged my SSD. So I need to reinstall macOS. The latter configuration of QE/CI is gone.

Then comes another treat before macOS can be installed ASUS BIOS update. After it I had noticed some ACPI errors while booting verbose in CLOVER. I hardly managed to reinstall it and even boot first time. But after the restart of it after install Android Tether driver for macOS (I don't have Ethernet at home), I can't boot it. I don't know what to do what configuration to use, it's new for me to work with such hardware. Also I need some help for post install.

Also I tried to remove FakeSMC and use VirtualSMC, use configs from guides to boot, nothing helps. It either shows errors like in screenshot below, just shows black screen.


There is my CLOVER Setup with dumped ACPI and minimal kexts from Rehabman's Laptop install guide and screenshot from clover bootloader in attachments below:

Guides that I used:

***Update: I managed to boot device but I get apple logo sticker or booted start up login page with inner layer behind(apple logo, can't click no where). I tried to play with lilu patching via devices, but I can't get right one. I have tried coffeelake and kaybeylake injections but no result.


P.S. Sorry for my bad English
 

Attachments

  • CLOVER-INST.zip
    1.1 MB · Views: 24
  • clover-log.thumb.jpg.09eddebf68347f0450f8a9083b9b0cdd.jpg
    clover-log.thumb.jpg.09eddebf68347f0450f8a9083b9b0cdd.jpg
    135.3 KB · Views: 38
Last edited:
Top