Contribute
Register

Cant boot linux through Clover

Joined
Jun 21, 2013
Messages
10
CPU
i5-8250u
Graphics
Mx150
Mobile Phone
  1. Android
Hi, I had a triple boot on my Xiaomi Mi notebook pro, I can boot my pc with clover and see my 3 os (elementary os, OSX and windows) OSX and Windows works like a charm, but when i go into linux it reminds me into the grub and choosing "elementary os" bring me to a black screen. But if i boot the linux partition without passing through Clover it starts normally. I guess thats some problem in my EFI partition.

SPECS
SSD1: Windows
SSD2: OSX/Linux
All installed in UEFI, no mbr.
I ll be glad to the one who will help me.
Thanks
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,264
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Check EFI/Clover/Linux folder for X64 UEFI Grub boot loader.
 
Joined
Nov 27, 2018
Messages
5
Mac
  1. MacBook Pro
On my PC i have Clover on USB drive and whenever i put it in it boots the Clover->OSX.
If the drive is not inserted it boots the Windows/Linux (whatever is on the drive). Its very easy and protects your boot data from the other OS.

What is this black screen you getting ? does it says something about "grub>"
Maybe your order of drives has changed and grub doesnt recognize this order of SSD on your motherboard, did you switch the drives recently ?
Since when the problem started ? After upgrade on the linux ?

Can you press 'e' on the grub screen where you see 'elementary os' ? can you edit the kernel line (should be linux..... /boot/...vmlinuz/linux-image-xxx... remove the "quiet splash" words and boot with F10 or Ctrl+X.

Could be anything... Is there a rescue kernel in the grub ? can you boot it ?

Update: https://www.tonymacx86.com/threads/help-booting-systemd-arch-efi-with-clover.188191/
that guy had similar/same problem, but solved it in a massacre way copying the kernel... you can still check what he experienced and what he did, but his way of solving is not correct. Let me know if you need further help.

Update2: try to put "nomodeset" instead of "quiet splash" on the kernel line
 
Last edited:
Joined
Feb 23, 2019
Messages
1
Hi there,
I got the same problem here on Xiaomi mi notebook pro. The only difference is that I'm trying to triple boot Windows/macOs/Ubuntu.
Anyway I got stucked when I try to boot Ubuntu from Clover bootloader, if I click the Ubuntu entry it brings me to the gub but then if I click on the entry for booting Ubuntu I got purple screen and it's stucked.
The weird thing is that if I manage to boot "manually" Ubuntu from BIOS it will work normally. Remainders 2 OS work fine.
Any idea?
I also read something about directly booting Ubuntu from clover, without displaying its grub, but I could't manage to do it.
Thanks in advance
 
Joined
Oct 9, 2018
Messages
1
Motherboard
and
CPU
intel i5
Graphics
gtx 1070
Hi there,
I got the same problem here on Xiaomi mi notebook pro. The only difference is that I'm trying to triple boot Windows/macOs/Ubuntu.
Anyway I got stucked when I try to boot Ubuntu from Clover bootloader, if I click the Ubuntu entry it brings me to the gub but then if I click on the entry for booting Ubuntu I got purple screen and it's stucked.
The weird thing is that if I manage to boot "manually" Ubuntu from BIOS it will work normally. Remainders 2 OS work fine.
Any idea?
I also read something about directly booting Ubuntu from clover, without displaying its grub, but I could't manage to do it.
Thanks in advance

hello, did you manage to solve? i have the same problem
 
Joined
Jul 29, 2016
Messages
93
Motherboard
ASUS MAXIMUS VII Formula
CPU
i7-4790K
Graphics
RX 580
Mac
  1. iMac
Over 2 years later... anyone get linux to boot in clover? Please help
 
Top