Contribute
Register

can't boot, blank screen; APCIPlatform copy :(

Status
Not open for further replies.
Joined
Nov 1, 2010
Messages
8
Motherboard
Asus P7H57D-evo
CPU
i5 - 760
Graphics
nvidia - asus ENGT240
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
So I've been pretty dumb. I was trying to update to mountain lion. I followed the guide but I kept noticing that 'About This Mac' reported that I was still on 10.7 not 10.8.2! I googled this problem and got some blog (that I trusted for some reason). It told me that this happens and I needed to deleted AppleAPCIPlatform.kext and download one from https://www.dropbox.com/sh/aetw9dhycpmr0i4/sfHGsecg3W . Then repair the drive.
After doing this I should reboot and all would be ok...... Well here I am with a non-bootable system. Normally I would go into the installer terminal and take my backup copy, but I can't load the installer or the new usb drive I've made.
So the problem:
Installed system crashes due to a copied AppleAPCIPlatform.kext KP with: Unable to find driver for this platform: ACPI SourceCache/xnu/....

Installer and USB unibeast loads but sits quitely with the spinning apple logo loading screen (MAC Framework successfully initialized using 16384 buffer headers and 10240 cluster IO buffer headers). I've tried -x, -x -f, npci=0x2000, GraphicsEnabler=No, GraphicsEnabler=No npci=0x2000 -v
I've also tried using a ubuntu disc to access the hard drive but since the drive is journaled I can't write to it :(

Any ideas ?

Thank you in advance.




EDIT: got it working. I removed all but 4Gb of ram, disconnected all the other drives and ran the usb installer with npic=0x2000 PCIRootUID=0 -v. Installed a new system, lets hope it works now !!
 
Status
Not open for further replies.
Top