Contribute
Register

Cannot update iPad and iPhone: Error 11

Joined
May 7, 2014
Messages
47
Motherboard
asus z97-pro wifi / Clover
CPU
i7 4970k
Graphics
intel 4600
Mac
MacBook
Mobile Phone
iOS
I wanted to update my new iPhone 7 to 10.1 via iTunes (iTunes 12.5.2.35, MacOSX 10.11.6). After iTunes had finished extracting the new firmware, iTunes told me that an unexpected error (11) occurred. My iPhone stayed on iOS 10.0.2.
I did all the tricks I could find in the internet (e.g. new cables, updating iTunes, disconnecting almost all usb devices, using VPN to pretend I'm in the USA). Nothing helped.

Even worse. My iPad Pro went into the restore mode. And my iTunes was not able to restore it. ****! I even have called the Apple support. Nothing helped.

Finally I went to my neighbor and used his macbook to restore my iPad and update my iPhone. So far so good!

I suspect that Apple has implemented some new server side checks that inhibit the iOS update on a Hackintosh.
Has anybody else experienced similar issues?
 
Joined
Feb 8, 2013
Messages
11
Motherboard
Gigabyte Z370N-WiFi
CPU
i5-8600
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Hi there,

It is an old thread, but I have had the same issue lately on my new Hackintosh : my iPhone 8 could not be restored or updated (iTunes managed to put it in "recovery" state, but then could not "boot" it, resulting in a everlasting "waiting for iPhone" state). I tried the same thing with a iPhone SE and it worked perfectly.

Then I tried restoring the iPhone 8 on my MacBooi Pro and it went smooth, even if both machines were on Mojave 10.14.1 and iTunes 12.9.0 !

So I made some tests with other devices I managed to put my hands on : another SE, a 5s, a 7+ and an iPad 6 : the first two were updated without problems, the last 2 were not. So it seems that on my hackintosh, A10 and A11 devices cannot be updated/restored through iTunes, whereas it works for older devices...

Would someone be able to confirm this and maybe elaborate a theory ?
 
Joined
Jan 11, 2019
Messages
7
Motherboard
GIGABYTE Z390 Gaming SLI
CPU
i7
Graphics
GTX 1060
I always update my iPhone through the phone itself. It's safer than through iTunes I think.
 
Top