Contribute
Register

Cannot update apps from App Store in Mojave 10.14.4

Status
Not open for further replies.
Joined
Aug 7, 2013
Messages
17
Motherboard
Gigabyte Z390-UD
CPU
i7-8700
Graphics
GT 740
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Using Mojave 10.14.4 since it was released and everything was fine until now. But for the last month or so cannot update any apps from App Store. I can see all my apps, purchases etc, but when I click on Update button the button becomes just a spinning ball and that's it. Nothing happens. At the same time MacBook Pro with 10.14.5 from the same network can download updated without any issues.

  • Can logout from iCloud, App Store and iTunes and login back without any issues. 2FA is enabled for iCloud and authenticates fine.
  • Couldn't find anything in the logs.
  • Got only one Ethernet (Realtek, wired) and it is set to en0.
  • Got the latest Clover, Lilu and WhateverGreen kexts in EFI and S/L/E.
Tried the following steps so far:

1. Sign out from App Store, sign in again. Sign out from App Store, restart, sign in again. Can see all apps etc, but just cannot update.

2. Post #7 from https://www.tonymacx86.com/threads/...d-com-apple-commerce-client-error-500.270957/

Sign out from App Store and run the following command:
Code:
defaults write com.apple.appstore.commerce Storefront -string "$(defaults read com.apple.appstore.commerce Storefront | sed s/,8/,13/)"

3. Post 18 from https://www.tonymacx86.com/threads/...commerce-client-error-500.270957/post-2005972

Code:
cd ~
rm Library/Preferences/com.apple.storeagent.plist
rm -rf Library/Caches/com.apple.SoftwareUpdate
rm -rf Library/Caches/com.apple.storeagent
rm -rf Library/Preferences/ByHost
chmod 755 Library/Cookies

4. Couldn't change UUID for some reason. I tried to use Clover Configurator, mount EFI, open config.plist with Clover and change UUID under "System Parameters" to the system one. But even if I saved it then once Mac boots it has a different UUID. Not sure why UUID is not applied from config.plist. Everything else seems to be applied from the config.

Any idea where to look and what look at?
 
Joined
Aug 7, 2013
Messages
17
Motherboard
Gigabyte Z390-UD
CPU
i7-8700
Graphics
GT 740
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Arright! After all unsuccessful attempts to fix the issue and upgrading to 10.14.6 I've found a workaround. This is 'Mac App Store command line interface' at https://github.com/mas-cli/mas

To install:
Code:
brew install mas

Once it's in, you could update all the apps that are available with:
Code:
mas upgrade

Or if mas says 'Everything is up-to-date', but App Store still says you've got updates for apps then simply delete the app and:
Code:
mas install 1234567890

Where '1234567890' is the app ID. You can get all apps ID's by:
Code:
mas list

Hope that would help someone!
 
Joined
Mar 14, 2014
Messages
742
Motherboard
Z97X-UD5H
CPU
i7-4790K
Graphics
2 x R9 280X
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
I had a similar issue that the Mac App store would not update five applications. It just stopped working after 24/9/20 for some reason. No idea what had changed at all.

Signed out of the App Store, signed in again, rebooted etc etc. All the things you did and with much the same effect :)

Had not the slightest idea of brew install mas, though I use brew.

Took a backup, installed mas from brew and ran mas upgrade.

Worked first time.

Thanks for this information. Appreciate it.

Rob
 
Last edited:
Status
Not open for further replies.
Top