<< Solved >> Cannot start install (Failed to detect supported SuperIO chip)

Feb 7, 2017
Laptop make & model # > See Rules!
UHD 630 + RTX 2080-MaxQ
Mobile Phone
  1. Android
  2. iOS

Today I have tried installing OSX catalina on my laptop, using the guide at
However, once I tried to actually boot from the bootable usb, I ran into a lot of errors and eventually the boot process froze.

Could anyone point me in the right direction? Thanks! :thumbup:

My system specs are as follows:
Model: Asus rog Zephyrus GX531GX
CPU/iGPU:Intel i7 8750H with UHD630 iGPU
eGPU: Nvidia RTX 2080 with Max-Q design (flagged to disable in the config)
Ram: 16 GB 8GB DDR4-2666 SO-DIMM
1TB M.2 NVMe™ PCIe® 3.0 Performance SSD (Samsung PM981 Polaris 1TB M.2 NGFF PCIe Gen3)

Here is a picture of the last errors thrown before it froze. If you need me to make a better picture/provide more information, I'd be happy to do so!

Thanks so much in advance!

EDIT: I have been making a few changes:
- Removed the PS2KeyboardDxe/PS2TrackPadDxe drivers, don't need them I believe.
- Removed the VoodooPS2 kext from EFI/OC/Kexts and from the config.plist, got rid of the PS2 errors.
- Removed the
SSDT-HPET ssdt from EFI/OC/ACPI and from the config.plist as I realized I didn't even need it. I now got rid of some errors here as well :thumbup:
- Removed the SMCBatteryManager kext from EFI/OC/Kexts and from the config.plist, I will patch my battery to 8bit after the succesful install. For now, I don't need it. (revision 2 verbose screen attached)
- Tried installing USBInjectAll.kext and added it to the config.plist, still wasn't able to get to the install screen.
- After doing some research, I found out that my laptop is using a Samsung PM981 SSD, which (from what I've found on the internet) requires NVMeFix.kext. I installed it, I still am not able to get to the install screen.
~~~LAST EDIT~~~: I managed to get to the macOS Utilities screen!! :headbang: I had to add SSDT-AWAC.kext to my EFI/OC/ACPI folder and add it to my config.plist.

However, I am still not able to start the installation of Catalina. From the verbose screen and some research on the internet about the last lines of errors within the verbose screen(smcsuperio), I believe it might have something to do with the Embedded Controller sstd (SSDT-EC.aml) which I have made with SSDTTime..

The guide I used is confusing me. It's telling me I should have SSDT-EC-USBX, while I currently have both SSDT-EC.aml and SSDT-USBX.aml. Did I do this the right way?

I have attached the newest OpenCore logs together with a picture of the verbose errors and with the newest EFI directory layout. If anyone might have an idea of what's wrong here, the help would be highly appreciated. I won't stop until I fixed this issue, and I will keep this thread updated. :thumbup:

Thanks a lot in advance!

Revision 2 Verbose errors: (Efi file called "Efi-older.rar" and opencore logs called "opencore-2021-02-08-163421-txt"

Revision 3 Verbose errors: (Efi file called "Efi.rar" and opencore logs called "Opencore-NEW.txt"



  • opencore-2021-02-08-163421.txt
    256 KB · Views: 24
  • EFI.rar
    1.9 MB · Views: 39
  • opencore-NEW.txt
    256 KB · Views: 29
  • EFI-Older.rar
    1.9 MB · Views: 18
Last edited: