Contribute
Register

Cannot disable SIP with terminal command

Joined
Oct 30, 2014
Messages
258
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
i9-9900k
Graphics
RX 580
Mac
iMac
When in Recovery mode, the disable command says that it has worked and that I need to restart. I do so and then use terminal to check the status and it is still disabled.
I am preparing to perform a clean install and have gotten stuck at this error when trying to install clover to my Catalina Install USB:
Screen Shot 2020-06-18 at 12.16.18.png
My config.plist is attached.
If I need to change something in there could anyone helping please specify how to do this.
 

Attachments

Joined
Oct 30, 2014
Messages
258
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
i9-9900k
Graphics
RX 580
Mac
iMac
I managed to figure this out after fumbling around with some things that did not work.

So, I THOUGHT I tried with SIP disabled but realized that it was reset by Clover. In order to update Clover we will need to to change it in Clover:

To enable SIP:

View attachment 436578

To disable SIP:

View attachment 436577
So open Clover Config. Mount EFI of system drive. navigate to config.plist. double click to open in CC. Make these changes. Close, Save. Then boot into "recovery from Recovery" at Clover GUI. Top left menu bar. Utilities/Terminal.
command: csrutil disable

restart. And you should be able to install clover now.
 
Top