Contribute
Register

Cannot boot without nv_disable=1 & kext-dev-mode=1 - Nvidia 750 TI

Status
Not open for further replies.
Joined
Sep 10, 2013
Messages
17
Mac
Classic Mac
Mobile Phone
I am on a fresh 10.10.3 Yosemite install, I cannot get my Nvidia 750 TI to display properly, and I cannot boot up without using the flags "nv_disable=1 kext-dev-mode=1 -v"

When I try to boot without the flags it starts to boot then shuts off my monitor (HDMI - I fear this may be the cause but I do not want to switch to VGA or DVI unless I absolutely have to) so this is my only option right now.

After much searching I am stumped, I installed the latest WebDriver-346.01.02f02.pkg from Nvidia. It installs the driver but still no options and I am at a very laggy 1024x768. My graphics are recognized as NVIDIA Chip Model 3 MB and my system definition is MacPro3,1.

I currently have NVIDIA Web Driver selected, NOT OS X Default Graphics Driver. and I noticed that org.chameleon.Boot.plist in /Extra contains only:
"<dict>
<key>Kernel Flags</key>
<string> nvda_drv=1</string>
</dict>"

I know there was more contained in that file before but I am not sure what was there and if it needs to be added back in or not?

Anyone got any suggestions, it would be greatly appreciated. I tried to be as detailed as possible, let me know if I can provide any additional info.

Thanks

Update: Switched to VGA, works properly. Is there any evidence of HDMI support for this card?
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,254
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
I am on a fresh 10.10.3 Yosemite install, I cannot get my Nvidia 750 TI to display properly, and I cannot boot up without using the flags "nv_disable=1 kext-dev-mode=1 -v"

When I try to boot without the flags it starts to boot then shuts off my monitor (HDMI - I fear this may be the cause but I do not want to switch to VGA or DVI unless I absolutely have to) so this is my only option right now.

After much searching I am stumped, I installed the latest WebDriver-346.01.02f02.pkg from Nvidia. It installs the driver but still no options and I am at a very laggy 1024x768. My graphics are recognized as NVIDIA Chip Model 3 MB and my system definition is MacPro3,1.

I currently have NVIDIA Web Driver selected, NOT OS X Default Graphics Driver. and I noticed that org.chameleon.Boot.plist in /Extra contains only:
"<dict>
<key>Kernel Flags</key>
<string> nvda_drv=1</string>
</dict>"

I know there was more contained in that file before but I am not sure what was there and if it needs to be added back in or not?

Anyone got any suggestions, it would be greatly appreciated. I tried to be as detailed as possible, let me know if I can provide any additional info.

Thanks

Update: Switched to VGA, works properly. Is there any evidence of HDMI support for this card?

there are lots of people using HDMI with that card.
 
Joined
Sep 10, 2013
Messages
17
Mac
Classic Mac
Mobile Phone
thanks for the update, can you elaborate a bit on what I am missing...
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,254
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,254
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
The problem is that the driver isn't loading. If I understand right, the only thing in your config file is the nvda_drv boot flag then that is likely your issue because you are missing all of the basic smbios info and everything else that is needed. I would rebuild your config file.
 
Joined
Sep 10, 2013
Messages
17
Mac
Classic Mac
Mobile Phone
is there any way to automate that or do i need to do it manually? sorry kinda new at this
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,254
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Joined
Sep 10, 2013
Messages
17
Mac
Classic Mac
Mobile Phone
so do we know precisely what it is looking for and what needs to be added using the Chameleon Wizard? I dont want to just randomly be enabling things that would be foolish
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,254
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
so do we know precisely what it is looking for and what needs to be added using the Chameleon Wizard? I dont want to just randomly be enabling things that would be foolish

Things like boot flags and such depend on your setup as to what works.
 
Status
Not open for further replies.
Top