Contribute
Register

Cannot boot Mojave Installer or OS: Asus H370-I BIOS version 2012

Joined
Jul 25, 2012
Messages
6,919
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Seems we have effectively bricked our motherboards! Let this be a lesson to others. Thanks for letting me know.
  • You can reflash with the Old Version of BIOS you had previously on that board and see if you can fix.
  • The steps are the same as you used to upgrade the BIOS , except you have the old Version of BIOS on the USB Disk.
 
Joined
Jun 19, 2017
Messages
13
Motherboard
Asus H370-I
CPU
i7-9700K
Graphics
RX580
Mac
MacBook Pro
Mobile Phone
iOS
I
  • You can reflash with the Old Version of BIOS you had previously on that board and see if you can fix.
  • The steps are the same as you used to upgrade the BIOS , except you have the old Version of BIOS on the USB Disk.
I wish it were that easy, or that I’m just being stupid.

I have downloaded all of the old versions from the Asus website. Selecting any other than 2012 result in a message stating it is not a valid BIOS. I can repeatedly apply 2012 though. The manual suggests you cannot downgrade versions.

I hope you can tell me I’m wrong.
 
Joined
Nov 12, 2018
Messages
5
Motherboard
Asus Roger h370-I
CPU
Intel i5-8400
Graphics
internal
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Android
  • You can reflash with the Old Version of BIOS you had previously on that board and see if you can fix.
  • The steps are the same as you used to upgrade the BIOS , except you have the old Version of BIOS on the USB Disk.
I already tried but impossible on my side
 
Joined
Jul 25, 2012
Messages
6,919
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I

I wish it were that easy, or that I’m just being stupid.

I have downloaded all of the old versions from the Asus website. Selecting any other than 2012 result in a message stating it is not a valid BIOS. I can repeatedly apply 2012 though. The manual suggests you cannot downgrade versions.

I hope you can tell me I’m wrong.
  • If Asus Manual says it cannot be downgraded, I would take their word for their product.
  • I don't have any Asus in my collection of Hackintosh Systems.
    • I remember using Asus long time ago for Windows but stopped them altogether.
    • To me, Asus MoBos are less 'friendly' toward Hackintosh and I use only Gigabyte Motherboards.

  • It's sad, now you have to use it exclusively for Windows only, right?
  • Is Windows booting from a separate disk?

  • Did you try to install macOS High Sierra and see if it will install?
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,533
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
@dufays, please update your profile (account details) with your Motherboard, CPU and iGPU or Graphics Card(s).
If you have a prebuilt computer enter make and model instead of motherboard.
The Rules said:
Profiles are mandatory so that others can assist you.
 
Joined
Nov 12, 2018
Messages
5
Motherboard
Asus Roger h370-I
CPU
Intel i5-8400
Graphics
internal
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Android
I wonder if there is not a novelty in the settings of this new version of the bios to change. I tried again a clean installation of 10.13 and 10.14 and it always blocks at the same time. Whereas everything worked very well before
 
Joined
Aug 28, 2018
Messages
7
Motherboard
Asus ROG STRIX H370-I Gaming
CPU
Intel Core i5 8400
Graphics
?
Hi. I have the same issue, it's my first build and i have the same motherboard with an i5 8400, i updated the BIOS recently. When i boot the "external" drive with clover, the Apple logo and a progress bar appears, it's fullfilled in aprox 20 minutes and it's all, after waiting several minutes nothing happens. Could you find a solution for your problem?

Thanks for your attention. Greetings.

Sorry for my English, I'm Mexican.
 
Joined
Jun 19, 2017
Messages
13
Motherboard
Asus H370-I
CPU
i7-9700K
Graphics
RX580
Mac
MacBook Pro
Mobile Phone
iOS
Yes, we have an identical problem.
I’ve spent a lot of time trying different BIOS settings but nothing seems to make any difference.
Currently trying to get Asus to tell me if I can revert to a previous BIOS version. Apparently you can use CrashFree BIOS 3 to revert, but I cannot identify how you launch this. It would appear to only work if the existing BIOS is corrupt.
I’ve even tried corrupting my existing BIOS but cannot even manage that.
 
Joined
Mar 2, 2019
Messages
7
Motherboard
ASUS H370-I Gaming
CPU
i5-8500
Graphics
RX 580
Any update on this? Unfortunately I did the same mistake.
Before all worked well and the same. Neither installed osX nor installer from usb is starting.

I tried to downgrade bios to previous version 1404 but the asus update tool is telling me "no proper bios"...
 
Joined
Mar 2, 2019
Messages
7
Motherboard
ASUS H370-I Gaming
CPU
i5-8500
Graphics
RX 580
Sorry, missed the second site of this thread.
But still there must be a way out for this...
 
Top