Cannot boot after trying to clean up audio kexts

Not open for further replies.
Jun 30, 2012
Lenovo M93p Tiny
HD 4600
Hey guys

I had to update itunes the other day on my ASUS P8Z68-V LX based Yosemite system. Generally it's run well for ages now but of course doing this messed up the audio setup as we all look forward to after updates like this.
Anyway, I've screwed it up somehow with trying to clear out the HDAenabler kexts etc and putting the right one back on there afresh with Multibeast.

This appeared to go ok but when I tried to reboot the machine no longer boots. It's not doing a panic, but comes up with "can't find mach_kernel".

I have found a solution for this error, which is to use "/System/Library/Kernels/kernel", which gets past this issue, but then subsequently gives another error: Memory Allocation Error.
Again, I've found a solution for this that someone else used, which is to use the boot flags: -f -v GraphicsEnabler=No AtiConfig=Pitcairn AtiPorts=4

BUT, here's the problem I currently have. I need to do all the flags for the Memory error AND the path for the kernel at the same time, and when I type any more than what fits visibly in the little dialog window for the boot flags, my screen immediately gets loads of weird colours in various places, and hitting enter does not then respond. It's a bit like it hangs but I'm not sure it actually is doing. Either way, I can't get past that point currently.

So even if those boot flags would solve the memory error, I can't use them at the same time as specifying the kernel path.

Any suggestions on how to get around this and get it booted again would be very gratefully received indeed!


Guess a full rebuild is gonna have to be on the cards then.

Tried to find a solution to this but in vain. I'm kinda surprised no-one's had this issue of only being able to type a very limited amount of text into the boot flags section without it going bang. :(
Not open for further replies.