Contribute
Register

Can I Run macOS Mojave with an ASUS ROG Strix Z390-E Motherboard?

Joined
Apr 16, 2019
Messages
2
Motherboard
Asus Rog Strix z390-e
CPU
i5 9th unlocked
Can i run mac os mojave in asus rog strix z390-e motherboard
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
16,007
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Many people are having success with Z390. Look at some of the User Builds and the CaseySJ Golden Build.

 
Joined
Mar 30, 2018
Messages
10
Motherboard
Gigabyte Z390 DESIGNARE
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air, MacBook Pro
Classic Mac
Apple, iMac
Mobile Phone
iOS
Hello everyone ! I purchased the same motherboard, and, after updating the BIOS to the latest version as per your suggestion, I can no longer go on. The system stops on apfs module start 1279. How can I fix it? Thank you all.
 
Joined
Sep 3, 2019
Messages
2
Motherboard
ROG STRIX Z390-E GAMING
CPU
i7-9700K
Graphics
RTX 2080S
Mobile Phone
Android
Hello everyone ! I purchased the same motherboard, and, after updating the BIOS to the latest version as per your suggestion, I can no longer go on. The system stops on apfs module start 1279. How can I fix it? Thank you all.
I have the same problem.
 
Joined
Sep 11, 2015
Messages
55
Motherboard
Asus ROG STRIX Z390-E
CPU
i7-9700K
Graphics
Radeon RX 560 4 GB
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
[QUOTE = "KoopaMcKing, post: 1959531, membro: 2128490"]
si, puoi
[/CITAZIONE]
hello, I have a configuration identical to yours, would you mind posting your EFI folder? thank you so much
 
Joined
Oct 31, 2018
Messages
8
Motherboard
ROG STRIX Z390-E
CPU
i9-9900K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
[QUOTE = "KoopaMcKing, post: 1959531, membro: 2128490"]
si, puoi
[/CITAZIONE]
hello, I have a configuration identical to yours, would you mind posting your EFI folder? thank you so much
Hi, sorry for the late reply. I am currently not at home but I’ll post my config as soon as possible if you’re still interested.
 
Joined
Oct 31, 2018
Messages
8
Motherboard
ROG STRIX Z390-E
CPU
i9-9900K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
first the exact components ive used:

- Tower: be quiet! Dark Base Pro 900 Rev.2

- Board: ASUS ROG STRIX Z390-E Gaming

- Power: 550W be quiet! Dark Power Pro 11 Modular 80+ Platinum

- M.2: 500GB Crucial P1 (CT500P1SSD8)

- SSD: 1TB Crucial MX500 (CT1000MX500SSD1)

- DDR4: 16GB (2x 8192MB) G.Skill Trident Z RGB DDR4-3200 DIMM CL16-18-18-38 (Will be Updated to 32GB soon)

- Cooling: Corsair Hydro H115i PRO RGB 280mm

- GPU: 8GB Sapphire Radeon RX 580 Nitro+ Aktiv

- CPU: Intel Core i9 9900K 8x 3.60GHz

- Audio: NI Komplete Audio 6 (I make Music)


config.plist:
- Acpi:
- - Patches:
- - - change HDAS to HDEF
- - - change _OSI to XOSI
- - - change GFX0 to IGPU
- - - change EC0 to EC
- - Fixes:
- - - FixShutdown

- Boot:
- - Arguments:
- - - slide=0
- - - dart=0
- - - darkwake=0

- Kernel and Kext Pathces:
- - Enable KernelPm, Apple RTC, AppleIntelCPUPM
- - KextsToPath:
- - - AppleAHCIPort
- - - com.apple.iokit.IOAHCIVBlockStorage

- System Parameters:
- - inject System ID
- - Inject Kexts: Detect

You should delete / disable anything else I dind`t mention to try my config.

Kext:
- AirportBrcmFixup (2.0.3)
- AppleALC (1.4.0)
- CPUFriend (1.1.9)
- FakeSMC (1800)
- HibernationFixup (1.2.7)
- IntelMausiEthernet (2.5.0d0)
- Lilu (1.3.8)
- NoVPAJpeg (1.0.0)
- USBInjectAll (0.7.1)
- WhateverGreen (1.3.1)

There are still some things that doesn't work like all USB ports or WIFI but currently I don't need it but I will fix those...

Hope this helps. let me know if you got any questions.
 

Attachments

Joined
Sep 11, 2015
Messages
55
Motherboard
Asus ROG STRIX Z390-E
CPU
i7-9700K
Graphics
Radeon RX 560 4 GB
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
first the exact components ive used:

- Tower: be quiet! Dark Base Pro 900 Rev.2

- Board: ASUS ROG STRIX Z390-E Gaming

- Power: 550W be quiet! Dark Power Pro 11 Modular 80+ Platinum

- M.2: 500GB Crucial P1 (CT500P1SSD8)

- SSD: 1TB Crucial MX500 (CT1000MX500SSD1)

- DDR4: 16GB (2x 8192MB) G.Skill Trident Z RGB DDR4-3200 DIMM CL16-18-18-38 (Will be Updated to 32GB soon)

- Cooling: Corsair Hydro H115i PRO RGB 280mm

- GPU: 8GB Sapphire Radeon RX 580 Nitro+ Aktiv

- CPU: Intel Core i9 9900K 8x 3.60GHz

- Audio: NI Komplete Audio 6 (I make Music)


config.plist:
- Acpi:
- - Patches:
- - - change HDAS to HDEF
- - - change _OSI to XOSI
- - - change GFX0 to IGPU
- - - change EC0 to EC
- - Fixes:
- - - FixShutdown

- Boot:
- - Arguments:
- - - slide=0
- - - dart=0
- - - darkwake=0

- Kernel and Kext Pathces:
- - Enable KernelPm, Apple RTC, AppleIntelCPUPM
- - KextsToPath:
- - - AppleAHCIPort
- - - com.apple.iokit.IOAHCIVBlockStorage

- System Parameters:
- - inject System ID
- - Inject Kexts: Detect

You should delete / disable anything else I dind`t mention to try my config.

Kext:
- AirportBrcmFixup (2.0.3)
- AppleALC (1.4.0)
- CPUFriend (1.1.9)
- FakeSMC (1800)
- HibernationFixup (1.2.7)
- IntelMausiEthernet (2.5.0d0)
- Lilu (1.3.8)
- NoVPAJpeg (1.0.0)
- USBInjectAll (0.7.1)
- WhateverGreen (1.3.1)

There are still some things that doesn't work like all USB ports or WIFI but currently I don't need it but I will fix those...

Hope this helps. let me know if you got any questions.
thank you very much indeed! : D
Tomorrow I will try to mix up ...


PS: What is USBInjectAll.kext used for if all the ports don't work? currently all my USB ports work on my configuration except 2.0

PSS: Would you be kind enough to upload your EFI folder? Thanks again :)
 
Last edited:
Joined
Jan 7, 2019
Messages
5
Motherboard
Asus Rog STRIX Z390-E
CPU
i9-9900k
Graphics
Nvidia GTX 1080
first the exact components ive used:

- Tower: be quiet! Dark Base Pro 900 Rev.2

- Board: ASUS ROG STRIX Z390-E Gaming

- Power: 550W be quiet! Dark Power Pro 11 Modular 80+ Platinum

- M.2: 500GB Crucial P1 (CT500P1SSD8)

- SSD: 1TB Crucial MX500 (CT1000MX500SSD1)

- DDR4: 16GB (2x 8192MB) G.Skill Trident Z RGB DDR4-3200 DIMM CL16-18-18-38 (Will be Updated to 32GB soon)

- Cooling: Corsair Hydro H115i PRO RGB 280mm

- GPU: 8GB Sapphire Radeon RX 580 Nitro+ Aktiv

- CPU: Intel Core i9 9900K 8x 3.60GHz

- Audio: NI Komplete Audio 6 (I make Music)


config.plist:
- Acpi:
- - Patches:
- - - change HDAS to HDEF
- - - change _OSI to XOSI
- - - change GFX0 to IGPU
- - - change EC0 to EC
- - Fixes:
- - - FixShutdown

- Boot:
- - Arguments:
- - - slide=0
- - - dart=0
- - - darkwake=0

- Kernel and Kext Pathces:
- - Enable KernelPm, Apple RTC, AppleIntelCPUPM
- - KextsToPath:
- - - AppleAHCIPort
- - - com.apple.iokit.IOAHCIVBlockStorage

- System Parameters:
- - inject System ID
- - Inject Kexts: Detect

You should delete / disable anything else I dind`t mention to try my config.

Kext:
- AirportBrcmFixup (2.0.3)
- AppleALC (1.4.0)
- CPUFriend (1.1.9)
- FakeSMC (1800)
- HibernationFixup (1.2.7)
- IntelMausiEthernet (2.5.0d0)
- Lilu (1.3.8)
- NoVPAJpeg (1.0.0)
- USBInjectAll (0.7.1)
- WhateverGreen (1.3.1)

There are still some things that doesn't work like all USB ports or WIFI but currently I don't need it but I will fix those...

Hope this helps. let me know if you got any questions.
Thank you for your detailed description of your config.plist sections, can you please indicate your BIOS version ? I have the exact same hardware as you but i'm stuck on apfs error on boot, and this information should resolve it

Thank you in advance
 
Top