Contribute
Register

Can anyone help me to make sleep work with wifi on my zenbook ux303?

Joined
Dec 11, 2015
Messages
16
Motherboard
ASUS Zenbook ux303ub-r4111t
CPU
i5-6200U
Graphics
HD 520 , GT 940M
Mobile Phone
  1. iOS
Hi everyone, after lots of attempts i managed to install Mojave 14.4 on my asus zenbook ux303ub and get almost averything working, except i wasnt able to make wifi work with sleep, i replaced the intel wifi with dw1560/bcm94352z which i made to work by installing the kexts.The problem is that when i install it sleep gets affected, when i press sleep it takes 1 minute to go to sleep and when i press the power button it wakes to a black screen that is showing only the cursor and i have to force shut down by holding power button , so in order to fix sleep the only way i have found is to select "fixregions" in config.plist acpi section but then wifi stops working, it shows "hardware not installed" when i click the icon and only bluetooth works.I have tried clover config changes, patching ssdt and dsdt, usb ssdt, installing kexts in different locations but none of them seem to work , can someone help me with this?
I attach the files below , thanks.
 

Attachments

  • debug_25741.zip
    5.8 MB · Views: 75
Joined
Dec 11, 2015
Messages
16
Motherboard
ASUS Zenbook ux303ub-r4111t
CPU
i5-6200U
Graphics
HD 520 , GT 940M
Mobile Phone
  1. iOS

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,383
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi everyone, after lots of attempts i managed to install Mojave 14.4 on my asus zenbook ux303ub and get almost averything working, except i wasnt able to make wifi work with sleep, i replaced the intel wifi with dw1560/bcm94352z which i made to work by installing the kexts.The problem is that when i install it sleep gets affected, when i press sleep it takes 1 minute to go to sleep and when i press the power button it wakes to a black screen that is showing only the cursor and i have to force shut down by holding power button , so in order to fix sleep the only way i have found is to select "fixregions" in config.plist acpi section but then wifi stops working, it shows "hardware not installed" when i click the icon and only bluetooth works.I have tried clover config changes, patching ssdt and dsdt, usb ssdt, installing kexts in different locations but none of them seem to work , can someone help me with this?
I attach the files below , thanks.
all your 3rd party kexts should be installed to /Library/Extensions

put these in the correct place:
Code:
Kext with invalid signatured (-67062) allowed: <OSKext 0x7fb2b4c2a760 [0x7fffa0e268f0]> { URL = "BrcmFirmwareRepo.kext/ -- file:///System/Library/Extensions/", ID = "com.no-one.BrcmFirmwareStore" }
Kext with invalid signatured (-67062) allowed: <OSKext 0x7fb2b6f62780 [0x7fffa0e268f0]> { URL = "BrcmPatchRAM2.kext/ -- file:///System/Library/Extensions/", ID = "com.no-one.BrcmPatchRAM2" }
make sure to install all your other kext to /L/E

you really need all those SSDT's in acpi/patched? what have you patched in those?

macbookpro 13,1 may be a better choice
 
Joined
Dec 11, 2015
Messages
16
Motherboard
ASUS Zenbook ux303ub-r4111t
CPU
i5-6200U
Graphics
HD 520 , GT 940M
Mobile Phone
  1. iOS
all your 3rd party kexts should be installed to /Library/Extensions

put these in the correct place:
Code:
Kext with invalid signatured (-67062) allowed: <OSKext 0x7fb2b4c2a760 [0x7fffa0e268f0]> { URL = "BrcmFirmwareRepo.kext/ -- file:///System/Library/Extensions/", ID = "com.no-one.BrcmFirmwareStore" }
Kext with invalid signatured (-67062) allowed: <OSKext 0x7fb2b6f62780 [0x7fffa0e268f0]> { URL = "BrcmPatchRAM2.kext/ -- file:///System/Library/Extensions/", ID = "com.no-one.BrcmPatchRAM2" }
make sure to install all your other kext to /L/E

you really need all those SSDT's in acpi/patched? what have you patched in those?

macbookpro 13,1 may be a better choice

Hi, thanks for your reply,

i changed to macbook pro 13.1 i removed the kexts and i installed them to /L/E and then run kext utility to rebuild cache and repair permissions , i left to /other only the necessary like virtualsmc and touchpad driver...as far as the SSDTs im not sure that i need them all, i used them from another guide that had the same model as mine.
After these changes wifi still doesnt work only bluetooth works, i attach the new debug files below , thanks
 

Attachments

  • debug_26391.zip
    3.2 MB · Views: 60

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,383
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi, thanks for your reply,

i changed to macbook pro 13.1 i removed the kexts and i installed them to /L/E and then run kext utility to rebuild cache and repair permissions , i left to /other only the necessary like virtualsmc and touchpad driver...as far as the SSDTs im not sure that i need them all, i used them from another guide that had the same model as mine.
After these changes wifi still doesnt work only bluetooth works, i attach the new debug files below , thanks
you should patch your own ssdt's and not use other pnes from other laptops even if they have the same make and model

also i noticed you haven't ran the terminal commands from here:
which you should do to get your sleep working
 
Joined
Dec 11, 2015
Messages
16
Motherboard
ASUS Zenbook ux303ub-r4111t
CPU
i5-6200U
Graphics
HD 520 , GT 940M
Mobile Phone
  1. iOS
you should patch your own ssdt's and not use other pnes from other laptops even if they have the same make and model

also i noticed you haven't ran the terminal commands from here:
which you should do to get your sleep working

i ran the commands but sleep was working 100% even before i ran the commands, so nothing changed, the problem is that i need to have 'fixregions' enabled in acpi section of config.plist for it to work , but then wifi gets disabled , but when i disable 'fixregions' wifi works normally but then sleep gets broken. So the problem is not that they dont work , it is that they dont work together.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,383
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
i ran the commands but sleep was working 100% even before i ran the commands, so nothing changed, the problem is that i need to have 'fixregions' enabled in acpi section of config.plist for it to work , but then wifi gets disabled , but when i disable 'fixregions' wifi works normally but then sleep gets broken. So the problem is not that they dont work , it is that they dont work together.
no problem reporting files attached
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,383
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
ok here they are:
all your 3rd party kexts belong to /L/E missing VirtualSMC etc

also keep a copy of essential kexts in clover

you will find you have duplicate kexts in both places which is fine

still using patched files another laptop, not good, remove those and use config.plist to do renames
 
Top