Contribute
Register

Broken audio after windows 10 dualboot

Status
Not open for further replies.
Joined
Nov 11, 2015
Messages
243
Motherboard
GIGABYTE Z390 DESIGNARE.
CPU
i7 7700K
Graphics
RTX 3080 TI
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. Android
  2. iOS
hi all i was running dual boot windows 8.1 +10.12.3 on my Dell 7537 and after i upgraded to windows 10 my audio seems to be no working please help me
 

Attachments

  • CLOVER.zip
    1.7 MB · Views: 53
  • problem reporting.zip
    604.2 KB · Views: 50
  • Screen Shot 2017-04-12 at 10.47.44 AM.png
    Screen Shot 2017-04-12 at 10.47.44 AM.png
    62 KB · Views: 86
  • Screen Shot 2017-04-12 at 10.47.28 AM.png
    Screen Shot 2017-04-12 at 10.47.28 AM.png
    21.2 KB · Views: 64

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,488
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
hi all i was running dual boot windows 8.1 +10.12.3 on my Dell 7537 and after i upgraded to windows 10 my audio seems to be no working please help me

At least one problem is very obvious from your kextcache output:
Code:
AppleHDA.kext has incorrect permissions; omitting.
 
Joined
Nov 11, 2015
Messages
243
Motherboard
GIGABYTE Z390 DESIGNARE.
CPU
i7 7700K
Graphics
RTX 3080 TI
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. Android
  2. iOS
At least one problem is very obvious from your kextcache output:
Code:
AppleHDA.kext has incorrect permissions; omitting.
sir,so how may i fix this (i have native hda backed up )
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,488
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
sir,so how may i fix this (i have native hda backed up )

If you're using patched AppleHDA.kext, delete current AppleHDA.kext and install patched AppleHDA.kext properly.

If you're using an AppleHDA injector kext (with Clover patches for AppleHDA), run the macOS installer to restore your AppleHDA and install the injector correctly.
 
Joined
Nov 11, 2015
Messages
243
Motherboard
GIGABYTE Z390 DESIGNARE.
CPU
i7 7700K
Graphics
RTX 3080 TI
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. Android
  2. iOS
i followed your U430 repo method ,
it was working fine
suddenly it was not working
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,488
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
i followed your U430 repo method ,
it was working fine
suddenly it was not working

Requirements are the same as always...

ALC283 is the same as my Lenovo u430. You can use AppleHDA_ALC283.kext in my u430 repo...

https://github.com/RehabMan/Lenovo-U430-Touch-DSDT-Patch

Requirements:
- Clover bootloader
- config.plist must have the four AppleHDA patches from my config.plist in the repo (but not the zml.zlib patch)
- AppleHDA.kext must be vanilla
- CodecCommander.kext installed to /S/L/E: https://github.com/RehabMan/EAPD-Codec-Commander
- AppleHDA_ALC283.kext installed to /S/L/E
- rebuild cache following the procedure detailed in the u430 guide: http://www.tonymacx86.com/yosemite-...ideapad-u330-u430-u530-using-clover-uefi.html
- DSDT patches "IRQ Fix" and "Audio Layout 3".
 
Joined
Nov 11, 2015
Messages
243
Motherboard
GIGABYTE Z390 DESIGNARE.
CPU
i7 7700K
Graphics
RTX 3080 TI
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. Android
  2. iOS
sir what if i'm using your patch_hda script?
 
Joined
Nov 11, 2015
Messages
243
Motherboard
GIGABYTE Z390 DESIGNARE.
CPU
i7 7700K
Graphics
RTX 3080 TI
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. Android
  2. iOS
patch_hda.sh is the script that creates AppleHDA_ALC283.kext.
so may i create own with your script and test because with your kext all working fine except the mic
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,488
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
so may i create own with your script and test because with your kext all working fine except the mic

Internal mic or external mic (via combo jack).
Mic via combo jack is known to not work...
 
Status
Not open for further replies.
Top