Contribute
Register

Broadwell-EP installer issues

Joined
Aug 29, 2012
Messages
2
Motherboard
ASUS X99-E WS UDB 3.1
CPU
Xeon E5-2687V4
Graphics
GT 640
10.11.5 installer created with UniBeast 6.2.0.
Asus X99-E WS USB 3.1
Xeon E5-2687 v4
GT 640

Booting to the installer just resets after printing the '++++++' line.

I've tried adding boot flags cpus=1 and -x, replacing OsxAptioFix2Drv-64.efi with OsxAptioFix2Drv-free2000.efi, replacing VBoxHfs-64.efi with HFSPlus.efi, and adding NullCPUPowerManagement.kext

What am I missing here?

[EDIT]
Setting a fake CPUID of 0x0306E0 gets past the reset, but leaves me with AICPUPM kernel panics, even with NullPowerManagement injected :(

[EDIT]
Removing almost everything from DSDT and SSDT in Clover stopped the kernel panics (dropping oem and generating tables = bad, it seems...)

Now it hangs on [ PCI configuration begin ] and no solution I can find fixes it (npci=0x2000, npci=0x3000, FixDarwin).
 
Last edited:
Joined
May 12, 2011
Messages
2,720
Motherboard
GA-X99M-Gaming 5
CPU
Intel Core i7-5930K
Graphics
MSI GTX 970 Gaming 4G
Mac
MacBook Pro
Mobile Phone
Android
10.11.5 installer created with UniBeast 6.2.0.
Asus X99-E WS USB 3.1
Xeon E5-2687 v4
GT 640

Booting to the installer just resets after printing the '++++++' line.

I've tried adding boot flags cpus=1 and -x, replacing OsxAptioFix2Drv-64.efi with OsxAptioFix2Drv-free2000.efi, replacing VBoxHfs-64.efi with HFSPlus.efi, and adding NullCPUPowerManagement.kext

What am I missing here?

[EDIT]
Setting a fake CPUID of 0x0306E0 gets past the reset, but leaves me with AICPUPM kernel panics, even with NullPowerManagement injected :(

[EDIT]
Removing almost everything from DSDT and SSDT in Clover stopped the kernel panics (dropping oem and generating tables = bad, it seems...)

Now it hangs on [ PCI configuration begin ] and no solution I can find fixes it (npci=0x2000, npci=0x3000, FixDarwin).
You're not missing anything. There's no Apple support for Broadwell-e... If you did any research you'd find that even 8 core cpu'(5960k) have been a problem. Hopefully you'll find a solution and share it we everyone. :beachball:
 
Joined
Aug 29, 2012
Messages
2
Motherboard
ASUS X99-E WS UDB 3.1
CPU
Xeon E5-2687V4
Graphics
GT 640
You're not missing anything. There's no Apple support for Broadwell-e... If you did any research you'd find that even 8 core cpu'(5960k) have been a problem. Hopefully you'll find a solution and share it we everyone.
I did quite a lot of research. I couldn't find anything about broadwell-ep (or broadwell-e) support, good or bad. Broadwell generally appears to be working. Hopefully my post will be helpful to someone else, if only in a negative way :(

I'm now off to wrestling with trying to get El Capitan running under KVM on this beast - even that is proving difficult.
 
Top