Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Joined
Mar 24, 2014
Messages
125
Motherboard
Aorus Xtreme Z390
CPU
i9-9900K
Graphics
Vega VII
Mobile Phone
  1. Other
Did you get your WiFi/BT card working in your Gigabyte Z390 Aorus Xtreme? If so, what did you do? I don't have mine working yet, but I found that at least the machine will boot if it is installed in a long slot (not a 1XPCIe slot).

Problem is in the "long Slot" as you funnily enough call it :lol: it won't work (at least not in my case and obviously not just my case) and it doesn't work in a PCIe X1 adapter card still, as of yet, so my solution was to jump to a suitable M.2 adapter (and I call it suitable, because the BCM94360CDPAX is a little longer, than the BCM94360CD and thus comes in contact with the USB connector of most of the cards you can order from china. Found just one "suitable" as of as of yet).

Long story short: old problem persists, just found a workaround. Btw the BCCM94331CD still works in the PCIe X1 Slot with adapter, it's just the "newer" cards making problems.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,923
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Feb 9, 2011
Messages
56
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
Radeon 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Problem is in the "long Slot" as you funnily enough call it :lol: it won't work (at least not in my case and obviously not just my case) and it doesn't work in a PCIe X1 adapter card still, as of yet, so my solution was to jump to a suitable M.2 adapter (and I call it suitable, because the BCM94360CDPAX is a little longer, than the BCM94360CD and thus comes in contact with the USB connector of most of the cards you can order from china. Found just one "suitable" as of as of yet).

Long story short: old problem persists, just found a workaround. Btw the BCCM94331CD still works in the PCIe X1 Slot with adapter, it's just the "newer" cards making problems.
Hi @SuDoDmz
I ended up getting the Fenvi FV-T919 card, and it works in the bottom long slot.
Re: your M.2 adapter setup: what adapter are you using and where do you have this installed? Did you replace the Intel CNVI wifi card with an adapter + BCM94360CDPAX, or do you have it plugged into one of the M.2 slots intended for NVMe drives?
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,923
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Oct 17, 2013
Messages
142
Motherboard
Chuwi AeroBook Plus
CPU
Intel i5 6287U
Graphics
HD550, 3840 x 2160
Mobile Phone
  1. iOS
After a lot of test and try I can boot normally on osx with Wifi and BT Enable in BIOS with the boot args

brcmfx-driver=1

Now, the system go online, the BT it seems works but if I try to use didn't working. The Wifi not see, even I set a patch on the config.plist.

Schermata 2019-09-11 alle 14.14.53.png


Schermata 2019-09-11 alle 15.06.07.png


I also attach the debug log.
 

Attachments

  • debug_19259.zip
    3.2 MB · Views: 60
Last edited:
Joined
Mar 24, 2014
Messages
125
Motherboard
Aorus Xtreme Z390
CPU
i9-9900K
Graphics
Vega VII
Mobile Phone
  1. Other
I ended up getting the Fenvi FV-T919 card, and it works in the bottom long slot.
Re: your M.2 adapter setup: what adapter are you using and where do you have this installed? Did you replace the Intel CNVI wifi card with an adapter + BCM94360CDPAX, or do you have it plugged into one of the M.2 slots intended for NVMe drives?

I ordered this one from eBay first (and a bunch of ufl to rp-sma cables) and then realised the BT-cable hindrance and ended up ordering another one (mea culpa for being so rash and not swiping any further in the search results), this one, to be specific. On my board you can't "replace" the CNVi card (else I would've ended up using the DW1830), so I ripped it out (quite a while ago, now that I think about it), because the combination would occasionally freeze the Windows boot-up, and placed my new card in the third (and last, namely M2P) M.2 Slot available (the others are occupied already with Samsung 970 pros, first one for Windows, second for Mac). Before getting there I also tried the WTXUP adapter, failed me again in this rig, but works in my x58 setup and it looks really nice!
 
Joined
Aug 29, 2019
Messages
1
Motherboard
Gigabyte Z390 M
CPU
Intel® Core™ i5-9400
Graphics
Sapphire PULSE RX 580 8G G5
Can't get my PCIe BCM94360CD to work 100%. The card is working at a reduced capability on WiFi since 802.11/AC is not reflected. Bluetooth is working, but can't get handoff/continuity and Apple Watch unlock to work.

I'm running Mojave 10.14.6 on a Gigabyte Z390 M Gaming, i5-9400 and Sapphire RX580 Pulse 8Gb. I used the procedure described at the beginning of this guide under "I. Broadcom WiFi/BT Installation".

Thanks in advance for any help provided.
 

Attachments

  • TroubleshootingFiles.zip
    2.8 MB · Views: 61
Joined
Sep 4, 2012
Messages
72
Motherboard
GigaByte Z390 Aorus Pro WiFi
CPU
i7-8700
Graphics
RX 560
Mobile Phone
  1. Android
  2. Other

Just a quick personal THANK YOU TOLEDA for the guide!!
THANK YOU REHABMAN for the fakeID kexts and patches!!!


A note on the guide: I just replaced the Atheros in my ProBook 470 G0 with a BCM94352HMB AzureWave, and I was about to post a problem request as the WiFi is seen, but doesn't want to "turn on"... when my eye caught elsewhere a weird mention about deleting the (old) network interfaces... and then it just *worked* !! so perhaps also, add in the first step where you state to remove all the old/previous .kexts (like the ProBookAtheros.kext :blush: nearly forgot about that .kext)
to also remove/delete the old WiFi interfaces from the network settings page.

Thanks again
 
Joined
Apr 21, 2016
Messages
1,008
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
Hi ben9923

I got a BCM94352Z and everything works well, but unlock with apple watch. "Allow your Apple Watch to unlock your Mac" opt at the "Preferences > Security & Privacy" is enabled, but the password field pops up when login. Is there the problem of hardware and no anyway to resolve it?

Regards,
Xavier
I believe it's a hardware problem, as it's not 100% compatible with Apple's drivers. Using a wireless card found in an Apple device will probably resolve that.
Never saw anyone having Auto Unlock working correctly with a BCM94352Z.
Like you, I had it enabled, but it didn't actually work. Only right after enabling the option, without rebooting.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,923
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
BT it seems works but if I try to use didn't working
USB not configured properly, SSDT-UIAC.aml/HS08 is not present. Off topic
4350 is sitting on RP05, not recognized. Edit config.plist/ACPI/DSDT/Fixes/FixAirport/NO
Apply fixes, restart, reply with new files
 
Top