Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Joined
Jul 28, 2016
Messages
125
Motherboard
ASRock B365M Pro4
CPU
i5-9600K
Graphics
RX 580
Mobile Phone
Android
Hi,

I have a problem with my Bluetooth on my ProBook 4540s (I followed RehabMans's guide entirely) using the BCM94352HMB Wi-Fi card:

Everything seems working fine (connecting and sending or receiving files from devices) but it seems that my Plantronics E50 (bluetooth headset) after 1-2 minutes of playing music (stuttering sound) (the source of the audio doesn't matter like YouTube, iTunes etc..) the connection gets dropped...

What I tried:

- Reset bluetooth module using the debug menu in OS X.
- Restart the laptop
- Restart the headset
- Using 5GHz network only.
- Disabled Handoff
- The headset works fine on another devices like Galaxy S7 and Huawei P10 Lite.

You can find the debug files attached.
 

Attachments

Last edited:
Joined
Jan 8, 2019
Messages
33
Motherboard
HUAWEI MateBook X
CPU
i5-7200U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
So what shall I do now in order to let others help me? Shall I edit my profile or tell you specifically about the issue and the device model?
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,878
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS

toleda

Moderator
Joined
May 20, 2010
Messages
24,261
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
have a problem with my Bluetooth on my ProBook 4540s (I followed RehabMans's guide entirely) using the BCM94352HMB Wi-Fi card
Did not use the Post #1/BT Injection method
Post to RehabMan's guide
 
Joined
Aug 25, 2015
Messages
235
Motherboard
DELL Inspiron 7370
CPU
i7-8550U
Graphics
UHD620
Mac
iMac, MacBook Air
Mobile Phone
Android, iOS
Sorry that I cannot answer your question but as my laptop is very close to yours (i7 7700), which injection do you use for display? I use ig-platform-id 0x3E920009 but that seems a bit weird to me...
I don't need any injections for versions higher than Sierra. I have a guide regarding to that with Sierra and fakeID for graphics and CPU. Click on my profile to take a look at it.
 
Joined
Jan 8, 2019
Messages
33
Motherboard
HUAWEI MateBook X
CPU
i5-7200U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
Can you assist me now? I've filled in the information in the account details.
My hackintosh is on the Lenovo X220i, who does not have a mac-friendly wifi card, so I've changed it to BCM94352hmb. The wifi is great, with 5 ghz, being rebranded to Airport Extreme. However, there is no bluetooth under both Windows 10 and MacOS Mojave (10.14.3), while the card is a combo card. How can I solve this problem?

I've solve this problem by taping the pin 20 and 51, and the bluetooth under both systems works great. But the wifi is still not working under Windows. I wonder why.

If this is off topic, how to enable "auto unlock" with Apple Watch like I do on the MacBook Pro?
 
Last edited:
Joined
Feb 17, 2011
Messages
422
Motherboard
Gigabyte GA-Z170X-UD3
CPU
i7-6700K
Graphics
Powercolor RX 5700 XT
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Android, iOS
Hi @toleda,

I've just finished installing High Sierra on an Asus VivoPC VM62, whose specifications are as follows:
• Core i3 4005U / 4 GB ram
• AzureWave AW-CE123H (BCM94352HMB)
• High Sierra 10.13.6 (17G5019) on a classic HD

I followed your guide and managed to get wifi working fine.
For the Bluetooth part, it's well detected, but unfortunately it fails to connect to any device (tried with Magic Mouse and MS Mouse 3600).

Don't know if it's related, but I also have sleep problems...

Here's my PR files (generated with gen_debug)
Could you help me to try to solve this bluetooth problem?
Thank you.
 

Attachments

Joined
Feb 20, 2019
Messages
45
Motherboard
Dell XPS 9360
CPU
i5-7200U
Graphics
HD 620
I'm currently using DW1560 on my build. However, when I update to Mojave, handoff doesn't seem to work. As mentioned in the first post, that plist mod for handoff is depreciated. How would I make it to work again? I have AirportBrcmFixup, BrcmFirmwareRepo, and BrcmPatchRAM2. kext. No plist modification for handoff.
Hey there, I have the same issue.
Since Mojave Handoff and Personal Hotspot with iPhone are not working anymore.

Airdrop and normal Bluetooth streaming is fine however.

Do you have a fix at hand?
Cheers!

Edit:
Fixed Handoff with a kextcache flush. Personal Hotspot still not working, but I can connect to it by entering the password.
 
Last edited:
Joined
Aug 25, 2015
Messages
235
Motherboard
DELL Inspiron 7370
CPU
i7-8550U
Graphics
UHD620
Mac
iMac, MacBook Air
Mobile Phone
Android, iOS
Hey there, I have the same issue.
Since Mojave Handoff and Personal Hotspot with iPhone are not working anymore.

Airdrop and normal Bluetooth streaming is fine however.

Do you have a fix at hand?
Cheers!

Edit:
Fixed Handoff with a kextcache flush. Personal Hotspot still not working, but I can connect to it by entering the password.
Hi, I'm glad that you got handoff to work. Would you mind to tell more specifically how to do a Kext cache flush?

Thanks
 
Top