Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Joined
Jan 20, 2019
Messages
6
Motherboard
Dell Inspiron 7000
CPU
i7-8750H
Graphics
UHD 630 + GTX MX150
I have added this one to patched in Clover.
Still no BT (WiFi works great). Here is what system info says:

BRCM20702 Hub:



Product ID: 0x4500

Vendor ID: 0x0a5c (Broadcom Corp.)

Version: 1.00

Speed: Up to 12 Mb/sec

Manufacturer: Apple Inc.

Location ID: 0x14a00000 / 5

Current Available (mA): 500

Current Required (mA): 94

Extra Operating Current (mA): 0



Bluetooth USB Host Controller:



Product ID: 0x821f

Vendor ID: 0x05ac (Apple Inc.)

Version: 0.38

Speed: Up to 12 Mb/sec

Manufacturer: Apple Inc.

Location ID: 0x14a30000 / 9

Current Available (mA): 500

Extra Operating Current (mA): 0



Composite Device:



Product ID: 0x820b

Vendor ID: 0x05ac (Apple Inc.)

Version: 1.00

Speed: Up to 12 Mb/sec

Location ID: 0x14a20000 / 10

Current Available (mA): 500

Current Required (mA): 0

Extra Operating Current (mA): 0



Composite Device:



Product ID: 0x820a

Vendor ID: 0x05ac (Apple Inc.)

Version: 1.00

Speed: Up to 12 Mb/sec

Location ID: 0x14a10000 / 8

Current Available (mA): 500

Current Required (mA): 0

Extra Operating Current (mA): 0

Does it help you?

Thank you so much!
May be this could help too, from kernel log:

2019-03-19 16:41:12.222905+0100 0x103 Default 0x0 0 0 kernel: (IO80211Family) AirPort_Brcm4360::init AirPortFamily_kexts-1430.2 "AirPortFamily_kexts-1430.2" Nov 12 2018 21:07:03
2019-03-19 16:41:12.222920+0100 0x103 Default 0x0 0 0 kernel: (AirPortBrcm4360) ARPT: 1.222918: AirPort_Brcm43XX:probe:, this[0x6226dbf2c6ca64c7] score[1400]
2019-03-19 16:41:12.223182+0100 0x103 Default 0x0 0 0 kernel: (IO80211Family) AirPort_Brcm4331::init AirPortFamily_kexts-1430.2 "AirPortFamily_kexts-1430.2" Nov 12 2018 21:07:03
2019-03-19 16:41:12.223194+0100 0x103 Default 0x0 0 0 kernel: (AirPortBrcm4331) wl: start
2019-03-19 16:41:12.668158+0100 0x103 Default 0x0 0 0 kernel: (AirPortBrcm4331) Enabling PCI power management
2019-03-19 16:41:12.668220+0100 0x74 Default 0x0 0 0 kernel: (AirPortBrcm4331) AirPort_Brcm43xx::powerChange: messageType = 0xe0000340
2019-03-19 16:41:23.600785+0100 0x3d9 Default 0x0 0 0 kernel: (IO80211Family) AirPort_Brcm4331::getSSIDData(): Get failure: APPLE80211_IOC_SSID: 6
2019-03-19 16:41:23.723008+0100 0x35f Default 0x0 0 0 kernel: (AirPortBrcm4331) in func createVirtualInterface ifRole = 1
2019-03-19 16:41:23.723103+0100 0x35f Default 0x0 0 0 kernel: (IO80211Family) AirPort_Brcm4331_P2PInterface::init name <p2p0> role 1
2019-03-19 16:41:23.723546+0100 0x35f Default 0x0 0 0 kernel: (IO80211Family) AirPort_Brcm4331_P2PInterface::init <p2p> role 1
2019-03-19 16:41:23.723581+0100 0x35f Default 0x0 0 0 kernel: (AirPortBrcm4331) Created virtif <private> p2p0
2019-03-19 16:41:26.915111+0100 0x4f3 Default 0x0 0 0 kernel: (AirPortBrcm4331) MacAuthEvent en2
2019-03-19 16:41:26.915112+0100 0x4f3 Default 0x0 0 0 kernel: (AirPortBrcm4331) Auth result for: ec:89:14:64:6c:30
2019-03-19 16:41:26.915114+0100 0x4f3 Default 0x0 0 0 kernel: (AirPortBrcm4331) MAC AUTH succeeded
2019-03-19 16:41:26.916983+0100 0x4f3 Default 0x0 0 0 kernel: (AirPortBrcm4331) wlEvent: en2 en2 Link UP virtIf = 0x0
2019-03-19 16:41:27.176708+0100 0x285 Default 0x0 0 0 kernel: (Lilu) AirportBrcmFixup: init @ failed to call parent 6
 
Joined
Jul 28, 2016
Messages
121
Motherboard
ASRock B365M Pro4
CPU
i5-9600K
Graphics
RX 580
Mobile Phone
  1. Android
Hi,

I have a problem with my Bluetooth on my ProBook 4540s (I followed RehabMans's guide entirely) using the BCM94352HMB Wi-Fi card:

Everything seems working fine (connecting and sending or receiving files from devices) but it seems that my Plantronics E50 (bluetooth headset) after 1-2 minutes of playing music (stuttering sound) (the source of the audio doesn't matter like YouTube, iTunes etc..) the connection gets dropped...

What I tried:

- Reset bluetooth module using the debug menu in OS X.
- Restart the laptop
- Restart the headset
- Using 5GHz network only.
- Disabled Handoff
- The headset works fine on another devices like Galaxy S7 and Huawei P10 Lite.

You can find the debug files attached.
 

Attachments

  • debug_21406.zip
    3 MB · Views: 159
Last edited:
Joined
Jan 7, 2019
Messages
53
Motherboard
Dell XPS 15 9500
CPU
i9-10885H
Graphics
Intel UHD Graphics + GTX1650 Ti
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
So what shall I do now in order to let others help me? Shall I edit my profile or tell you specifically about the issue and the device model?
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,516
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS

toleda

Moderator
Joined
May 19, 2010
Messages
22,928
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
have a problem with my Bluetooth on my ProBook 4540s (I followed RehabMans's guide entirely) using the BCM94352HMB Wi-Fi card
Did not use the Post #1/BT Injection method
Post to RehabMan's guide
 
Joined
Aug 24, 2015
Messages
232
Motherboard
DELL Inspiron 7370
CPU
i7-8550U
Graphics
UHD620
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
  2. iOS
Sorry that I cannot answer your question but as my laptop is very close to yours (i7 7700), which injection do you use for display? I use ig-platform-id 0x3E920009 but that seems a bit weird to me...
I don't need any injections for versions higher than Sierra. I have a guide regarding to that with Sierra and fakeID for graphics and CPU. Click on my profile to take a look at it.
 
Joined
Jan 7, 2019
Messages
53
Motherboard
Dell XPS 15 9500
CPU
i9-10885H
Graphics
Intel UHD Graphics + GTX1650 Ti
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Can you assist me now? I've filled in the information in the account details.
My hackintosh is on the Lenovo X220i, who does not have a mac-friendly wifi card, so I've changed it to BCM94352hmb. The wifi is great, with 5 ghz, being rebranded to Airport Extreme. However, there is no bluetooth under both Windows 10 and MacOS Mojave (10.14.3), while the card is a combo card. How can I solve this problem?

I've solve this problem by taping the pin 20 and 51, and the bluetooth under both systems works great. But the wifi is still not working under Windows. I wonder why.

If this is off topic, how to enable "auto unlock" with Apple Watch like I do on the MacBook Pro?
 
Last edited:
Top