Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

toleda

Moderator
Joined
May 19, 2010
Messages
22,962
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I have this problem with GA-H370N,neither of bcm94352 works. I'm wondering about successes with these boards on GA-Z370N
Z370N (Kaby Lake chipset) does not use Intel CNVi WiFi, bcm94352 replaces Intel Wifi and works.
H370N (Coffee Lake chipset) uses Intel CNVi WiFi, bcm94352 only works in another M.2 slot with an adapter. See KevinAgnes/Post #358.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,962
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Z370 is also Coffee Lake, however, according to this article, does not have CNVi
Author is wrong and did not do appropriate research
"Z390 motherboards released a year after Z370 and added the niceties introduced in the more mainstream options."
Z390/Coffee Lake chip set includes silicon CNVi "niceties," USB 3.1 Gen 2, etc.
Z370/Kaby Lake chip set does not include CNVi, however, supports Coffee Lake processors
An unplanned Intel consequence, all 200 Series motherboards support Coffee Lake processors (BIOS updated required)

Coffee Lake - Wikipedia/Chipsets:
The enthusiast Z370 (a rebranded Z270), launched alongside the first Coffee Lake CPUs in October 2017 ...
 
Last edited:
Joined
Jan 5, 2014
Messages
73
Motherboard
Gigabyte GA-Z390M Gaming
CPU
i9-9900K
Graphics
RX 590
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
@toleda @jaymonkey it did work flawlessly!
View attachment 342751
(M.2-KEYM to M.2 KEYA+E adapter / M.2 KEYA+E to Mac WLAN / BCM94360CS2)

So for H370N-Wifi users and many others that don't have m2-WIFI or have m2-CNVi slots, this solution works.
It's kinda creepy with 2 adapters in a m2 key m slot!
View attachment 342752
but everything working!
View attachment 342756 View attachment 342755
I managed to use the antenna cables from the original intel cnvi wlan card!
View attachment 342753
:thumbup::mrgreen:

Hi,

I have searched and searched on eBay for the red M.2 adapter in the pics. Just can't find it. Could you point me towards one? I would realy appreciate it :)

Thanks for your post!
 
Joined
Nov 22, 2018
Messages
10
Motherboard
ASUS z370-P
CPU
i5-8600k
Graphics
RX 580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello, I have PCI-E card with BCM94360CD (https://www.ebay.com/itm/Broadcom-B...2aOg:rk:1:pf:0&LH_ItemCondition=1000&LH_BIN=1)

Both WiFi and BT are working, even iMessage, Continuity, Handoff, AirDrop, but I have noticed slow speeds on 5GHz network and a bit laggy mouse and keyboard when uploading over 20mbit/s. We have 500/50 mbit/s internet connection with AC wifi and my computer within 3m from router can reach max only 270/30 and average 160/30 mbit/s. For example, my Macbook pro at same position can reach 300/50 with no problems every time with max of 360 mbit/s download.

When I try 2.4GHz network, mouse and keyboard are unusable. Is this something that can be fixed by config edit or is it hardware issue?

Thank you.
 

Attachments

  • debug_32496.zip
    3.5 MB · Views: 82
Joined
Nov 22, 2018
Messages
10
Motherboard
ASUS z370-P
CPU
i5-8600k
Graphics
RX 580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Country Code: #a, why?
Suggestion from another user with similar problems. I'll try exact country code, could this be causing the issue?

I have looked up our wifi, it has not set the country code and it has no option to set it. Which country code should I use than?
 
Last edited:
Joined
Feb 23, 2011
Messages
26
Motherboard
Gigabyte Z77X-UD3H
CPU
i5-2500K
Graphics
GTX 960
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I have installed on my HP Elitedesk 800 G3 Mini 65W (Skylake version i5 6500 HD Graphics 530) a m.2 wifi-BT card with a Broadcom BCM94352Z.
https://www.amazon.fr/gp/product/B079FQP3QR/?tag=tonymacx8607-21

I’m running Mojave.

I followed this guide for Wifi injection (installed with kextbeast in L/E and country code booting) and BT injection (installed repo and ram2 in L/E with kextbeast).
Everything is fine with Wifi but I have no BT device detected. But I have in System Configuration > Hardware > USB a BCM20702A0 as USB BT.
 

Attachments

  • report.zip
    1.2 MB · Views: 58
Top