Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Joined
Jan 10, 2012
Messages
127
Motherboard
AsRock Z97E-ITX/AC
CPU
i5-5675C
Graphics
HD 6200
Mac
MacBook Pro
Mobile Phone
iOS
Hello everybody,

trying to get Bluetooth to work again after going to Mojave (10.14. and 10.14.1) from Sierra.
I did a clean install because I thought I had something misconfigured - I could not install High Sierra or later with 16.2 system definition. Even clean install did not work with 16.2, so I am now running with 14.2 and HD6200 graphics.
I did restore the old system from TimeMachine, so there might have been some things restored that should not have been.

Broadcom BCM94360HMB seems to natively support Wifi, but Bluetooth is not working any more.
Removed FakePCIID stuff I hope, added BrcmFirmwareRepo.kext and BrcmNonPatchRAM2.kext to /L/E with KextBeast but they do not seem to load. Cannot find any error messages referring to why.

My configuration:
Board ASRock Z97E-ITX/AC latest BIOS
Intel i5-5675c with HD 6200
Broadcom BCM94360HMB 0x0b05:0x180a

Bluetooth does appear under USB as BCM20702A0, so I hope it is configured well enough?

Am adding lots of problem reporting files in case they could help as required - and am hoping for suggestions.
Any further output required?

Thanks a lot in advance!
Rudolf
 
Joined
Mar 4, 2014
Messages
297
Motherboard
GA-Z87-HD3
CPU
i5-4570
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
You might try the alternate configuration: XHCI Mode = "Smart Auto", then use FakePCIID_XHCIMux.kext (keep in mind you'll need a completely different SSDT-UIAC.aml).
Before I head over to USB thread for help trying the above. I have another question:

I've noticed that when Bluetooth is unavailable after sleep, if I log out of user account and log back in then BT is available again. Does this give any better clue to solution? I've attached fresh PR files
 

Attachments

Last edited:
Joined
Mar 6, 2018
Messages
14
Motherboard
Gigabyte Z370 AORUS GAMING WIFI
CPU
i7-8700K 5.0GHZ (OVERCLOCKED)
Graphics
Sapphire-Radeon RX 580 8 GB NITRO
Mac
Mac Pro
(Help) I So I have a Brodcom BCM94360CD and I cant get my Mx Master 2s to connect to bluetooth. My bluetooth see it but wont connect for some reason. Can Someone me please?
 
Joined
Jan 10, 2012
Messages
127
Motherboard
AsRock Z97E-ITX/AC
CPU
i5-5675C
Graphics
HD 6200
Mac
MacBook Pro
Mobile Phone
iOS
added BrcmFirmwareRepo.kext and BrcmNonPatchRAM2.kext to /L/E with KextBeast but they do not seem to load. Cannot find any error messages referring to why.
Maybe someone can tell me where to look for reasons?
I do not understand why these Brcm* kexts are not loading...

Did anyone find other errors in my config?
(I saw that one person viewed my files ;o)

Thanks,
Rudolf
 
Joined
Nov 8, 2014
Messages
119
Motherboard
Z370M DS3H
CPU
i5-8400
Graphics
RX 560
Mac
MacBook Pro
Mobile Phone
iOS
Hi



I3-6100
Asrock Z170M-itx
Mojave

I have yet another system I’m trying to get up and running. However it would seem the bluetooth part of my BCM94322HM8L card is not seen by my system.It should be on port HS13, that’s where the original card shows up ..

Wifi works fine

Patch USB in ACPI. I have patched USB correctly I think

Method used:Broadcom wifi/Bluetooth Guide

Installed kext in /L/E

USBinjectall
Lilu
BrcmPatchRAM2
BrcmFirmwareRepo
AirpotBrcmFixup
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi



I3-6100
Asrock Z170M-itx
Mojave

I have yet another system I’m trying to get up and running. However it would seem the bluetooth part of my BCM94322HM8L card is not seen by my system.It should be on port HS13, that’s where the original card shows up ..

Wifi works fine

Patch USB in ACPI. I have patched USB correctly I think

Method used:Broadcom wifi/Bluetooth Guide

Installed kext in /L/E

USBinjectall
Lilu
BrcmPatchRAM2
BrcmFirmwareRepo
AirpotBrcmFixup
Your ioreg was not captured with correct IORegistryExplorer.app.
Please use v2.1.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello everybody,

trying to get Bluetooth to work again after going to Mojave (10.14. and 10.14.1) from Sierra.
I did a clean install because I thought I had something misconfigured - I could not install High Sierra or later with 16.2 system definition. Even clean install did not work with 16.2, so I am now running with 14.2 and HD6200 graphics.
I did restore the old system from TimeMachine, so there might have been some things restored that should not have been.

Broadcom BCM94360HMB seems to natively support Wifi, but Bluetooth is not working any more.
Removed FakePCIID stuff I hope, added BrcmFirmwareRepo.kext and BrcmNonPatchRAM2.kext to /L/E with KextBeast but they do not seem to load. Cannot find any error messages referring to why.

My configuration:
Board ASRock Z97E-ITX/AC latest BIOS
Intel i5-5675c with HD 6200
Broadcom BCM94360HMB 0x0b05:0x180a

Bluetooth does appear under USB as BCM20702A0, so I hope it is configured well enough?

Am adding lots of problem reporting files in case they could help as required - and am hoping for suggestions.
Any further output required?

Thanks a lot in advance!
Rudolf
Your ioreg was not captured with correct IORegistryExplorer.app.
Please use v2.1.
 
Top