Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Screenshot 2023-01-02 at 6.17.11 PM.png
 
You can try adding the BCM94360CD device-id (0x43a0) to OpenCore config.plist or to your Clover config.plist, so the card is recognised and possibly activated in an earlier version of macOS. The device-id entry might look something like the DeviceProperties entry for my Broadcom WiFi card below.

View attachment 561045

The Device Path, slot name, type and model entries can be obtained from Hackintool > PCIe tab, using the Export function. Then Copied to your system config.plist's DeviceProperties section.

The device-id and built-in entries would need to be manually added. This example is shown in an OC plist viewed in ProperTree plist editor.

You could also try adding the AirportBrcmFixup.kext boot argument to your config.plist:

brcmfx-driver=1 this enables/pushes the AirPortBrcm4360 kext for loading.

0 - AirPortBrcmNIC-MFG,​
1 - AirPortBrcm4360,​
2 - AirPortBrcmNIC,​
3 - AirPortBrcm4331​

These are the Broadcom WiFi kexts that function in Mountain Lion, Mavericks & Yosemite, with the corresponding card device id's listed against each kext.

View attachment 561044


thsi is a very clever and good idea. i bet it would work.

i don't want to modify my deviceproperties entries of my plist because i run mojave on the regular.
but this is a great idea. i managed to get the PCI stuff working in mojave now too, so i don't absolutely need mountain lion.

is there a way to create a deviceproperties entry for a range of kernels, like the kext loading? probably not?

very good idea and thank you. i will keep this in mind for the future, no dobut.
 
Same issue as before - I can see my MX Master 3 mouse, but I cannot connect to it - just shows spinny progress indicator forever.

Speedtest.net:
(Used Stats to confirm no network activity during tests)
USBC Ethernet Dock on gigabit home ethernet to gigabit provider fiber: 249/337.
DW1830 to Unifi / Ubiquiti hardware: 71/49.
DW1830 to provider's router: (paused to let ads load without a pihole): 17/27, then 7/8, then 12/34.
DW1830 to Unifi / Ubiquiti hardware (again): 62/72
I'm two American inside walls away from both WAPs.
With near LOS (it's behind a TV) to a 802.11ax Wifi 6 Ubiquiti WAP, I get 214/135.
 
is there a way to create a deviceproperties entry for a range of kernels, like the kext loading? probably not?
No, you currently can't differentiate DeviceProperties by a range of kernels.

While that is possible with Kernel Extensions (Kexts) and Kernel Patches it is not when dealing with Device Properties.
 
Greetings Forum,
I have a problem, and this is the source of wisdom. I hope I am not missing an obvious mistake.

My laptop is a Dell inspiron 7378. It is working as a Mac Pro 14,1 Ventura 13.3.1(a) [now 13.4] and OC 0.9.2.
The intel wifi card never gave high throughput and did not connect well through the various Bluetooth fixes, so I recently replaced the M.2 card with a new BCM_4360NG.
It works great for WiFI, but is not functioning correctly for Bluetooth.
It is recognized. Apple System Info shows:
Bluetooth Controller:
Address: 88:63:DF:8A:64:21
State: On
Chipset: BCM_20702B0
Discoverable: Off
Firmware Version: v150 c9317
Supported services: 0x382039 < HFP AVRCP A2DP HID Braille AACP GATT SerialPort >
Transport: USB
Vendor ID: 0x004C (Apple)
Not Connected:
Moshe Sadofsky’s iPhone SE:
Address: 98:9E:63:79:CF:89
Vendor ID: 0x004C
Firmware Version: 15.7.0
Minor Type: MobilePhone
RSSI: -77
Moshe’s iPad:
Address: 6C:70:9F:0E:7D:18

I can manually turn bluetooth on, and it detects my iPhone, and asks to connect. But that pairing never establishes and then disappears.

Is there something I am doing wrong? I believe I port mapped correctly, but have also tried using InjectAll. No luck. I also tried various combinations of BT firmware kexts and fixup kexts. Nope. Willing to follow advice.
Thanks in advance.
Edit: The 13.4 update did not fix this.
 
Last edited:
Hi everyone, I managed to fresh install Ventura on my CustoMac Mini, using Opencore and following Dortania Opencore guide, but I have two problems: wifi not working and my MOTU Ultralite Hybrid mk3 external audio interface not being recognized (I'll open a new thread somewhere else for that).
My WiFi/BT card is a broadcom BCM94360CS2 card with m2 adapter. If I understand correctly it is supposed to work without any kext, BT works, but no WiFi.
I tried to add brcmfixup kext (removing AirPortBrcm4360_Injector.kext from config.plist) but still no luck.
In the last months WiFi wasn't working on Mojave, do you have any suggestion on something to try before ordering a new WiFi/BT card? In that case which card do you recommend to run Ventura on my system?
Thanks a lot!
 
Last edited:
Broadcom on Somoma will only work correctly with OpenCore Legacy Patcher. I would suggest you get an Intel AX(XXX) and do not manipulate your installation by modifying the Kernel. Or downgrade back to Ventura.
 
Back
Top