Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Joined
Feb 23, 2019
Messages
80
Motherboard
Dell XPS 13 9360
CPU
i5-7200U
Graphics
HD 620, 1920 x 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Personally I would do the following:
  1. Remove HS04 from the Hackintool USB config, if as you say it is serving the disabled card reader.
  2. 'Export' the revised USB config from Hackintool to the desktop, last button on the right below list of ports.
  3. Check that the connector types are correct in the USBPorts.kext
    1. Right click on the USBPorts.kext
    2. Open Contents folder
    3. Open Info.plist, which will show the Usb config and connector types for each port activated by the kext.
  4. Add the checked USBports.kext created by Hackintool to the /CLOVER/kexts/Other folder.
  5. Remove the USBInjectAll.kext from the /CLOVER/kexts/Other folder
  6. Remove the SSDT-UIAC.aml from the /CLOVER/ACPI/patched folder.
Reboot the system and see if that makes any difference.

Not sure what you have done to get sleep 'kinda' working or what would effect the Function keys for sound and brightness to not work.

Thanks for reply @Edhawk
Just followed all the steps above - USBPorts.kext hasn't changed anything - all USB ports work as before
Wifi works but no Bluetooth.

Sleep function works, but function keys got screwed by something - they don't work as they should
no sound control accept in Preferences , no brightness control accept in preferences .

Touching brightness function keys even once disables Trackpad completely till restart.

No idea where to look to revert/repair those keys to normal operation and to repair Trackpad -
something in config.plist or ?
 
Last edited:

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
2,496
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,443
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks for reply @Edhawk
Just followed all the steps above - USBPorts.kext hasn't changed anything - all USB ports work as before
Wifi works but no Bluetooth.

Sleep function works, but function keys got screwed by something - they don't work as they should
no sound control accept in Preferences , no brightness control accept in preferences .

Touching brightness function keys even once disables Trackpad completely till restart.

No idea where to look to revert/repair those keys to normal operation and to repair Trackpad -
something in config.plist or ?
you will have to create a new thread for your other issues, as this thread is for wifi and bluetooth
 
Joined
Oct 27, 2019
Messages
41
Motherboard
Asus TUF B550-Plus
CPU
Ryzen 5 5600
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Hi all,

I am experiencing an issue with BCM94360CS and PCI adapter.

These are not detected in Hackintosh at all.

I tried the lowest and second lowest PCI port with no luck.

Additionally, I am unsure how to connect antennas to BCM as they wouldn't hold. I assume it would be dectable anyways though, so that's a separate issue.

System:
MacOS Big Sur 11.2.3 (20D91)
Asus B550 Gaming Tuf-Plus (no WI-Fi version)
Graphics - RX580
Latest version of BIOS

I am using Opencore. All the files are attached as per the manual in the first post.

Your help is enormously appreciated. Been battling with Wi-Fi for months now...

Cheers
 

Attachments

  • Archive.zip
    25.3 MB · Views: 9
  • Archive.zip
    25.3 MB · Views: 8
  • 20211020_192311.jpg
    20211020_192311.jpg
    2.8 MB · Views: 18

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,443
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi all,

I am experiencing an issue with BCM94360CS and PCI adapter.

These are not detected in Hackintosh at all.

I tried the lowest and second lowest PCI port with no luck.

Additionally, I am unsure how to connect antennas to BCM as they wouldn't hold. I assume it would be dectable anyways though, so that's a separate issue.

System:
MacOS Big Sur 11.2.3 (20D91)
Asus B550 Gaming Tuf-Plus (no WI-Fi version)
Graphics - RX580
Latest version of BIOS

I am using Opencore. All the files are attached as per the manual in the first post.

Your help is enormously appreciated. Been battling with Wi-Fi for months now...

Cheers
think those connectors are too big
 
Joined
Oct 27, 2019
Messages
41
Motherboard
Asus TUF B550-Plus
CPU
Ryzen 5 5600
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
W
think those connectors are too big
Would you mean the antenna connectors? They seem to fit but never "click in". The BCM chip fits into the slot perfectly, and the adapter fits into PCI slot perfectly, too
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,443
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
W

Would you mean the antenna connectors? They seem to fit but never "click in". The BCM chip fits into the slot perfectly, and the adapter fits into PCI slot perfectly, too
the wires, the connectors on the end seem to look too large, or maybe it is just the image
 
Joined
Oct 27, 2019
Messages
41
Motherboard
Asus TUF B550-Plus
CPU
Ryzen 5 5600
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
They do look and feel a little bizarre and they won't stick. However, I don't think that this would be the main reason for the card to be undetected.

If anything, I could solder these to the module?
 

Attachments

  • 20211020_211050.jpg
    20211020_211050.jpg
    2.4 MB · Views: 14

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,443
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
They do look and feel a little bizarre and they won't stick. However, I don't think that this would be the main reason for the card to be undetected.

If anything, I could solder these to the module?
yes, they are too large
 
Top