Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Joined
Aug 25, 2013
Messages
166
Motherboard
GIGABYTE GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi all,
I just install this card WiFi Card BCM94360CD 802.11a/g/n/ac 1750Mbps BT4.0 PCIe Network Adapter that I got from amazon for my current build and was able to connect my wifi on my "ac" band on my router and ran a speed test and it shows 258mbps DL and 200mbps UL (I have fiber).
I installed the kexts following the guide here and when I am transferring 2-3gb file from my MacBook Pro to this Hackintosh using airdrop, the Hackintosh stopped receiving files and stop the transfer. It didn't work before installing the kexts and thought maybe I do need to install the kexts. So, I did but results still the same. Can someone here help me? some guidance.
1. I have both airportbcmfixup & Lilu kext in EFI/Clover/kext/other.
2. Install both brcmfirmwareRepo & BrcmPatchRAM2 (as directed by Rehabman for my version10.14) in /library/extensions folder using kextbeast.

Reboot and try transferring again and still failed. Sorry, thought it would work out of the box but it didn't for air drop.

bump. Please assist. Thank you.
 
Joined
Mar 29, 2011
Messages
855
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
The way Airdrop works is that the bluetooth negotiates the connection, and the wifi does the transfer. If the devices are not on the same wifi network, an ad-hoc wifi connection is created. That might function somewhat differently, so you can try ensuring that both devices are on the same ESSID and same band (hold option while clicking wifi menu to check whether the band is 2.4 ghz or 5 ghz).
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
6,451
Motherboard
Gigabyte Z490i Aorus Ultra - OC 0.6.8
CPU
i5-10600K
Graphics
GT710 - 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
bump. Please assist. Thank you.


Hello again.

For your Broadcom chip you should not need to use the kext patches. The wireless card comes from an Apple machine. I have used the same one. Recommend you remove brcm*.kexts from L/E and rebuild kextaches. As @kylec says, you need both BT and wi-fi enabled. So as well as checking the bluetooth section of System Report, check Wi-Fi too, like this:

wifi.jpg


:)
 
Joined
Aug 25, 2013
Messages
166
Motherboard
GIGABYTE GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
The way Airdrop works is that the bluetooth negotiates the connection, and the wifi does the transfer. If the devices are not on the same wifi network, an ad-hoc wifi connection is created. That might function somewhat differently, so you can try ensuring that both devices are on the same ESSID and same band (hold option while clicking wifi menu to check whether the band is 2.4 ghz or 5 ghz).

Hi yes. It is on the same wifi band of 5ghz.
 
Joined
Aug 25, 2013
Messages
166
Motherboard
GIGABYTE GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello again.

For your Broadcom chip you should not need to use the kext patches. The wireless card comes from an Apple machine. I have used the same one. Recommend you remove brcm*.kexts from L/E and rebuild kextaches. As @kylec says, you need both BT and wi-fi enabled. So as well as checking the bluetooth section of System Report, check Wi-Fi too, like this:

View attachment 468668

:)

Thanks Utter. I will check this after deleting the brim kexts from the folder I added. Will report back.
 
Joined
Apr 24, 2019
Messages
38
Motherboard
Lenovo E580 (20KS003AXS)
CPU
i5-8250U
Graphics
UHD620, RX 550
Hello, I have Broadcom BCM94352Z installed in Lenovo ThinkPad E580. With appropriate kexts both Bluetooth and Wi-Fi are working, but BT4.0 devices cannot be connected while Wi-Fi is on. If turn off Wi-Fi and then connect BT4.0 device it will work. But when turn Wi-Fi back on, BT4.0 will work with interference (mouse pointer is laggy). For BT3.0 devices there is not such problem.
Any thoughts how this can be fixed?
 
Joined
Apr 16, 2020
Messages
2
Motherboard
Asus x540LA
CPU
I3 5005U
Graphics
HD 5500
Hi everyone! hope you're all doing great. I managed to install Catalina in my pc, and everything works just fine after a few DSDT patches. The only thing that is not working is my wifi. I have a Broadcom 4322AG. I've seen some kexts around for it, but they are all for El Capitan and Mavericks. Saw some not that clear info for Sierra. My question here is, is it possible to make it work? I know there are some 2009 MBPs with my same wifi card, but of course those are not supposed to get Catalina. Does it only work in those systems then?

Thank you so much for taking the time to read this. Have a nice one!
Nevermind, I just rebranded it using Ubuntu 10.10 and now it is recognized natively as Airport Extreme.
 
Joined
Aug 25, 2013
Messages
166
Motherboard
GIGABYTE GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello again.

For your Broadcom chip you should not need to use the kext patches. The wireless card comes from an Apple machine. I have used the same one. Recommend you remove brcm*.kexts from L/E and rebuild kextaches. As @kylec says, you need both BT and wi-fi enabled. So as well as checking the bluetooth section of System Report, check Wi-Fi too, like this:


:)

Hi Utter,
Looks like it worked after removing the two brim kexts. I was able to transfer 200mb and 2gb files with no problem. Verified the channel, band and SSID of wifi are both the same. Thank you so much.
 
Joined
Apr 24, 2019
Messages
38
Motherboard
Lenovo E580 (20KS003AXS)
CPU
i5-8250U
Graphics
UHD620, RX 550
Hello, I have Broadcom BCM94352Z installed in Lenovo ThinkPad E580. With appropriate kexts both Bluetooth and Wi-Fi are working, but BT4.0 devices cannot be connected while Wi-Fi is on. If turn off Wi-Fi and then connect BT4.0 device it will work. But when turn Wi-Fi back on, BT4.0 will work with interference (mouse pointer is laggy). For BT3.0 devices there is not such problem.
Any thoughts how this can be fixed?

I bought CSR8510 Bluetooth USB dongle that is working with Mac out of the box. I removed Brmc Bluetooth kexts and deleted all related .plists. Strange thing that it continue behaves exactly the same:
  • When Wi-Fi is turned on - BT4.0 mouse cannot be connected
  • When Wi-Fi is turned off - mouse can be connected, but after re-enabling Wi-Fi mouse sometimes works with interference
  • If disconnect mouse and then try to re-connect it - it will not be detected. For successful reconnection BT needs to be turned off and back on. Behavior is the same with Wi-Fi on/off.
So it looks like problem is not in BCM94352Z, but with MacOS itself. Maybe someone have an insight on how to fix it?
 
Joined
May 16, 2020
Messages
10
Motherboard
Dell E6440
CPU
i5-4310M
Graphics
HD 4600
I recently loaded up 10.15 on my Lenovo T550 and replaced my WiFi Intel Adapter with this "MacOS Hackintosh For Broadcom BCM94352Z NGFF WiFi Card 1200Mbps 802.11ac BT4.0" from eBay. I for the life of me cannot get this to work, nor BT or WiFi. Nothing I have tried works. I loaded the kexts in /Volume/EFI/EFI (boot), OS Vol /Volume/macOS/EFI, /Volume/macOS/Library/Extensions, not working. This could simply be a case of misunderstanding on my part. Any help would be appreciated. Thanks.
 
Top