Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Joined
Aug 2, 2017
Messages
1
Motherboard
Asus H110i Plus
CPU
Intel i5 6500
Graphics
nvidia 1070
Hey Rahabman,
First of all, thanks for the good work (and the other collaborators). I'm kind of a newbie. I have just set up a clean install of the lastest High Sierra on an EVGA Stinger Z270 motherboard, which has the AzureWave CB210NF m.2 Wifi card. The chipset I believe is BCM4356. I have put the following kexts in FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext. My Bluetooth keyboard (probably BT2) works, but my Bluetooth 4/LE devices are in a connected/connect loop, with CPU usage jumping high.

Wifi is not present (not important given that I have ethernet working, but would be nice as well)

Am I missing any steps to get BLuetooth 4LE working?
 
Joined
Apr 8, 2014
Messages
26
Motherboard
Acer Aspire 5740g (Clover legacy)
CPU
Core i3 330M - Mobile Intel HM55 Express
Graphics
ATI Mobility Radeon HD 5470 - 1366x768
Has anyone had the chance to check problem reporting files here?
AW-CE123H (BCM94352)
Everything works correctly until a wake from sleep,
the BT recovers fine but WiFi is "off" in network settings and can't be used/enabled.
Method 1 in High Sierra.
Thanks for the help
 
Joined
Jan 1, 2018
Messages
30
Motherboard
Asus Asrock z270 killer SLI
CPU
Intel 7700k
Graphics
GTX 1070ti
Mac
  1. iMac
If your WiFi hardware does not work on Windows (seems to be what you imply with your reply), then it is likely your WiFi hardware is defective.

I also thought this might be the case, so I ordered another BCM4360, installed it, but am still having no luck turning on WiFi. Please see files attached.

One thing that I should note... the one issue I had during the hardware installation process was actually installing the antenna cables to the BCM4360. It does seem to be installed properly, but the wire connectors were somewhat finicky. Could this possibly be the source of the issue? Also, would it be of any value to try installing the BCM4360 using a PCIE adapter instead of a NGFF (M.2) adapter?
 

Attachments

  • WiFi Help.zip
    1.6 MB · Views: 102

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,624
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I also thought this might be the case, so I ordered another BCM4360, installed it, but am still having no luck turning on WiFi. Please see files attached.

One thing that I should note... the one issue I had during the hardware installation process was actually installing the antenna cables to the BCM4360. It does seem to be installed properly, but the wire connectors were somewhat finicky. Could this possibly be the source of the issue? Also, would it be of any value to try installing the BCM4360 using a PCIE adapter instead of a NGFF (M.2) adapter?

Did you test your hardware on Windows?
 
Joined
Jan 1, 2018
Messages
30
Motherboard
Asus Asrock z270 killer SLI
CPU
Intel 7700k
Graphics
GTX 1070ti
Mac
  1. iMac
Did you test your hardware on Windows?

I did not intend to use windows, so I am not sure if additional configuration is required for WiFi. Upon booting into Windows, there was no WiFi (and no ethernet connection either). I downloaded the Windows Broadcom driver onto a USB with a mac and then installed it in Windows... no WiFi networks detected. Please see screenshot and let me know if what I am encountering is really a hardware issue.
Capture.PNG
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,624
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I did not intend to use windows, so I am not sure if additional configuration is required for WiFi. Upon booting into Windows, there was no WiFi (and no ethernet connection either). I downloaded the Windows Broadcom driver onto a USB with a mac and then installed it in Windows... no WiFi networks detected. Please see screenshot and let me know if what I am encountering is really a hardware issue.View attachment 314405

Seems you have a hardware problem.
WiFi hardware may be defective, installed incorrectly, or lacking required antennas, etc.
Note that Windows 10 will automatically acquire the required drivers (via Windows Update, assuming internet connection via Ethernet) or have them already included.
 
Joined
Jan 17, 2018
Messages
6
Motherboard
GIGABYTE Z370 AORUS Gaming 5 + Clover
CPU
Core i7-8700k
Graphics
Intel UHD Graphics 630 + 3840 x 2160
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi, guys, I have BCM94360CD installed in my hackintosh, it should work out of boxed without any kext. Am i right? but turns out, Wifi work out of box, but bluetooth not working. Here's my problem reporting base on the guide, please let me if there's something I am missing. I will provide it as soon as possible.

Description of WiFi/Bluetooth problem
BCM94360CD without any kext fix, Wifi working, but bluetooth not working. bluetooth can not be turn off, and can not pair with my trackpad. with #41's method, I could turn off bluetooth now, but still can not pair any bluetooth devices.

OS X version/motherboard model/BIOS version/processor/graphics
High Sierra 10.13.3 / Gigabyte Z370 AORUS Gaming 5 / F4 / Intel Core i7-8700K / UHD630​

Procedure/Guide used
I do not apply any kext fixed yet.

I try to following #41 @shepworth's method, to retrieve a product id (0x0A2A ) & vender id (0x8087 ), and modify the IOBluetoothFamily.kext, and reinstall kext & reboot, the bluetooth can be turn-off now, but still can not pair my devices

Copy of IOReg & Screenshoots & Clover
please see attached.​
 

Attachments

  • bluetooth_reporting.zip
    2.9 MB · Views: 88
Last edited:
Joined
Mar 2, 2016
Messages
63
Motherboard
GA-Z170X-UD3
CPU
i7 6700
Graphics
Geforce 710 gt
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hello all! Got my El Capitan 10.11.6 build working wifi/Bluetooth fine , until i updated my gigabyte 170x ud3 Bios to F23E, now Wifi works but Bluetooth icon its greyed out and shows "Not Available". checked the Usb ports config first of all and checked f for it on the apropiate thread,and it's ok. I don't understand why, under system information , Usb, appears the device as 0a5c:22be (AzureWave Aw ch 123) when the card is BRCM4360 cd When i build this computer, my first card was the 1st mentiones (AW ch 123) but removed and buyed the new BCM4360CD and (i dont remember how ) get working. Maybe this have some to see in the mistakely wrong devices ? i'm little lost ....
I attach requested files , thanks.
 

Attachments

  • troubleshooting files.zip
    3 MB · Views: 61
Joined
Jun 23, 2013
Messages
8
Motherboard
Gigabyte GA-H97M-D3H
CPU
i5-4690
Graphics
GTX 760
Mobile Phone
  1. iOS
guys, I recently bought a BCM943602CS from China, and it works flawlessly, WiFi, bluetooth, airdrop, handoff etc etc, the only thing is my internet connection is slower than normal using this card. I live in a shitty building with a 25mbps bandwidth, and when I test my connection speed my hack gets something about 10 and 15mbps, but my iPhone gets full bandwidth, using the same server and app. Do I need to patch something? I had the same problem with a USB dongle (DWA-131) in the past, never found the issue cause. thanks in advance. OS 10.3.3
 
Joined
Jul 25, 2012
Messages
49
Motherboard
Gigabyte GA-X299 Designare EX
CPU
i9-9980XE
Graphics
RX 580
Mac
  1. Mac Pro
Classic Mac
  1. Apple
  2. Power Mac
Mobile Phone
  1. iOS
Guy's is there any eBay or other link where i can buy one, that works natively and HP compatible? All cards i've found are IBM/LENOVO/HP incompatible :banghead:
 
Top