Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Joined
Oct 23, 2013
Messages
7
Motherboard
HP Envy 17-u177cl Laptop (Clover)
CPU
i7-7500U
Graphics
Intel HD620/NVIDIA 940MX, 1920x1080
Read post #90.

I presume you are referring to you statement "Does not work for all laptops... (reason not known)"?

Because my problem is different from 9000RPM. He says his card is not detected. Mine is clearly detected, it is just problems "powering it on".

I have not tried to validate it with Windows. Sadly I nuked windows entirely and it would be very time consuming to go backwards. Do you know if BCM94350ZAE is supported by Linux? I live linux would be easier to do.
-Thanks
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I presume you are referring to you statement "Does not work for all laptops... (reason not known)"?

Because my problem is different from 9000RPM. He says his card is not detected. Mine is clearly detected, it is just problems "powering it on".

Both are common problems.
Your issue may be incorrect ACPI patching (forgot to simulate version of Windows with an appropriate "OS Check Fix" patch or not using _OSI->XOSI + SSDT-XOSI.aml).

Do you know if BCM94350ZAE is supported by Linux?

No idea.
 
Joined
Nov 8, 2015
Messages
33
Motherboard
MSi B150M BAZOOKA
CPU
i5-6500
Graphics
Sapphire Tri-X R9 290X
Mac
  1. MacBook
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
@RehabMan, since you got an undocumented WLAN to work with your Lenovo, I'm going to try a Lenovo branded BCM94352Z (FRU: 04X6020). Will report back this weekend. Thanks.
 
Joined
Jan 1, 2018
Messages
30
Motherboard
Asus Asrock z270 killer SLI
CPU
Intel 7700k
Graphics
GTX 1070ti
Mac
  1. iMac
BCM94352 and M.2 adapter installed. WiFi not working, BT is working.
  1. Unable to turn wifi ON
  2. OS X 13.13.3/ASROCK Zc270 Killer SLI/ac/BIOS version/Intel i7 7700k/(ASUS)NVIDIA GeForce GTX 1060 3GB
  3. AirportBrcmFixup.kext/lvs1974 method. Also tried FakePCIID/RehabMan method
  4. Attached
  5. Screenshots attached
  6. Config.plist and DPCI boot log attached
TIA for the help
 

Attachments

  • WiFi Help.zip
    1.6 MB · Views: 70

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
BCM94352 and M.2 adapter installed. WiFi not working, BT is working.
  1. Unable to turn wifi ON
  2. OS X 13.13.3/ASROCK Zc270 Killer SLI/ac/BIOS version/Intel i7 7700k/(ASUS)NVIDIA GeForce GTX 1060 3GB
  3. AirportBrcmFixup.kext/lvs1974 method. Also tried FakePCIID/RehabMan method
  4. Attached
  5. Screenshots attached
  6. Config.plist and DPCI boot log attached
TIA for the help

WiFi hardware installed is not BCM94352.
The ioreg shows 14e4:43a0 which is BCM4360. Did you test the WiFi hardware on Windows?
 
Joined
Jan 1, 2018
Messages
30
Motherboard
Asus Asrock z270 killer SLI
CPU
Intel 7700k
Graphics
GTX 1070ti
Mac
  1. iMac
WiFi hardware installed is not BCM94352.
The ioreg shows 14e4:43a0 which is BCM4360. Did you test the WiFi hardware on Windows?

You are correct about the Wifi hardware, apologies.

I do not have my High Sierra drive configured as a dual boot. However, I do have another drive which is dual boot (Sierra + Win10) and there is no WiFi... not sure if that makes a difference.
 
Joined
Nov 8, 2015
Messages
33
Motherboard
MSi B150M BAZOOKA
CPU
i5-6500
Graphics
Sapphire Tri-X R9 290X
Mac
  1. MacBook
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
Just got my Lenovo FRU 04x6020 BCM94352Z. I had the Airport BrcmFixup and FakePCIID_Broadcom_WiFI already applied and upon startup, native WiFi is working.

Below are pictures of the BCM94352Z(left) and BCM94350ZAE(right). Both are Lenovo branded. The documentation for my Lenovo Yoga700 doesn't list the BCM94352Z as supported but it works. It lists the BCM94350ZAE as supported, that's why I originally bought this one. And RehabMan said he put in an "unsupported" Lenovo WiFi card in his so it seems like whoever is writing the codes are just putting in a list of all Lenovo FRU wifi cards.

8X5ZZPS.jpg


RWecJJC.jpg
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
You are correct about the Wifi hardware, apologies.

I do not have my High Sierra drive configured as a dual boot. However, I do have another drive which is dual boot (Sierra + Win10) and there is no WiFi... not sure if that makes a difference.

If your WiFi hardware does not work on Windows (seems to be what you imply with your reply), then it is likely your WiFi hardware is defective.
 
Joined
Sep 3, 2015
Messages
20
Motherboard
Gigabyte H81M
CPU
4590
Graphics
headless
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
I got a problem with my bluetooth that I can't seem to figure out...

I have a BCM94360CD with product ID 4500 & vendor ID 0a5c. The bluetooth is product 828d / vendor 05ca. This is supposed to be & as far as I can tell is a real Apple card. WiFi works natively & bluetooth is supposed to as well but I can't ever get anything to show up in Bluetooth Preferences; it never picks up my devices.

I'm not sure what else to try here. I have a completely vanilla test install of 10.13.3 in addition to my main one & I suspect that a part of my Clover installation may be to blame because it's not working there either, although it has before. I searched Install OS X High Sierra.app with Pacifist for the word 'Bluetooth' and reinstalled every file it found. I did a reinstall on my own through Recovery mode as well.

I tried out BRCMPatchRam2.kext as well as & BRCMFirmwareRepo.kext in S/L/E, but when I run
Code:
cat /var/log/system.log | grep -i brcm[fp]
nothing at ALL shows up in Terminal.

The bluetooth is connected with a 5 pin USB header to USB Mini adapter, and like I said it does show up in the menu bar & System Preferences.

My system is a 4590 running 10.13.3. I'm attaching a copy of my config.plist & IOReg, in case it's of any use..
 

Attachments

  • config + IOReg.zip
    939.4 KB · Views: 67
Top