Contribute
Register

Broadcom DW1820A crashing both Windows and OS X

Joined
May 31, 2019
Messages
13
Motherboard
ASUS Z370-P II
CPU
Intel Core i5-9600K
Graphics
Asus Radeon RX580 8GB OC
Hi Folks,

I built my first working Hackintosh build this summer. It is fully working (absolutely no issues) apart from WiFi/Bluetooth networking. Just to get a few things out of the way:
  • I read through the relevant Broadcom post by RehabMan.
  • The right kexts are in place.
  • My XHCI configuration (the SSDT patch) is in place, fully tested and working.
Now here comes the weird part: as long as I only used OS X, the DW1280A had usually worked perfectly well and both WiFi and Bluetooth were working fine (apart from HandOff/Continuity, if someone knows how to get these to work, do tell me!). However, sometimes when switching between Windows and OS X, a kernel panic would get triggered by the WiFi card, most of the time solved by simply resetting or going to Windows and back again.

However, I had a few crashes a few days ago related to installing a bad kext (my bad). At this time I needed to reset the computer quite a few times. I also updated Lilu at the same time, not sure if this is relevant in any way. Since then, my WiFi card has been going nuts.

In Windows, Bluetooth still seems to work fine using some Lenovo drivers, but the Dell-Broadcom WiFi driver keeps shutting down with the error code 10 (cannot start device) right after booting, and trying to reset it by setting it to Disabled and then Enabled in Device Manager produces a system hang (not even the reset button works on the PC). Also the startup kernel panic in OS X is perpetuated after such an event.

After starting the PC without the DW1820A, both Windows and OS X work fine and then putting the WiFi card back in makes WiFi and Bluetooth in both operating systems work fine again as long as I don't switch between them. However, switching between the two operating systems breaks it again. In fact this has gone as far as to break my Windows installation to the extent where first it would boot to a blue screen of death and then the disk would get corrupted forcing me to repair the disk from an external Windows repair drive and restore to an earlier restore point with no WiFi/Bluetooth drivers in it.

Does anyone suspect what the problem could be? I really enjoyed having working WiFi/Bluetooth in Windows and OS X, so ideally I don't want to scrap the DW1820A - but I'm not putting it back in until I figure out why it started to fail so badly recently. I'm suspecting that something related to the power states of the device is not being set properly on the chip when powering it down, but I have absolutely no experience with firmware. The DW1820A is connected via the adapter that comes with the Gigabyte GC-WB1733D-I in case this helps.

Thanks for any help in advance! :)
 
Top