Contribute
Register

Broadcom BCM94352Z DW1560 with OpenCore + Big Sur

Joined
Oct 6, 2018
Messages
7
Motherboard
Gigabyte GA-Z170N Wifi
CPU
i5-6600K
Graphics
RX 580
Greetings! I have managed to create a fresh install of BS using OpenCore. The main issue I have now is that the Broadcom BCM94352Z DW1560 is not working (no Wi-Fi or Bluetooth). My previous build on this hardware was Clover and it was working well under that config.

So I'm looking for any tips or pointers. Here is a tree listing of my EFI and I've attached the config file. Am I missing anything obvious?

TIA!

Code:
EFI
├── BOOT
│   └── BOOTx64.efi
└── OC
    ├── ACPI
    │   ├── SSDT-EC-USBX.aml
    │   ├── SSDT-EC-USBX.dsl
    │   └── SSDT-PLUG-DRTNIA.aml
    ├── Bootstrap
    │   └── Bootstrap.efi
    ├── config.plist
    ├── Drivers
    │   ├── HfsPlus.efi
    │   ├── OpenCanopy.efi
    │   └── OpenRuntime.efi
    ├── Kexts
    │   ├── AirportBrcmFixup.kext
    │   ├── AppleALC.kext
    │   ├── BrcmBluetoothInjector.kext
    │   ├── BrcmFirmwareData.kext
    │   ├── BrcmPatchRAM3.kext
    │   ├── CpuTscSync.kext
    │   ├── IntelMausi.kext
    │   ├── Lilu.kext
    │   ├── VirtualSMC.kext
    │   └── WhateverGreen.kext
    ├── OpenCore.efi
    ├── Resources
    │   ├── Audio
    │   ├── Font
    │   ├── Image
    │   └── Label
    └── Tools
        ├── CleanNvram.efi
        └── OpenShell.efi
 

Attachments

  • config.plist
    16.3 KB · Views: 50
Joined
Sep 25, 2016
Messages
3
Motherboard
Gigabyte Z170N Gaming 5
CPU
i5-6500K
Graphics
RX 570
I believe you need to disable AirPortBrcm4360, which is now within AirportBRCMfixup.kext. There's a few different ways of disabling this within the plugins folder (deleting it from the folder), or specifying in .plist the max macOS which the kext will load for (20 is Big Sur, 19.9.9 is below this).

Fixed everything for me.

The details are here from folks far smarter than me....

#### Please pay attention
In 11.0 (Big Sur) class AirPortBrcm4360 has been completely removed. Using of injector kext with such class name and matched ```vendor-id:device-id``` blocks
In 11 (Big Sur) class AirPortBrcm4360 has been completely removed. Using of injector kext with such class name and matched ```vendor-id:device-id``` blocks
loading of original airport kext. To address this issue and keep compatibility with older systems injectors for AirPortBrcm4360 and AirPortBrcmNIC were removed
from main Info.plist file. Instead, the two new kext injectors are deployed in PlugIns folder: AirPortBrcm4360_Injector.kext and AirPortBrcmNIC_Injector.kext.
***You have to block (or remove) AirPortBrcm4360_Injector.kext in BigSur.*** In OpenCore you can specify MaxKernel 19.9.9 for AirPortBrcm4360_Injector.kext.
 
Joined
Oct 6, 2018
Messages
7
Motherboard
Gigabyte GA-Z170N Wifi
CPU
i5-6600K
Graphics
RX 580
I believe you need to disable AirPortBrcm4360, which is now within AirportBRCMfixup.kext. There's a few different ways of disabling this within the plugins folder (deleting it from the folder), or specifying in .plist the max macOS which the kext will load for (20 is Big Sur, 19.9.9 is below this).

Fixed everything for me.

Thanks @dsteib2 — I removed the plugin and tried again but still no luck :(. On the bright side, Bluetooth is working!

Your config looks similar to mine. Any chance you could share your EFI so I can compare?

Thanks!
 
Joined
Sep 25, 2016
Messages
3
Motherboard
Gigabyte Z170N Gaming 5
CPU
i5-6500K
Graphics
RX 570
Thanks @dsteib2 — I removed the plugin and tried again but still no luck :(. On the bright side, Bluetooth is working!

Your config looks similar to mine. Any chance you could share your EFI so I can compare?

Thanks!
It's not removing the plugin, it's removing the plugin within the plugin. Maybe you noted that already, but if not... It took me a long time to figure this out. AirportBRCMFixup.kext has both the AirportBrcm4360_injector.kext and AirportBrcmNIC_injector.kext within. By clicking on Show Package Contents you can review and delete out the 4360_injector.kext.

Attached is my config.plist too if that helps.

1607124452129.png
 

Attachments

  • config.plist
    27.2 KB · Views: 86
Joined
Jul 18, 2018
Messages
3
Motherboard
Msi k9 neo
CPU
Intel i7
Graphics
And radeon
Can somebody tell me if somebody get it worked on a x250 laptop with broadcom BCM94352Z?

And if someone made it can he upload his efi please ? I successfully installed big Sur but Wifi don't work with broadcom BCM94352Z
 
Joined
Feb 24, 2013
Messages
38
Motherboard
Gigabyte H370-HD3
CPU
i5-8400
Graphics
570
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hopefully this topic will provide some help.

 
Joined
Oct 6, 2018
Messages
7
Motherboard
Gigabyte GA-Z170N Wifi
CPU
i5-6600K
Graphics
RX 580
Sorry — I haven't had a chance to get back to this and have since discovered problems with VMWare (related to networking on Big Sur) which means I'm staying with Catalina until those are sorted.
 
Top